Personal Website Won't Run Game


I’ve created a website for my game and joined a web service provider to host it. I want it to be playable from the site with Quixe and, as far as I can tell, I have all the files in the right folders. It is playable from within a browser from my hard drive, but it won’t run on the website (it just says "Loading … ").

I read in another thread that some servers don’t recognize the interactive fiction suffixes like “gblorb” or “glulx.”. Could this be the problem? And, if so, what exactly do I need to ask my provider to do to configure their system to recognize the file type? I assume they will have no idea what a “gblorb.” is.



If you use the “release along with a web site” option, Inform generates Javascript files rather than .gblorb. Any server should recognize .js.

Can you look in the browser’s error console for error messages? If not, please post the URL so we can look.

Okay, the website is

If I include “release along with a website,” do I also release with an interpreter?


“Release along with an interpreter” is sufficient. That part is working.

It looks like the file is cut off. It should be 261877 bytes, but the version on your site is only 178281 bytes and ends in the middle of a line.

The version of glkote.min.js that I have is 256,000 bytes. It wasn’t completely uploaded before but, now that it is, the game still won’t play.

How can I access the errors console? Can I get to it through a browser’s menus or maybe using a shortcut key?

Control-Shift-K on Firefox.

Depends on the browser. What are you using?

The file is also cut short. You should probably re-upload everything, and make sure the files are identical on your home machine and on the web server.

Mozilla Firefox is fine. I have three different browsers (Explorer, Firefox, and Chrome). I use whichever one works best with my screen reader, which often depends on what I want to do.

I compared file sizes when I fixed glkote, and Sequitur was indeed truncated. I re-uploaded it then, and it said that the whole file was uploaded. But just checking now, it was the old file size. I needed to delete the old file before re-uploading (even though I had it set for replacing the file, and that had worked for glkote).

Anyway, everything works now. I’ve uploaded it to the archive as well, and I’ll officially announce its release when it is accepted there.

Thanks to you both for your help.