Parchment Crumbling

At 10:45 on Saturday night, IFDB’s Play Online button is producing errors, no matter what game I try. With Galatea, Parchment loading simply stops. With other games, I get:

This happens in both Firefox and Chrome.

[rant]I think the problem with Galatea. is probably with the if-archive or somehow with the file itself; Insight, Weishaupt Scholars, and My Angel are working in parchment, but when I tried downloading the zblorb of Galatea it just failed (“unknown error”).[/rant]

Another Parchment question, though – do save and restore work for z-files anymore? When I save it gives me a new URL, but reloading that URL doesn’t do anything in Firefox or Safari.

It’s not the archive. (I can download pr-if.org/play/galatea, which works.)

I suspect the file translation service that iplayif uses has gone off the rails in some way.

Oh, right – that error is the one I always get when I’m trying to auto-open a download with Gargoyle (instead of saving it and opening it manually).

iplayif.com/?story=http%3A%2F%2F … ;vm=gnusto works
iplayif.com/?story=http%3A%2F%2F … orb;vm=zvm doesn’t

So there’s either a problem with ZVM, or, I suspect the Runner. I’ll get onto it!

Galatea seems to have an assembly error - it has a @read_char with no operands. I’ve updated ZVM to now allow this.

I haven’t found other games to be broken, but if you can pinpoint any which are then please do so.

Try Taco Fiction. It’s still giving me the same error message I reported Saturday night. Some other games do seem to be working.

It’s having trouble downloading from the Archive. It’s supposed to have up to 60 seconds but it’s giving up earlier than that… maybe the Archive is disconnecting for some reason? Any ideas Zarf?

The archive is down at the moment. It was in the last 12 hrs.

Yes. https://intfiction.org/t/ifarchive-outage-on-tuesday-jan-24th/3449/1

Right. Forgot about it.

I had too…
Taco Fiction loads, but there’s a JS error somewhere. I’ll track it down tomorrow.

Wow, there were some very obvious bugs there. I’m amazed they hadn’t been reported before now, no Glulx game would have run!