Odd behaviour from Workbench

I’m running workbench on Windows 10. Ever since the latest windows update, Workbench will change ( seemingly unprompted) the name of the folder ‘webuires’ located in the ‘resources’ folder to this:
“…/…/…/…/…/…/program files (x86)/tads 3/lib/…/…/…/…/…/…/program files (x86)/tads 3/lib/…/…/…/…/…/…/program files (x86)/tads 3/lib/…/…/…/…/…/…/program files (x86)/tads 3/lib/…/…/…/…/…/…/program files (x86)/tads 3/lib/webuires”
I have no idea why it does this. It seems to cause Workbench to crash after a few runs. I can manually open the .t3m in a text editor, and change the name of the folder back to ‘webuires’, after which it works fine, although Workbench changes the name back to the long …/…/… string after a few times and we go through the whole process again.
Does anyone have any idea what might cause this?

I have run into the same problem and can’t figure it out. Did you ever get this resolved?

Yes - and no. In the end, I stopped using my own version of the webuires folder in ‘Resource Files’. Instead, I had to run Workbench as admin, which then allowed me to edit the original webuires folder in the TADS WEBUI directory. Although this solved the folder renaming problem, what it didn’t do, was stop Workbench crashing. It’s so unstable now as to be verging on unuseable.

A couple of things I’m not sure of, is if it works better -

  1. With HTML TADS?
  2. With an older version of Windows?

I’m afraid I don’t have the skills to get to the bottom of what’s happening though. My guess is it has something to do with Windows 10 upgrades, but that’s absolutely just a guess.

Sorry, I run TADS on a Mac, so I don’t have any light on this… How is the Workbench program by the way? Is it an IDE in essence?

Workbench is a very nice IDE. I once tried running it in MacOS in a Windows emulator, and it was about 98% functional; there were a couple of dialog boxes that didn’t redraw correctly.

With respect to the original problem of file naming, I have no clue, but I’ll keep an eye out for it when I switch my project to the WebUI.

1 Like

Is that Windows emulator a purchase product or a free download?

Your search engine is your friend. I haven’t used MacOS for more than 5 years; I have no idea what’s out there.

I have used two commercial products to run virtual Windows on MacOS, Parallels and VMware Fusion. I found that VMware Fusion was the most effective solution. Fusion provided a very good virtual environment. Close to 100% of Windows applications would run properly. I found that swapping to the full Windows environment was most effective rather than running it in a side by side configuration.

Fusion provided upgrades periodically and they frequently cost as much as half the initial purchase price of the app.

I haven’t used it since February. The logic board on my Macbook pro bit the dust and it wasn’t worth the cost of replacement.

Apple has a virtual environment available. I didn’t find it to be as effective as Fusion.


Thanks, I’ll look into those suggestions… I feel like I’ve been managing all right without an IDE, but then, maybe I don’t know what I’m missing :slight_smile: