No input after Questions with Parchment for inform7

Hey there,

currently working on my first text adventure, I ran into a bug when you play the game within a browser using the parchment parser.

The part in which the error occurs is:

Calling is an action applying to one topic.

Understand "call [text]" as calling.
Carry out calling:
	if the topic understood matches "Melissa" and the player is carrying the smartphone:
		clear the screen;
		say "You are calling Melissa … she replies 'hey darling. are you fine?'";
		say paragraph break;
		if player consents:
		 	say "really???";
			 say paragraph break;
			say "oh i see!";

The code works fine in any client. But not in a browser. If you call Melissa, the question appears but the input is gone, so no answer could be given.

any idea?

I compiled the story and tried both Z-machine and Glulx versions and both work fine for me. The only issue is that the Z-machine version doesn’t show the caret at first, but it does accept input.

Note that “if player consents” doesn’t automatically show the > prompt, you’ll have to print that manually if you want it.

I manually updated the parchment parser for Inform and now it works and shows the >.

Before it even did not accept the input.