Nethack 3.6.0

New version’s up.


This was in production longer than Duke Nukem Forever.

I dunno if I can go back to this after being spoiled by DCSS.

Oh wow, my dad and I used to play this in the early 90s when I was a kid. I had no idea anyone was still working on it. I might have to go and lay waste to some newts for old time’s sake :slight_smile:

You gotta be kidding, right? :slight_smile:

I like the Terry Pratchett bit. :slight_smile:

The timing’s funny. I’d recently rediscovered NetHack (and Slash’Em) because I got them for my iPod.

Incredibly complex old-school roguelike with permadeath on a desktop? Eeeeh, I’ll pass. Haven’t the time.
Incredibly complex old-school roguelike with permadeath on a mobile device? GIMME GIMME GIMME!

I wish ADOM were available for the iOS, too. For me, Nethack was all very well and good, but back in the day it was ADOM that I played over and over and over again.

…aaaaaannnnd it crashes on opening. It’s Brogue rather than DCSS that has spoiled me for NetHack except for

those goddamn confusion traps–having a monster walk on a confusion trap and then continue to walk over it is an absolutely soul-deadening experience–I’m pretty sure that I’ve read that it’s basic game design not to suddenly steal the player’s agency

but I would’ve taken it for a spin for old time’s sake. However it seems to be not necessarily ready for prime time.

That’s odd; mine didn’t. But I was playing in tiles.

I’m using a Mac–I don’t seem to have a tile set available, at least not from the main page.

No crash here.

A few thoughts on DCSS vs. Nethack (pre-new-release):

Yea, all of the points made are reasons why I prefer DCSS now, hah

Are you using the NetHackTerm application? I downloaded the package, ran the installer, and when I open the application I get “Illegal instruction: 4”. I just manually cd’ed to the usr/local/bin directory in the Terminal, typed “nethack”, and still got “Illegal instruction: 4”. So something isn’t working.

I just never got into DCSS because of all the time I spent running around pillars. And I’m thoroughly spoiled on nethack so that’s not an issue. And Brogue is soooooo smooooth, when not running into the problem I complained about in the other post. Though these days I seem to scratch my roguelike itch with Realmspeak, which is a java implementation of a boardgame I had way back in the day (and have retrieved and placed in the attic, but it’s a lot quicker to play on the computer).

…bringing it back Connections-style to interactive fiction, my twinyjam entry was a fanfic for that last game.

Magic Realm, right? I’ve been reading about that lately. I don’t see any real way of giving it a try (with the physical version), but I’m very curious about it.


Well, Caleb, assuming you’re not in Burlington VT, I guess you could go download the Java version anyway. It’s actually designed for remote multiplayer so maybe I could walk you through a game–though I’ve never tried to do it multiplayer and me trying to do that kind of thing seems like it has the potential to end poorly.

Where have you been reading about it? It is a fascinating game but it has a pretty steep learning curve (as in, it took me about twenty-five years to really get into).

As for nethack, the dev team sent me a nice note explaining that they had just put up a new binary after my bug report… still doesn’t work though. I can probably chalk this up to my computer being tetchy.

Not in Vermont at the moment, sadly. (Though I did grow up there, and miss it quite a lot!) I play a lot of board games in general–I run a once a month game program at the library where I work–and in the last year or so I started seeing articles about Magic Realm, mainly on boardgamegeek. It sounds like a complex but very engaging system that made a big impression on a lot of people. I’m going to take a look at Realmspeak now.

Someone else who plays Brogue!!

Brogue is pretty fun.

My top three roguelikes are ADOM, ToME and Incursion though.

Nope, I’m using the Windows version.