Most-wanted updates

I can get Quip-Based Conversation to compile; do you have version 5 of Quip-Based Conversation, and version 10 of Reactable Quips? (If not, I can try to find them, though I might not have much time today.) … index.html … index.html


It could be that the problem is in Reactable Quips and not in Quip-based conversation. I don’t know.

Hmm, I tried the examples in those extensions and they compiled, though I did get a run-time error for one of the Reactable Quips examples. But I haven’t checked to see that my versions are exactly the same. Have you tried compiling the examples?

Weird. Yes, I’ve tried those. My I7 version is 6M62.

Problem. In ‘Table of Ask Results’ , column 1 (NPC), the entry ‘guard’ (row 2) is a genuine, non-blank entry: it’s a specific value. That’s fine, of course - the whole idea of a table is to contain values - but this is a column which already contains a name of a kind: ‘a person’ .

Ummm maybe the extension was badly imported and the tabs and rows are wrongly spaced? hmmm

Did you by any chance copy-paste the extension code from the documentation instead of hitting the “import” button next to the extension title? I think copy-pasting tends to mess the tabs up.

That said, that example was the one where I got the run-time errors (which I haven’t been able to track down).

Nop. I’ve downloaded the extensions from those urls, then installed with Inform 7 installation process. Then use the button to automatically copypaste the examples in the editor.

OK, I’ve figured it out! The confusion wasn’t your fault at all–I had hacked my versions of the extensions to compile, and I didn’t update the version number. The background is here; Inform changed the way it handled blank table columns, so you need to take the tables that are defined with a kind name in the top row and move them to the heading.

Unfortunately while testing this I downloaded the versions of the extensions from the website and they overwrote my working versions. Also unfortunately, Michael updated the extensions himself, but they were uploaded on his personal website which is now gone. But there may be some people who have the extension and could upload a working version (you could try PMing paulobrian or Joey Jones).

Ok, yes, it works!

The solution is simple enough, please, upload a new version to the extensions library with the fix. I think this library is the perfect middle ground between Hybrid Choices and Threaded Conversation, so it is important that authors have access to this standard way o implement conversations.

Thanks! You saved my comp entry!

Ruber Eaglenest.

Glad to hear it works!

Now that you’ve got a working version, can you attach it to a post here? As I said, I broke my copy of the extension. If you post using the Full Editor you can attach files using “Upload attachment” at the bottom of the post. (The process is a bit convoluted; you have to hit “Browse” and then you also have to hit “Add the file.”) I could probably get them onto the new extensions library. The one on is mostly for extensions that go with older versions of Inform.

Or if anyone has a working e-mail for Michael Martin we could try to get his fully updated extensions. Or if anyone has the updated extensions.

Ok, this is the one that needed the update. I’ve updated it to version 11, just to fix the table thingy. Added a note, but my english is not perfect, maybe you want to review it before uploading to the official server.

Reactable Quips.i7x (19.2 KB)

Thanks so much! I’ll look at it and see if I can upload it to the library. And if anyone has Michael Martin’s official updated versions, that’d be great too.

I’d be happy to get any updated versions into the Public Library.

Right now I’m having a weird issue with one of the updated examples in Reactable Quips. I guess I can see if I can hunt up Michael’s version.

What issue?

I had to cut some logic when I was building the game in Spanish, so I thought the library was not working 100% with the Spanish extension. Maybe the issue was there in the original all the time…

In “Security Consultant,” the commands “guard, sesame” and “guard, password” give a run-time error about an invalid snippet:

Somehow the “topic understood” is getting broken, and I can’t figure out why.

This shouldn’t be a problem if you’re using Quip-Based Conversation, because Quip-Based Conversation blocks “answering it that” commands without trying to consult the topic understood.

This happens even on a minimal implementation:

[code]Include Reactable Quips by Michael Martin.

The Vault is a room. The guard is a man in the Vault.

test me with “actions/guard, sesame”.[/code]

The thing is that the answering that action works fine when the command is entered in the form “answer sesame to the guard,” which means that the error probably has something to do with the way the parser converts “guard, sesame” into an answering it that action. Which means looking at the parser. Which means a massive headache.

1 Like

OK, I’ve tracked down the source of the error. It comes from this line:

Responding with is an action applying to one number. Understand "[number]" or "say [number]" as responding with when RQ is active.

The issue is that, when you have an Understand line with “[number]”, it makes the topic understood go wrong when processing commands of the form “NPC, TEXT THAT’S NOT A VERB.” As can be seen with this minimal case:

You can see a guard here.

test me

[1] answer sesame to guard
The guard doesn’t seem to understand “sesame.”

[2] guard, sesame
The guard doesn’t seem to understand "
*** Run-time problem P39: Attempt to say a snippet value which is currently invalid: words 0 to 3.


[3] actions
Actions listing on.

[4] answer sesame to guard
[answering the guard that “sesame”]
The guard doesn’t seem to understand “sesame.”
[answering the guard that “sesame” - failed]

[5] guard, sesame
[answering the guard that "
[** Programming error: tried to read from -->-1 in the array “parse”, which has entries 0 up to 60 **]
guard , sesame"]
The guard doesn’t seem to understand "
*** Run-time problem P39: Attempt to say a snippet value which is currently invalid: words 0 to 3.

[answering the guard that "
[** Programming error: tried to read from -->-1 in the array “parse”, which has entries 0 up to 60 **]
guard , sesame" - failed][/code]

Anyhow, that definitely shouldn’t happen, so I filed a bug report. And again, if you’re using Quip-Based Conversation, it probably won’t affect you, because Quip-Based Conversation intercepts answering that actions in order to tell the player to type “TALK TO NPC,” without printing the topic understood.

I’m not sure if people are still watching this thread or not, but I figured that this seemed like the appropriate place for what I wanted to say:

I’ve gone ahead and updated Plugs and Sockets by Sean Turner for use in my own story, modifying any Plurality statements and any other bugs that I’ve found when trying to run a game with it included. I’m happy to release it if that’s allowed and if it’s something people are interested in.

Hey, @Scott, welcome to the forum!
Replying to a thread bumps it to the top of the “latest” list so people will definitely see it.

I’m unsure if the public library would accept an update by someone who is not the original author, but there are also repositories for “experimental” releases and mods to extensions where people might find it useful. Check out the “Friends of I7” Github.

It seems like it should be updated though, as @emshort’s “Power Sources” depends on it.

Each official extension should have its own auto-generated thread on here:

Ah! I wish I’d known about Friends of I7 sooner - it seems that Plugs and Sockets has already been modified in exactly the same way there!

1 Like