Making Hyperlink Interface work

Hi! I’ve been trying to make Hyperlink Interface by Leonardo Boselli work for ages now but it hasn’t been updated Can anyone help? Here is the problem I’m having currently:

What other extensions are you including? It sounds like something else is also trying to handle hyperlinks and the two are coming into conflict.

Oh, whoops, it was probably an exit lister I have installed. With that off, it gives me these errors:

I’m guessing this is an extension from 6G60?

I think so, yeah.

Sorry for the late response!

Can anyone help?

I’m afraid I let this thread go cold because I have had a hell of a time at work lately and haven’t been online much.

So I’m seeing two main problems.
1 - some of the definitions are conflicting with the exit lister in Small Kindnesses
2 - general 6G60 -> 6L** update issues, like “change X to Y” needing to be “now X is Y”

I’ll see if I can look at the extension again later today.

Cool, thanks. Had any luck with it?

I don’t suppose anyone has had any luck getting this working? I’ve quoted out the exit lister and replaced all the instances of “change” with “now”. The errors I’m now getting are:

This looks like you tried to mess with all the responses in Hyperlink Interface (by way of translating them to Italian) before including Hyperlink Interface itself. Therefore, I7 had no idea you were trying to talk about responses in your translation extension, but did its best to create a bunch of objects instead, since that was what it knew how to do that was most syntactically similar to what you wrote. Why it says that some of them are trying to create objects with parentheses in their names, while a few are merely trying to say that things are values, I have no idea. I suspect it has to do with the particular letter in the parentheses; it seems to be okay with F, M, or N, but other letters are bad. This is probably a bug; all letters should be bad. I have no idea what is special about F, M, or N.

And then it got even more confused when it got to the actual extension and those nonsensical objects conflicted with things the extension was trying to create, in particular the hyperlink emphasis kind. The hint that clued me in is the problem message:

(emphasis added) It’s not kidding about confusion between names. Put Hyperlink Interface before Hyperlink Interface IT, so that I7 knows what you’re talking about.

Italian? :open_mouth: Oh damn, I have no idea why, but for some reason I thought I was supposed to include Hyperlink IT. :mrgreen: Really sorry about that, I can’t explain why I thought that at all. I’m definitely not intending to make this in Italian, just to clarify. :laughing: Ok, without the Italian file, the error text turns to this much shorter version:

…I feel like a complete jerk for not looking this up before, but did you get this version of the extension? The 6L-compatible versions of extensions that are on the “old” extension site but not in the Public Library tend to be on the I7 github. This looks like it should solve the problem.

We really need to do a better job of making this clear.

Anyway, for the record, and for future updating purposes:

In a couple of places you had “change… to…” and you changed “change” to “now” but didn’t change “to” to “is.”
In the latest I7 you have to write “when latest parser error is…,” I guess to enable clarification between the kind “command parser error” and the global variable “latest parser error.”
Not sure exactly why the other two worked before and not now.

Oh? No, I wasn’t using that version. It’s been a while, but I’m pretty sure I got it off a code base though. The extensions are a bit misleading, but it really isn’t your fault, so don’t worry about it. :laughing: I tried that new version you linked to just now and I am still getting a couple of errors, but not as many:

The Table of User Styles is defined by the standard rules, but it has a different schema depending on whether the project is compiled for Z8 or Glulx. This looks like you’re compiling your project for Z8. Hyperlink Interface includes Glulx Text Effects by Emily Short, which indicates that it will probably not work in Z8. Check your project settings to make sure you have Glulx chosen.

Z Machine? That’s really weird because I’m definitely using Glulx. I just double checked, and that is the option selected in settings. I’m also already using Glulx Text Effects by Emily Short!

I just tried to compile the interface on its own with Glulx with just a blank room and I got this:

[code]In Chapter - Hyperlink Types, Section - Glulx Style Definitions in the extension Hyperlink Interface by Leonardo Boselli:

Problem. The table ‘Table of User Styles (continued)’ won’t work as a continuation, because it contains columns not found in the original ‘Table of User Styles’ .

The old table has columns: style name, background color, color, first line indentation, fixed width, font weight, indentation, italic, justification, relative size, reversed.

The new table has columns: style name, fixed width, boldness, relative size, glulx color.

Problem. It looks as if ‘Table of Common Color Values (continued)’ is meant to be related to an existing table, but I can’t find one if it is.

Perhaps you’ve put the new part before the original? The original has to be earlier in the source text.[/code]

That looks like an old version of the extension (or the new version of the extension with an old version of Inform).

This might be of help: … xt-effects

[rant=incorrect; see bg’s comment below]So, in line with the link bg just gave, it looks like you should check to make sure you have the most current version of Glulx Text Effects.[/rant]

In the link I gave, it was the other extension that needed to be updated, not Glulx Text Effects. Glulx Text effects got a major rewrite, so other extensions needed to be updated in order to be compatible with it.