Logo loading before the game

I have noticed that several adventures that have been made in Inform 7 have logo images that begin before you start. Is this something that is easily achieved or is there a lot involved?

1 Like

Easy. See chapter 25.8, “Cover art”. Or I guess that’s 23.8 if you still have the old release.

1 Like

Perfect! Thanks. I just wasn’t sure how to word what this was.

To demonstrate my commitment to making a post-comp release of my ShuffleComp title, I’ve put together some cover artwork to include with a future version. It’s in the game’s Materials folder, named precisely after the examples in the documentation: Cover.png and Small Cover.png.

And yet…

Problem. A problem occurred with the ‘Release along with…’: instructions (‘Release along with cover art’ ): The release instructions said that there is a cover image to attach to the story file, but I was unable to find it, having looked for both ‘Cover.png’ and ‘Cover.jpg’ in the ‘Materials’ folder for this project (with the file ‘C:\Users\user\Documents\Inform\Projects[game name]\Cover.png’)

(And now I have erased the rest of my message, replacing it with the solution to Windows users who may find themselves in the same boat as me: the Windows filesystem is playing around with me, allowing me to think that I’m giving my files file extensions when I save them; based on what I told it to do and what I was seeing in Windows Explorer, I reasonably thought that I had a file named Cover.png, but in the computer’s secret heart of hearts, the file was actually named Cover.png.png … so to make it Inform-findable, I had to rename Cover.png just to Cover … what a pain.

It might be a worthwhile, albeit low-priority, idea in future versions (unless already supported, I have no idea) to make a small (and I understand extraordinary given the context) nod to GUI interface by allowing cover art to be selectable from a directory-listing window such as one might see when using the ‘Save as’ option on a project.)

1 Like

“Hide extensions of known file types” is an evil, terrible misfeature, and I always turn it off the instant I get a new computer that inexplicably has it on. Glad you were able to figure it out though!

The sad thing is, someone probably got a good bonus for that “feature”.

If you need another reason not to hide file extensions, remember that that feature can make a dangerous file look safe (e.g. ILOVEYOU.TXT.vbs looks like text but is actually executable VBScript).