Linux/Ubuntu Support needed for Inform 7

Hi guys,

I just installed the latest version of Ubuntu 11.04 with the freshest and latest drivers. Well, it seems that the newest GTK drivers for web-applications are not compatible with the latest version of Inform 7. When I try to install the gnome-inform7_6G60-0ubuntu2_amd64.deb package the I get the following error:

The following precondition is not fulfilable =>
libwebkitgtk-1.0-0 (>= 1.3.10) -1.0-0 (>= 1.3.10)

If I try to install the libwebkitgtk-1.0-0 (>= 1.3.10) I need to download other packages which would destroy the current sub-packages of the standard Webkit. I don’t want to screw my working system.

Does anybody know a workaround? Maybe just a precondition needs to be rewritten somewhere in the deb package?

Big thanks

Hmm that’s strange. I’m on the same OS as you at work and Inform7 works fine aside from a couple of minor things. Then again, this isn’t a fresh install… it’s been updated a few times since Ubuntu 9 something.

Sorry I don’t have any ideas for a fix at the moment. :neutral_face:

Found the error. It seems that I screwed up the migration from maverick to natty. Damn it.

Funny enough I got help texts for natty, but core components where still maverick. Now, I moved to oneiric, that is 11.10, and Inform 7 works.

Thanks anyway

Gnome-Inform 7 is going to need to be updated (again) regarding its GTK/Webkit dependencies for 12.04. It’s not finding icons correctly and seems to be crashing when you tell it to run the game from within the IDE.

Yeah, it hasn’t been very stable for me in Gnome lately.

I got the crashes too, but it was quite usable (ubuntu 12.04). Until a recent system update it was working, but now I can’t even open a project with it. I tried to compile from sources (both the development version and the 6G60, but both tell me:

[code]configure: error: Package requirements (
gdk-2.0 >= 2.2
glib-2.0 >= 2.16
gtk±2.0 >= 2.20
gio-2.0 >= 2.18
gconf-2.0 >= 2.4
gtksourceview-2.0 >= 2.2
webkit-1.0 >= 1.0
) were not met:

No package ‘gconf-2.0’ found

Yet I have uuid-dev, libgtksourceview3, libwebkit 1.1 etc

It’s a fiddly time getting all those dependencies installed.

I was trying to compile gnome-inform7 out of trunk, to see if a particularly inconvenient crash bug that only appears when Custom Library Messages is included (which puts a line break in the status bar and crashes the gnome-inform7 built-in 'terp) was fixed. This was on a 32-bit 12.04 machine.

In my case, even after getting the -dev dependencies listed above installed (yes, you need the *-dev versions of the packages, not the normal runtime ones), the compilation failed with a -Werror about a format string not really being a string literal. Even after editing the makefiles to remove that particular check and the -Werror flags, it still kept hanging up there, so I gave up and went back to the more constructive task of working on my story, and hacked a work-around into the Custom Library Messages extension, kindly suggested by EmacsUser on the Inform7 mantis. :stuck_out_tongue:

I too am running a 12.04 system (albeit 32-bit PAE XUbuntu with a bare openbox session), and am having no problems (other than normal bugs). In any case, considering that it’s working here, I would be more inclined to suspect some sort of weirdness with your system rather than a critically broken package, and posit that even if you can get it to compile, you might find that you’ve spent a good deal of time and not solved anything.

Perhaps the package is missing a dependency that you need to install by hand (just a silly guess! I would’ve thought that the debian build scripts would have automatically used ldd to pull in the appropriate dependencies). Perhaps some elucidation can be gained running it on the commandline, and seeing if it complains about a missing library or something else that might point you in the direction of what the problem could be.

Perhaps also try creating a new project and copying your source and resources over to it. I have read that newer releases sometimes break compatibility with older project files.

I don’t really know what I am doing most of the time, but I hope that helps!

If for some reason it explicitly wants gconf-2.0 instead of the one you have, you could always try to symlink to gconf2.whatever and call it gconf-2.0.

However, “gconf” is actually a Gnome config. Inform7 “runs in Gnome” so to speak on Ubuntu. Perhaps Inform looks for something specific in gconf version 2.0? Then the only resolution would be to wait for an Inform update/fix or posibly revert your gconf somehow.

Sorry I can’t help more, but I’ve rarely got free time at an updated Ubuntu machine lately and my server is running an older distro.

I found the cause of the error: I made a symbolic link pointing from ~/Extensions/Name/Extension.i7x to some extensions on my system. When I link only the file (in the folder), it crashes Inform7 with

ERROR: app.c:875:rebuild_extensions_menu: assertion failed

When I link the whole “Name” folder, it works.

Hm. That’s worth a bug report. I use symlinks-to-extension files as a part of my normal workflow. (The Mac IDE is fine with it.)

I compile with Ubuntu on the command line, not with the IDE, and I have symlinks all over the place and haven’t had any problems. It’s also way more efficient than using the IDE, YMMV.