Lectrote 1.0

Not much changed, but I’m calling it 1.0 and past beta.

I added .blb/.blorb to the Mac file associations.


The README now has some instructions on packaging Lectrote with a game file to make a standalone app.

You can add new windows and features, as I’m doing with Hadean Lands. However, I don’t have docs on that part. You’ll have to trawl through the source code. Sorry.

You can package a Windows app on Mac, but you can’t build a Mac app on Windows. Sorry again – the Mac packaging process relies on some Mac dev tools that aren’t multiplatform.

I was thinking of adding Lectrote to the Interpreter page at IFWiki. Would it be correct to put it in the Windows, Mac OS X, and Linux rows of the table (in the Glulx column)? Is there anywhere else it should go?

Just those three.


I just went to Lectrote 1.0.3 from 1.0.1.

Two games I was playing before (Six, Leadlight Gamma), and which were essentially running, now gave the message

‘Quixe init: TypeError: Cannot read property ‘width’ of undefined Cannot read property ‘width’ of undefined TypeError’

in the status bar when I opened them. I wondered if this might be a caching thing, so I searched my library and threw away all Lectrote files. Then I tried both games again.

At this point, Six ran, and was resumable as well. Leadlight started to run, but on the second screen it hung with the TypeError message again.


Okay, that’s not great.

These are both games with graphics, and I suspect that’s the connection. I don’t have Leadlight, however.

If anybody has a test case that demonstrates the problem, that would help.

I’ll do some more poking around with the situation myself when I get the chance. This week’s had both A New Job plus Being In Hospital.


I’m trying to construct a simple Flexible Windows test case:

Include Flexible Windows by Jon Ingold.

The pic-window is a graphics g-window spawned by the main-window.

Window-drawing rule for the pic-window:
	rule fails.

When play begins:
	[say "Graphics window open.";]
	open up the pic-window.
The Kitchen is a room.

(Compiled with Flexible Windows 14/140419 under 6G60.)

This produces the quoted error in Lectrote 1.0.3… and also 1.0.1… and it crashes in the 6G60 IDE as well. So that doesn’t really narrow down the problem at all.

Are you sure those games worked under Lectrote 1.0.1?

I’ve posted Lectrote 1.0.4, which should fix the problem.


I screwed up while doing the “retina-resolution Counterfeit Monkey graphics” fix, so in fact the bug is present in Lectrote 1.0.1 through 1.0.3.

(Let me know if it works. I need to do another GlkOte/Quixe release once I’m sure.)

And 1.0.5, which adds “Find” and “Full Screen” menu options.

And 1.0.6, which adds an “Other Font” option to the preferences dialog.