Labyrinth of Loci for Mac

I was excited to see that Labyrinth of Loci got a download link for a Mac app for those of us who aren’t able to play the Windows version. Unfortunately, though, every time I try to download the Mac app, I wind up with a file that my computer refuses to open, with an error message saying that the app is broken or corrupted.

Has anyone else been successful getting this to run on a Mac?

I’m running OS 10.11, in case that is relevant.

It ran for me without problems. I’m on El Capitan 10.11.4.

I haven’t tried Labyrinth of Loci, but that sounds like the message a Mac gives when there’s something wrong with the security certificate, not necessarily when there’s anything wrong with the file. (It’s very high-handed and Apple-like that they say “The file is damaged byyyyye” rather than “Something is messed up with the security certificate and we don’t want you to open this,” but oh well.)

If you change your security preferences to allow opening Apps from anywhere these messages go away–at least on my settings, when I try to open a new app it gives me a warning about where it was downloaded from and lets me do it. Of course there’s the risk that the app isn’t actually safe! Though I’m not sure that I think the risk is that much less for the apps that Apple wants to let through.

Oh, and at some point (possibly after a system update) my preferences that let me open apps from anywhere got reset to keep me from opening apps again, and I had to change them back.

Anyway, apologies if that isn’t the problem, but the error you described does sound like Apple being sniffy about a security certificate rather than anything wrong with the app itself.

It’s not the same as the “unknown developer” message (and if I try to force-open it the way I would to get around an unknown dev issue, it doesn’t work). So… hm.

I got the same response when I tried it.

The “unknown developer” message means the app is unsigned. This is not that – I think “broken or corrupted” implies the signature is present but wrong. (Which does merit some harsh treatment from the OS, I think.)

I’ve run into this for apps distributed in .zip files. But not all apps distributed in .zip files; I don’t understand the situation entirely.

Wait, I see the problem.

When you unpack it, you get a directory “” which is not actually a Mac app bundle. It’s a regular directory which contains an app bundle. Just rename it to remove the “.app” suffix and open the directory.

The OS was freaking out because it looked like an app which was missing not just the signature, but the entire standard app structure.

(The app inside is unsigned, so you have to do the manual-open trick, but this succeeds.) (The manual-open trick, for those who don’t know, is to right-click and select “Open” rather than just double-clicking.)

Aha! And that does it, thanks!