Josh Grams's's 2022 IFComp ramblings

Tried three in a row that…weren’t my thing right now: time to call it a weekend.

  • Lost at the Market: tried largely because it was Gruescript. It’s intentionally surreal but also the text is just off enough that I couldn’t tell if some of it was accidental or intentional rejection of traditional punctuation etc. Didn’t grab me enough to try to push through and form an opinion, personally. And the nouns and verbs keep switching around which, again, is it underimplementation? Or intentional surrealism? If surrealism is even the right term. I think it’s supposed to be an interactive poetry/dream sequence kind of thing, so if that’s your jam…

  • The Thick Table Tavern: Had a looong opening sequence with a disembodied voice being generally ominous and mysterious while also demanding your name etc., which was entertaining to argue with but a LOT of clicking (you could probably short-circuit this by being cooperative, but who does that?), then a full-screen close-up animation of beer sloshing which almost made me dizzy, so watch out if you get motion sickness, and then an introduction which badly needed copyediting/line edits and was also verging on purple prose, so I quit before I got to the bartending part. But I am curious about that, so I’ll probably go back to this when I have more energy for it.

  • Arborea: this dumps a lot of disconnected info on you up front but with no real hook? And it’s weirdly cued, or not cued? Unless you type help you don’t know what you’re even supposed to do to get untrapped from the first room (I guess if you just try all the directions you’d find it, but…). Then there are eight directions all with tree themes but no clear reason to choose one over the others. I came to a blind monk who’s giving me tea with sugar and the game is giving me unsubtle “hints” that I want to trick him into giving me a (rock-hard?) sugar cube without dissolving it in the tea, but I have no idea why, or who I am, or what I’m doing here, or why I should care about any of this? So I stopped. The individual elements did seem intriguing, so I’ll likely come back to this one as well.


Thank you for trying TTTT out!
There is an option in the settings to remove animation (text and otherwise). The links are also key-binded if you prefert to use a keyboard instead of clicking.
If you just want to mix some drinks (the purple prose comment is very fair, I tend to over-write a lot), you might want to check the Arcade mode instead :slight_smile: (no pressure obviously).


Right, I saw the animations setting, which is awesome: it’s clear you’ve put a lot of work into this. But I think you can’t turn it off until after you’re greeted by this (where the whole background is lurching around like a ship in a storm)?

Oh, I didn’t notice the key bindings. And I usually check for that, too. Excellent.

And I forgot about Arcade mode, yeah. But I’ll probably go back for the story: I was curious to see where it went, but my brain was too much in editor mode to enjoy it this evening.


Ah yep yep yep. The beer wave at the first go without setting was probably not the best way to start. I’ll either change the default setting for the annimation or make that first background static only.

I’ll be the first to admit the story mode is a chunky one, so if you can’t get back in the story at all, that is no problem at all :slight_smile: (still mind blown about the pruple prose comment, it is so on point for this story…)


Thank you so much for the review! I loved hearing the story read out loud. I wasn’t a huge fan of Papers, Please, but now I definitely see the resemblance; maybe it was a subconscious influence? Also, you’re right that the letters in the sample IDs have a significance (it’s explained in the walkthrough which I just uploaded).


Ohhh. I bounced off Papers, Please fairly early so that didn’t even cross my mind: I wasn’t thinking of it as an influence, but as a reference point for readers, as a well-known example of intentionally putting a positive-feedback death spiral at the center of a game.

And while I’m on that topic, Kathryn Li’s Goat Game from last year also feels somewhat similar to me, though that’s much more focused on the ethics of scientific research. But sci-fi, player character in a somewhat crushing situation, etc.

digression on Lucas Pope

I tend to think of Lucas Pope not as someone who’s unusually creative but as someone who goes hard on looking for unusual places to put mechanics or technology.

Papers, Please: What if we took all these “don’t do that” kinds of mechanics and found a game to build around them where they’re thematically appropriate? Positive-feedback death spiral, dumping tons of rules on the player and not giving them time to learn them, putting too much stuff in a small space so you have to overlap them and can’t find the ones you need, etc.

Obra Dinn: lots of people think those logic grid puzzles are boring, or tedious, or kid stuff (for the record, I loved these as a kid). But what if the clues were implicit in a 3D first-person mystery game? Also: what if we took a one-bit (black-and-white) display, and used edge detection and fancy dithering to do a real-time 3D display that’s so incredibly computationally intensive that it would have been completely unimaginable on the kind of hardware that would have had this sort of display? (which is actually the reason I’ve never quite brought myself to buy Obra Dinn: as a programmer who grew up with some of that hardware, it feels so jarringly viscerally wrong that I had a really hard time getting into it when I watched people playing the beginning…)

spoilers for Archivist and Revolution

Also, huh. I definitely didn’t realize there was that direct of a connection between the letters on the DNA samples and their classifications. The game tells you about the X ones, and when the R ones are introduced I noticed that they were about the revolutionaries. But I think the first few you encounter (W, S, F) that starting out with two or three or four different letters, and then only decoding a few of them, I hadn’t picked up on that (other than Science, as I said in a previous post).


I loved them as a kid too. My friend Melvin even implemented a generator of these logic grid puzzles. Once you get the conceit they’re no longer challenging, or rather, the challenge is in working out facts implicit in the way the clues are stated. Obra Dinn does a great job of taking the fun step of the puzzle and expanding it into a full scenario.



OK, I went back and worked through this. I figured out a few more things by myself but mostly went back and forth between trying a bunch of things and then giving up and going back to paging through the walkthrough.

I think… if you’re a big fan of oldschool parser puzzle-quests and the moon logic (?) of the old point-and-click adventures, you might really enjoy this one? Otherwise it might be a little much. Though it does have a good walkthrough: it’s written in prose, it’s not just a list of commands, so it’s fairly easy to jump around and find a particular thing you’re looking to do and then backtrack to find out what you missed. And at the start of each section it tells you what objects you need and usually where they’re from. Well done.

But it’s a lot. There are eight separate tree-themed areas in the eight directions from the forest hub where you start. Each of them has several rooms, and the puzzles interlock across them, so it’s a puzzle to even figure out where you can start, and then where you can next make progress. I didn’t map out the puzzle dependencies so I’m probably wrong about this, but… I don’t think it’s completely linear but it felt close to it? Like sometimes you could progress in multiple places but mostly you were trying to find the one or two rooms out of this whole sprawling map where you could now do the next thing. I found that frustrating, but if you like making maps and taking notes and keeping track of which obstacles are still waiting to be solved, this might be right up your alley.

And the writing exacerbated this for me. It wasn’t bad (in fact it was pretty good), but it felt like a bit of a mismatch for how puzzly this game is. If you compare to–well, let’s take an example from this comp–Arthur DiBianca’s Trouble in Sector 471, the writing there is very concise: you know (or at least strongly suspect) that anything there has a use. In Arborea, it’s much more telling a story and placing you in these 8 worlds. But that meant I was, say, struggling to interpret that one sentence in the middle of the second paragraph that describes the area and figure out what the exit directions were. So that question of “is this here for story and place, or is this a mechanical clue?” on top of the “which of these twenty-some locations am I supposed to use this thing on?” was a little much for me.

And then the verbs were an odd mix of feeling a little under-implemented for common synonyms (you can’t pick fig, you have to take fig) and then a lot of specific custom verbs for specific puzzles (boldly go south!?). The custom ones were usually cued in the text, but missing some more basic synonyms had sort of a chilling effect and made me less likely to try unusual commands like that. And there were a bunch of places where you had to disambiguate between objects with similar names, where I feel like a more experienced author would have designed around it.

So yeah. I have mixed feelings about this. Ugh, and according to the review spreadsheet this is the first mention of it, too, so I don’t want to be too negative. Because it’s definitely worth a try if you like big puzzly games. And again, it does have an excellent walkthrough if you want to play tourist, or if you want help for a specific puzzle. And the writing is pretty good. But it’s a very ambitious project from a first-time author, and it feels like the design is a little conflicted. And though it lists four playtesters, all of whose names I recognize, it still feels like it could have used a little more playtesting or more time in the oven (e.g. put the x trees output directly into the forest hub room description, please!).

And I bet there are plenty of people here whose playstyles will click with this game a lot better than mine did.

Edit: I actually kept a transcript on this one, so I went back and edited a bunch of comments into it, with the usual >; format… (54.1 KB)


Hi Josh,

Many thanks for your review. I mean, you know, I get that it wasn’t quite for you, but I really appreciate you sticking with it and the effort you’ve put into the review, and I’ll definitely look through the transcript.

All the best



Thick Table Tavern

Went back and finished this one too. Hmm. It didn’t feel like there was as much story as I would have liked, but looking at Mike’s review I think I just got really unlucky: I only saw a single patron event (the fortunteller) so there were just the daily bits of banter with your boss and coworker, which felt like light variations on the same thing, pretty much. I didn’t even realize there was supposed to be a second coworker, a chef? I did get one event with more rushes than usual where someone came in and cooked tons of food but that was the only time I ever saw that character, though he had been vaguely mentioned once before, so I thought he was just some random crazy relative of the boss or something.

I also think I probably hit a bug at the end: I didn’t track and add up what I was making but I’m sure I was well over 300, and I thought we were counting up my money to make sure, but when I clicked to continue it blipped to some other guy buying the tavern with no transition text or description.

And the drink-mixing minigame was fun at first but there’s not actually that much there: just read the recipe, click the things, go. I don’t do alcohol at all, ever (I think it all tastes awful and I’ve always found it to make people excruciatingly boring, even just at having-a-drink-or-two-with-dinner levels) so I didn’t have any reference for what the drinks or the ingredients were, but even so I didn’t have any trouble. Even on hard, the timer is pretty generous: I rarely needed more than half the time. Except for the single-ingredient drinks: then it flies by. But that was on a second partial playthrough so I remembered what most of them were anyway.

It’s very pretty, but on closer look not quite as polished as it seems. The longest recipes overflow the box and you can pretty much see enough of the last line to know what it says but I generally scrolled down anyway to be sure. The name of the drink isn’t anywhere on the actual drink mixing screen, I think? The different glass shapes and color changes when you add an ingredient are fun, but the color changes, at least, seem to be random: I made the same drink three times in one batch once and they were all different. I guess it serves to let you know that you added something, but it doesn’t tell you if you got it right or wrong. The ingredients on the recipe aren’t in the order that they are on the shelf, but the order you add them doesn’t actually matter: if you want to shake or stir the “drink” before you put any ingredients in, go ahead. Likewise, it asks you to restock the bar but it doesn’t seem to affect the game if you don’t. I’m not sure if the other little tasks change anything either. Maybe they affect how many customers you get?

Altogether, it’s pretty, the story is fun, and if you can get past the overly-enthusiastic writing and the feeling that English is probably not the author’s first language, the dialogue is actually really well done. (I didn’t want to derail Mike’s thread any further, but I’ve also helped edit IF by speakers of other languages and that’s always fun, so if anyone’s in that boat feel free to ask.) The minigame got to feel like a grind, but the game wasn’t so long that it overstayed its welcome too badly for me. Well worth a try.


Thank you for giving the game another try and giving it a more extensive review. I do appreciate it a lot!

You’ve given me a lot to thing about, especially regarding the fine-tuning of the bartending experience (timer on hard difficulty/notification of it being right from wrong/maybe other events happening during the rushing). I should probably introduce Brom, the chef, before the randomisation starts too.

Regarding the bug/issues:

  • I think you caught a different bug for the Ending. If you had a passage where you and the other NPCs counted the coins, you should have gotten a dialogue between you, the boss and the notary to sign the papers. I will check my code and fix that.
  • The name of the drink should always appear at the top of the bar, after the Order:. If this is not appearing, then there might be something wrong on my end too :confused:. Would you have by any chance a screenshot? (If not, no worries, your review is already plenty helpful!)
  • After the morning of Day 2, the rest of the game/passages is randomly generated. So you may indeed have been unlucky with the lunch-time patron. I do plan on having more people coming in in the future, so this should be less of an issue, then (I didn’t have the time to include it before the deadline)

Thank you again for the helpful and critical comments! :smiley:

1 Like

The ending passage was the one where they hide your tip box to scare you. And then ends with Roscoe pulling out the plug and the coins pour out, and he says something like “let’s make sure it’s all there.” And then the next passage you find him and he’s surprised to see you and you ask who he’s waiting for and then the guy shows up and apparently buys the place?

Oh. Huh. The name of the drink is there in the one screenshot I have. I guess I’m just oblivious. Hrm. Maybe I was only looking for it on the recipe pad? Dunno.


Then it’s definitely an issue with the code. I’ll fix it when I have access to it again. Thank you for letting me know!
No worries about the second one :slight_smile:
Edit: @JoshGrams, that one is fixed. Thank you again!


The Grown-Up Detective Agency

You’d expect this from Brendan Patrick Hennessy, but… wow. This one is SO good. Really nails the vibe of an updated version of old “plucky kid adventurer has zany but barely plausible adventures” books like Encyclopedia Brown or Homer Price or whatever. The art is spot-on too. 12-year-old kid-detective Bell Park accidentally time-travels forward to straighten out her 21-year-old grown-up-detective self. Does a good job with “things are a mess but there are still reasons to be happy, so hang onto them.”

I didn’t realize until late in the game that you can use the browser’s history controls to go back and forward through the story: that’s a nice touch. I wonder if that’s a Snowman thing? The other Twine story formats don’t do that, I think mostly because browsers disallowed it for a while?

I think this story is pretty much going where it’s going: you can track down the clues in any order and it’s very smooth about accommodating and acknowledging the things that you’ve already done but I suspect that otherwise the branching is minimal. Which in this case is a good thing, I think. There are no wrong choices here: it’s a comfortable space and you can play it however you want.

I think the only little quibble I have is that the first conversation starts right out with two character portraits so if you haven’t looked at the cover art then you don’t know which one is Bell and which one is Cassidy. It becomes clear as soon as you have a second conversation, but the first one goes on for a while, so it feels like that could have been finessed so it was clear from the start: have Bell talking to herself for a beat before Cassidy comes in, or, y’know, mention one of their hair colors in the prose, or something.

It doesn’t really have anything for the “it’s not a game if it doesn’t have puzzles!” crowd, but otherwise… I wouldn’t be at all surprised if this one wins the comp.


Use Your Psychic Powers at Applebee’s

How did I forgot to mention this one? You are a Psychic Brand Ambassador for Schtupmeister Beer in this absurd little adventure from Geoffrey Golden (who also gave a great NarraScope talk about the 65 bite-sized interactive stories he’s published through an e-mail newsletter over the past three years). Anyway:

Your top secret corporate mission is to mentally suggest customers buy a product. But out of fear over legal action, you’re only allowed to whisper “Schtup Up to Schtupmeister” into their brains once per night. So your timing must be right.

It’s short, it’s very silly and over-the-top, it branches a lot based on what order you listen to people’s thoughts and how long you wait before making a suggestion. I don’t want to make this review longer than the game, so go play it. And, y’know, maybe go subscribe to Adventure Snack too, if those seem like your thing.


The Princess of Vestria

I wasn’t expecting much from this, given the sparse description, lack of a cover image, default SugarCube styling, and screen-and-a-half of text between choices. But it’s actually a very pleasantly middle-of-the-road entry. Sort of an interactive adventure novella: if this were a mass-market paperback there’d be a choice about every page or page spread. But it reads nicely enough, and the choices feel well-placed and fairly consequential: most of them either get you immediately caught or switch up the options you have later on. It gives you 5 “lives” if you want to play straight through, or you can use the default SugarCube menu to save and load if you want to be a little more experimental.

The story is your basic “young person goes off on a quest: hijinks ensue.” Feels like the kind of thing Lloyd Alexander liked to write. The writing is perhaps more workmanlike than inspired, but it’s perfectly competent. It definitely gets into info-dump territory for a bit at the beginning but not too badly. There are a couple of odd jumps but it mostly follows pretty smoothly (you go to buy a horse and you ask the price and then it jumps to you riding along a few miles down the road, that kind of thing).

The other place I found a little jarring was

You’re from a country that has outlawed magick, you find a book that will teach you magick and is clear about the difference between allowable and Dark Magick. I tried some basic telekinesis, then rejected attempting mind control on my companion in a pinch, then the next time magick came up I was performing mind control on a fly, with no choice given. I guess this is relatively harmless, and it was the setup to a plot point later on, but given that mind control is clearly over the line into Dark Magick and your character has been expressing guilt over committing a crime by performing magick at all…

I also didn't get the music-box riddle at all

I know, it doesn’t matter if you can’t solve it, you can still keep going (though I kind of wish there had been a link to skip the 5-minute timer and just give up and move on). But I went back and cheated by peeking at the code to find the answer and I still don’t understand it.

There wasn’t anything too outstanding about this, but it was pleasant and kind of charming and I enjoyed it.


I’m playing this at the moment and I did eventually work it out, so here we go…

The woman’s name is Julia. There are five words on the music box: Joy, Beauty, Fulfilment, Happiness, Passion. In the first word, J is the first letter; in the second word, U is the fourth letter; in the third word, L is the third letter; in the fourth word, I is the fifth letter; and in the fifth word, A is the second letter. So it’s 1, 4, 3, 5, 2.

It took me ages to figure out! I also wanted a button to skip it, but then it was satisfying when I got it.


Ohhh, man! I was starting to get into that kind of logic but then I told myself I was overthinking it and the answer wouldn’t be that complicated and I must be overlooking something simpler. Thanks!


The Absence of Miriam Lane

Wow. There’s so much here. I’m not sure where to start. You’re hired by a man to find his wife, who has disappeared, and he can’t remember her, nor can anyone else. I think the blurb says it best:

Sometimes people give pieces of themselves away.

Sometimes they give too much and who they are wears thin.

They become an absence. A hole in the world.

And a terrible Light shines through.

This is by Abigail Corfman (The Open Sorcery games, 16 Ways to Kill a Vampire at McDonalds, A Murder in Fairyland). As you’d expect, it’s very good. And very intense.

The mechanics remind me a bit of Erstwhile: you’re finding items and thoughts and doing things with them. Though it’s more developed and focused here. There are three phases: first you’re poking around their house looking for places where a “terrible Light” is affecting things, to determine if this is, in fact, what happened here. Then you find her absence and you have to strengthen her presence by bringing her personal objects that bring her joy (but not the ones that may have once brought joy but now are chains weighing her down and making her smaller). This part was pretty amazing and definitely required some thought.

one really useful thing in the walkthrough that didn't occur to me

is that you can show items to her husband and he’ll comment.

And then finally you have to talk to her back out of it: tell the story of how she was pushed into becoming nothing. This is a sequence of lines with cycling links and you have to choose the correct words to fill in.

There are at least a few endings depending on how well you do at bringing her back (or you can push her into nothingness entirely, I think?).

Yeah. Very well written, well presented and illustrated (photos posterized to just black and white, I think?). The implementation often required more clicks than theoretically necessary, but it would be quite a bit of work and possibly coding to get much better than this in Twine. Hmm. But a lot of work has gone into this…and there were a few places that felt like they could have been smoothed out easily… I don’t know. Most people are bad at interface design, even (especially?) the ones who think they’re good at it. It wasn’t a big deal. Just…more clicking than you’d really like sometimes.

There’s a little puzzle/game where you have to find the characteristics of different flowers to be able to pick them or whatever. That was very well done and interesting.

It was a little confusing that you had different abilities in the different phases: in the first phase you occasionally get given items, but you can’t just pick up anything that you want, and there are some obvious “Just let me solve this puzzle with this item!” moments. The second phase is all about picking up and using objects, so you will get to do that. But you don’t know that beforehand, which was a little frustrating. You don’t know to just trust that in the first phase the game will give you any object you need to manipulate, and otherwise you don’t need to worry about it yet.

Anyway. This is a terrific game: go play it.


I had to go back and keep playing it after the meetup until I got to an ending, then I played it again several times until I got to the optimal ending. It’s a powerful game and highly recommended.