Josh Grams's IFComp reviews

Well, I guess we’re doing reviews by reviewer rather than reviews by game again…I sorta liked it the other way: it was fun when people riffed off other people’s reviews, and even when they were independent it was informative to scroll through a bunch of opinions on the same game in one place, but whatever.

Taste of Fingers - Short Horror, Twine

This took me about 10 minutes. Originally written for the Russian IF-Competition 2016. Sort of a zombie story? A disease that turns people into monsters.

This is an interactivity-for-pacing game rather than one with any branching at all, I think? It could be nearly as effective as a static short story. And it has a few translation artifacts. But it’s a good short horror story, and the the layout and presentation and the pacing/timing of the way the text is revealed is well done.


Oh man, The Libonotus Cup is really well-done. Silly pirate game, starts off parser-based walking around town trying to repair your ship, with Invisiclues-style graduated hints built in. Then goes more choice-based for the race itself. Rhyming-based sword-fights when your crew tries to mutiny or other pirates attack.

Your ship’s registration, is, of course, in your ship’s glovebox. The Raider’s Digest contains an actual crossword puzzle! When you go to weigh anchor you get a silly commentary about how much it weighs, complete with assuming spherical pirates. The jokes go on and on. Great fun.


Also, @nilsf, how do you pronounce this? I’m guessing leeb-oh-note-us, as in the classical Greek for a south-south-westerly wind?


It does refer to the SSW wind (though the Roman version).
That’s pretty much how I say it though with more of a French-speaking-person-trying-to-remember-his-Latin-classes-from-decades-ago sound to it (lit-beau-nos-tus with that last bit rhyming with lotus (in French)).

Thank you for your kind review. :slight_smile:


I’ve played about an hour of Cygnet Committee: don’t know how far through I am, but far enough to say it’s worth checking out if you like audio games with your IF. And especially since it’s distributed as a windows executable, I want to give it some visibility.

But I *think* Mac/Linux users can run it in your browser? Worth a try.

Although I don’t know why it’s a windows executable? It says it’s in Twine, and if I use my zip utility to uncompress cygnet_unzipper_win.exe and open data/files/index.html in my browser it seems to work fine. The blurb also says that Mac and Linux versions will be coming on itch after the competition opens, but then the itch page says “available in 43 days” so maybe they’re not coming until judging is over? @pbparjeter?

Still. If you’re on Mac or Linux, try pretending the Windows .exe is a .zip file (or renaming it to .zip?) and trying to open it up the html in your browser. Might not work, but seems worth a try.

Anyway. The game. I’m not going to fold a bunch of this so you can choose not to open it, but it’s mostly mechanical stuff and very early in the game and not particularly spoilery.

This is a spy/action-movie kind of plot? You’re sneaking into a military/research complex to supposedly shut down an AI (we’ll see if that’s how it actually turns out). Whenever you go to do something, there are four audio “tracks” on the screen: you hover your mouse up and down to select and listen to one, and have to click on the one that’s different to progress.

screenshot of first audio challenge

My biggest beef with this game is that you usually have to choose the right track 3 to 5 to 7 times to advance and there’s NO PROGRESS MARKER.

a bunch of not-really-spoilery examples from the early game: read this before playing to save frustration

The game starts up and there’s only one link on screen: “open the door”. You have to click it SIX TIMES before it goes through. There’s a “clunk” sound each time you do, it’s the same each time, and you just have to keep trying until it works.

Then you have to swim to shore, with the audio tracks. Most of these will take you onward when you’ve done it enough times, but this one just keeps going until you right-click to stop listening, and then the link mysteriously works. So I don’t even know how many times you have to do it: I tried like 10 times before I gave up and canceled out and then the link appeared.

Then you get into the game and there are a couple of tasks where there’s environmental noise (waterfall, wind tunnel) so you can’t hear the choice tracks. On the waterfall I could barely hear them so I tried for a while and never got through. I assume I have to go find a way to change the environment before I can go through here (this is strongly hinted in the text) but it still just lets you try indefinitely so it’s unclear.

Also, when you click an audio track, there’s usually a success sound. And it doesn’t wait until that sound is done before it plays the new audio track again? So they overlap and usually you have to mouse around to hear the one you’re on again because you couldn’t hear it over the success sound.

Once you get past the fact that it doesn’t explain its mechanics well, it’s a location-and-object-based secret-agent game, just presented with a choice-based interface instead of a parser-based one. Think Chuk and the Arena, if you played that.

Save points are at computer terminals where you have to watch a voiced story bit with a video loop running behind it. Those are well-done, black-and-white, scanlines, heavy French accent?

screenshot of first video clip

And the story is very…weird? In the fourth or fifth location you see, there are some beans growing.

Their description is:

Most unsettling is the fact that the engineers spliced in genes from the human auditory systems to speed up growth of the plants. The marker says: “Without an actively ‘listening’ subject, human ear cells and vegetable cells are interchangeable, merely a system that will respond predictably to air vibrations as a means to an end.”

The genetically enhanced plant hybrids were in turn “canned” in metal devices. Just sentient enough to serve as the sonar cameras and touchpads that make up the base’s security system.

You would rather not think about it.

Oh, I should mention that I’ve already run into not one but two fairly tight timed sequences. Only the vertical position of your mouse matters, and there are only four tracks, so it’s not like you’re aiming at a tiny target. But if mouse speed is a problem for you, or you find timed sequences frustrating…

But otherwise this is a satisfyingly fun and weird sci-fi secret-agent game so far.


Thanks for the positive review!

The game is in theory runnable in pretty much any modern browser, but hasn’t been tested on different platforms, so I decided to publish it only on Windows initially.

There are some issues on Mac due to the way right clicking works on the system. There are also a few other things that might break due to my slightly hackish Javascript code. By bundling the browser I knew exactly which browser version it was, which prevents any problems.

It simply wasn’t possible to get enough Mac testers pre-comp, so if anyone wants to test it on Mac, let me know and I can possibly release other OS versions earlier.

My biggest beef with this game is that you usually have to choose the right track 3 to 5 to 7 times to advance and there’s NO PROGRESS MARKER.

This is partially deliberate; as you collect ‘data chips’ you’ll be able to spend them to bypass most audio challenges and move a lot more quickly. I might be able to put in a progress marker in a post-comp release though.

Those are well-done, black-and-white, scanlines, heavy French accent?

Yes, I generated these from (Amazon Polly), which gives it the slightly robotic sound. The voice font is French / Celine. There is some more info about sources and influences in the credits pages.

You’re sneaking into a military/research complex to supposedly shut down an AI (we’ll see if that’s how it actually turns out).

Don’t trust anyone!

Oh, and you can check how far into the story you are by clicking on the map icon in the top right corner.

1 Like

I think that’s Dreyer’s Jeanne d’Arc, interesting. I watched that in school once. Looking forward to playing the game.

I think that’s Dreyer’s Jeanne d’Arc, interesting. I watched that in school once. Looking forward to play the game.

Yes, it is, good eye.

The comp organizers were generous with letting me use clips of it in a fair use context—here is a thank you to them for clearing it before the comp began.


Thank you for the review of Taste of Fingers!
Could you DM me on those artifacts? I want to keep polishing my entries, especially the translation.

1 Like

Funicular Simulator 2021

A short, lightly surreal time-loop game. Reminds me a lot of What the Bus?, the author’s entry from last year. Edit: Ack! I was waffling between playing this or Starbreakers! next, sorry. Funicular Simulator is by a totally different author. Wow. Oops. I still stand by them giving me a similar vibe, though.

You’re riding up a mountain to see a once-in-twenty-years aurora. There are four other passengers, and you can have the sort of weirdly-intimate conversation with one of them that you occasionally have with people on public transportation. And then it abruptly loops back to the start, and you can do it again.

And then at some point it ends instead of looping back. For me that was pretty quickly: 15-20 minutes, not the hour that the comp info suggests.

Yeah. There’s probably subtext here that I’m missing, but it was fun anyway. The game’s splash screen says “There are no wrong choices so enjoy the ride.” That sounds about right. What the Bus? felt like a puzzle: how do you escape this shifting surreal transportation network? But this was a slightly melancholy (?), gently trippy ride. A ships passing in the night sort of feel?


Hey, I don’t just do surreal games about public transit! I have range!

(Clearly I need to play Funicular Simulator, though!)


So, Starbreakers. Hmm. I enjoyed E. Joyce’s other games more. Sorry!

Ah. If you get to the end, then the redacted section of the About page now says “This game was originally an exercise in expanding our puzzle repertoire and exploring some non-standard uses of Twine; despite our best intentions, it developed a plot.” I think that about sums it up: it feels more like a tech demo than something created for the sake of the story.

It’s a collection of challenges with a loose frame story. There’s one of those logic grid puzzles, a word-search grid, a Polybius square cipher, pouring stuff between different-sized containers, a liar/truth-teller puzzle, a collection of riddles, and so on. Although implementing all these in Twine is certainly an achievement, they fall mostly into categories of puzzles that I’d rather let a computer solve than work through by hand: not difficult, just time-consuming (though this turns out to make sense with the story). But hints and outright solutions are provided right in the game so you can skip them or solve them as you please. And they were competently done: a couple could have had a slightly smoother interface but that might be more fiddling around with web coding than it’s worth.

The story is okay. Intentionally fractured and a bit video-game-y and you probably figure out what’s going on before it’s explained to you at the end, but it does a workmanlike job of fitting a plot around the puzzles. It wasn’t clear to me if there was any particular reason for which characters showed up in which scenes, but they weren’t characterized heavily enough that I cared (and given the plot, that’s probably also intentional?).

Dunno. Felt more like a technical achievement than anything. Competently done, but nothing to make it particularly stand out from a player’s perspective? Unless you’re more into these kinds of puzzles than I am.


Thanks for the honest review! We unfortunately ran out of time this year to polish this up (I really would have liked to go back and flesh out the characters more) but that’s the nature of comps, I suppose. We learned a lot from this and I think our next game should be better for it.


I spent about 20 minutes with Fourbyfourian Quarryin’ and still have no idea what I’m supposed to do. It starts off with a vague 500-word info dump about the political setting? Maybe that would make sense if I’d played the previous game? about gives a bit of the history of the game’s development and relationship to the previous game and says to try it again to get game details (but then gives you more history of the game), the manual doesn’t seem to say anything. There’s a bunch of help about how chess pieces move, which…yeah, I know that already. I can go around and place chess pieces but it just gives some unhelpful flowery spy/diplomacy-ish bit about it not working. And for some reason it makes you place the one king last, which I don’t quite understand since you just seem to be placing them, not making moves… So…chess puzzles. Which I usually like, but not enough to try to fight the game to figure out what the puzzles even are.

1 Like

Place the pieces you have available (your king and whatever other pieces it tells you you have to work with, like 2 bishops) first, then call the enemy king to the square where you want him so he will be defeated by the pieces you’ve already placed. There’s no moving pieces around after placing them- you set it up so that when the enemy king is placed (called), he’ll be in checkmate.


Oh dear. My apologies.

I thought I clued the PLACE verb better once you were on a quest.

I should probably make an update that nudges you after 5 moves without placing to say “just PLACE something and don’t worry it it’s wrong. There’s no actual way to lose.” I did this for 5x5 but, apparently, not 4x4.

The game should also give hints if you place things wrong. I have a few typos to update anyway.

No, I saw PLACE and KICK and so on, I just had no idea what I was trying to accomplish by placing the pieces. I figured it out eventually: I had missed that the manual says something different when you’re on one of the small maps. At that point I’d already read a whole bunch of help commands, almost none of which told me anything that wasn’t obvious, so…yeah, I missed the one thing that actually tells you your goal.

It was also confusing that you first have to stalemate with a limited set of pieces, and then you have to go back and do the same small map again to mate with some extra pieces: I didn’t think that was explained well enough. It gets marked differently on the main map but I didn’t see a legend for that anywhere? There’s a command that gives a legend for the small maps, but I didn’t see one for the main map. It does hint you at some point, I think? But it was weird to have it give a hint that’s like, “hey, it seems like you don’t know what to do next, try this!” instead of just telling you in the first place, OK, you stalemated this king and lulled his suspicions and made some allies, now you can go back and finish the job.

Also I was first playing on the original version: looks like you’ve now fixed the bug where you couldn’t move the friendly king. There was also a bug where if you had the enemy king on the board but removed one of the other pieces then there didn’t seem to be a way to check the solution: has that been fixed as well? (I’m afraid I can’t remember how I got in that situation but it happened several times).

And it was frustrating that it only told you once what your pieces were, and that it told you before the bit about the golf game or whatever, so it was easy to miss. I would have put it below the map and displayed it every time the map was displayed. Maybe just a column of piece abbreviations off the side of the board so it doesn’t take up any extra space?

Anyway. Once I figured out what I was supposed to do, the puzzles were fun. I’ll have to go back and try it on hard mode at some point.