Jigsaw crash

A short question about Jigsaw:
When I Play the game, it crashes everytime I swing the pendulum. I can’t do anything against it. Have tried Filfre, Winfrotz and Nitfol as Interpreters, but all have the same Problem. I’ve also tested the z5-version of the game, but it’s the same. Can anyone help?

Is there an error message?

I just restored a save-game and made it to the pendulum section and swung it without any problems. Could you provide a savegame? Preferably of the .z8 version. And please tell us which interpreter you used to save the game, most savegames are in the same format but a few interpreters may use a different ont.

It worked fine for me with Windows Frotz (which is probably the same as your WinFrotz) and iFrotz.

EDIT - Oh, and of course, what Zarf said - any error message?

There was no error message. The Interpreter simply showed “Please Wait” for about ten minutes, until I closed it. Sorry for the stupid question, but I’m new in this Forum and don’t know how to send a save game. It tells me that .sav extensions are not allowed as attachment.

You can rename the extension. Or you can zip it.

“Please wait”? That’s weird. Was that an in-game message or an interpreter message? Exactly which version of Jigsaw is it? You can type “version” and it’ll show the release number.

It is an Interpreter message. The Version is release 3 - Serial number 951129.
Jigsaw pendulum.zip (1.08 KB)

That’s VERY strange! I can totally reproduce the crash with your savegame, but only with your savegame.

I’m sorry, I don’t think I’ll be able to help you, but with the information you’ve provided maybe someone else can.

For me, it crashes on Windows Frotz and Gargoyle (didn’t bother trying others).

EDIT - Could you try going back to an earlier savegame and getting to the pendulum bit again? In case the savegame got corrupted, or something?

EDIT 2 - If you type “verify”, does it comfirm the game file is “intact”? That’s about it for my expertise, I’m afraid.

EDIT 3 - I’m sending you my savegame, of my game session. It won’t be terribly useful - at that point I have 30 points, whereas you have 35, and even if we had the same amount of points you’d still find we’ done some things differently. But please try it out and let us know whether it crashes too… My guess is it won’t.
swing pendulum 2.rar (1.24 KB)

I’ve tried playing it again and it isn’t helping. Verify Shows that the game file is intact. Thanx anyway for trying to find a solution.

Bump to ensure you saw my latest edit. :wink: I’m sorry, it really should have been a new post, I’ve been chided about that before…

That’s so strange. On my Computer, your save game has the same problem as my save game.

The plot thickens. FYI, I’m using Windows Frotz 1.18.

Please, someone help Targor because I’d really like to know what’s happening but am woefully inept at the wizardry that you other guys do so well!

EDIT - I just tried the savegame I sent you in case I messed something up, but mine definitely loads well.

You never actually told us, incidently, which interpreter you used for this particular savegame you sent.

This was a Filfre save file.

I’m curious: what happens if you load Peter’s save, then save again immediately (before doing anything) and send it back to him? Will it then crash for him as well?

O.K. Let’s try it. This is a save file which was directly reproduced from the old save file.
Swing pendulum new.zip (1.27 KB)

BTW, I tried saving the saved game he sent me, then restored it. still crashed. im talming about the first, original one. i havent tried the new one yet

i,m not home now and won’t be till, well, practically tomorrow, dont wait for my test results

EDIT and when I test again i’ll be using Filfre as well. no point trying to bugfix across different interpreters, even if the save format is the same

On “swing pendulum” after loading the saved game the interpreter gets jammed in a loop on the @insert_obj opcode, oddly enough. If you turn on object movement and object locating in Frotz from the debugging menu (Alt-D) and then “swing pendulum”, you can see the last thing printed is

@move_obj madeline cake yourself

Which is where it gets stuck (@move_obj is what Frotz calls the opcode, the Z-Machine specification calls it @insert_obj. Yay consistency.)

It appears that the object tree is corrupted and that this is why the interpreter gets stuck. It is possible that there is a subtle bug in either the game or the interpreter used to generate the saved game file that has resulted in the game data being in an inconsistent or unexpected state, which will be very difficult to track down.

Jigsaw is old enough to predate strong debug-mode checking for illegal array and object-tree operations. (Inform’s -S mode, that is.) I won’t be surprised if it has bugs.

This sounds like a situational bug – something you did that most players didn’t try – rather than something that worked on 1996-era interpreters. I’m just guessing, though.

One could probably rig up Frotz to do a (slow) object-tree consistency check every turn. (Unless that’s already a debug option?)

But then why would my save game file also crash? And crash on his system but not on mine?

Got it. The problem is either Filfre or a combination of Filfre and Jigsaw.

Your save game is screwed, I’m afraid. You can use mine, but play in Gargoyle or Windows Frotz. Every time I used Filfre it crashed on Swing Pendulum, same as you. I’m using Filfre 1.11 (I actually wasn’t, then I updated). You SHOULD be able to load my save game into G or WF. Filfre crashes with your savegame AND with mine. And your savegame crashes everywhere.

In spoiler tags are the chapters I’d already concluded up to my savegame. You’ll probably have to replay a certain chapter, I guess, since you had 5 more points. I think I had all the animal sketches and the pieces, because knowing Nelson from Curses I made a point of checking the walkthrough after every chapter to make sure I’d gotten everything (I usually did, but now and again I got a nasty surprise).

An alternative, of course, is grab the walkthrough and speed through the sections you’ve already solved. What you can’t do, I’m afraid, is pick up from your own savegame…

[spoiler]Ok, judging from my saved games, it appears I’d completed…

The beginning (duh!)
My Chapter One was called Ricochet, that’s WWI, that’s unavoidable.
My Chapter Two was the Titanic.
My Chapter Three was “Temps Perdu”. That’s where you are now[/spoiler]

EDIT - I e-mailed Maher about this. Because He Should Know.

EDIT 2 - Just in case you prefer to re-do the whole chapter, I’m attaching my “Chapter 3” savegame. I hate picking up where someone else left off, and you might not enjoy it much either.

EDIT 3 - Unsurprisingly, “swing pendulum new” - the one you created from my save - works fine on Frotz and crashes Filfre. I didn’t try Gargoyle, but I don’t think I have to, at this stage.

EDIT 4 - And now I’m going to bed!

EDIT 5 - And now I woke up. Got a reply from Maher, here it is:

29-Chapter Three Temps Perdu.rar (1.14 KB)