Introducing ADLENGINE

Hi all.

First, a little about me: I’ve been making games for 20-25+ years in some capacity, started out with text adventures on the BBC Micro, some of my faves include The Hobbit, Colossal Adventure and Hampstead. Moved onto the Amiga and finally onto PC.

Fast forward to now and I’ve been busy developing a role-playing / text adventure engine for the last year (including one total rewrite)… which just happens to be multiplayer =D (you are able to collaborate with others with world building / editing right built into the engine). All commands are descriptive and very easy to pick up.

Why am I building it, because the older I’ve got the more I’ve slowly become fascinated with how much power there is in words and that’s what I want at the heart of #adlengine and any scenarios I create within the engine.

The aim is to make it customisable and moddable to allow people to bring words to life in unique ways, offering both freedom to create and freedom of play, including CYOA, Dungeon Crawler and more.

Link: https://www.adliberum.com/engine/141
Download: https://www.adliberum.com/engine/dl/11504/
How To: https://www.adliberum.com/engine/how-to-use-adlengine.pdf

The engine can be deployed to the web using webfiles + .adlengine files. Or your game can be shared with others by sharing the .adlengine file/s which they can play on the downloadable software versions.

Would love it if you got chance to check it out. All questions / feedback welcomed :slight_smile:
Here’s a few gifs for demonstration.

Below is a custom theme I’ve made in adlengine for an adventure I will be creating in it called Adliberum…

Looks interesting!

I clicked on try it out. there was a Skull, but i couldn’t do anything. “look skull” etc failed.

So i try installing the system. I have a gate and a dirt pile. the gate is locked, and the parser doesn’t like the pile.
look pile, x pile, search pile, get pile. etc

Hi yes the parser currently doesn’t take variations for objects (currently) although, to interact with the dirt pile, dirt should work. e.g. push dirt, take dirt. look at skull would work / examine skull.

Thanks for the feedback. Appreciate it.

The most current web version can be tested at https://www.adliberum.com/engine this requires either Chrome / Firefox or a browser that supports WebRTC (for multiplayer).

Alternatively; if the web version doesn’t work, the download versions come complete with their own in-built version of Chrome which gets round any WebRTC issues :slight_smile:

Download: https://www.adliberum.com/engine/dl/11504/
How To: https://www.adliberum.com/engine/how-to-use-adlengine.pdf

Single player should work in any browser and your game / work can be downloaded using the dl command which exports it to a .adlengine file which can be imported. (IF you name this file game.adlengine it auto loads if its found either in the web directory or in the main folder.)

Look plinth - i don’t understand that.
Look stone plinth - i don’t understand that.
examine plinth
.
Look on plinth - i don’t understand that.
look skull - i don’t understand that.
examine skull -> picture of skull. Yea!!
get skull - I don’t understand that.
take skull - You take the skull. Yes!!

the skull breaks revealing a small key

examine small key - you can’t see a SMALL KEY
take key - you cant see a KEY
look key - i don’t understand that.

give up.

Apologies, I’ve uploaded a broken level file (caused by a bug with .creative mode that was turning creative mode off between commands) when updating to the latest version.

Will work on fixing the example for testing purposes :slight_smile: thanks for the feedback.

Please bear in mind that its not 100% stable and there will be bugs.

Thank you jkj, I have fixed lots of issues with custom commands, as a direct result of your feedback, which will come into play with the next major update :slight_smile:

In adlengine, custom commands allow the player to perform “non-standard” actions, adding flexibility.

For example.

IF kick dirt THEN delete dirt AND note is visible
ON kick dirt SAY the dirt shifts, revealing a note

You can also add your own / variations by using
push dirt==kick dirt

I will also be adding variations libraries which will come built-in to handle a multitude of variations, over time.

New version uploaded: adlengine v11508
Download at: https://www.adliberum.com/engine/dl/11508/

Lots of bug fixes including a better demo file and controls command now works for exits.

i.e. hatch controls u
everything done with the hatch i.e. unlock / lock / close / open is now mirrored onto the direction specified.

Also currently working on a Demo video / Promo video, which I’ll post up once its finished :slight_smile:

New Promo Video: https://www.youtube.com/watch?v=HN-fYHF-N3c
Link To Channel: https://www.youtube.com/playlist?list=PLpAmEbhsnk0fpsWGY1ZCAItJj_M3cP5dO

ADLENGINE LANGUAGE TESTS: US & RUSSIAN (HELP NEEDED!)

To enable support for other languages I am currently looking for both US and Russian supporters to help determine if experiments to enable both US and Russian language support are working.

Please follow the instructions below and respond with feedback as to whether it worked or not.

US:

  1. visit adliberum.com/engine/langtest
  2. type .us and press ENTER.
  3. press SHIFT + 2
  4. reply with the symbol rendered. If it worked you should have just typed the @ symbol. Please provide as much detail as you can, including location, keyboard type, keyboard layout, language etc.
    Thank you!


Russia:

  1. visit adliberum.com/engine/langtest
  2. type .ru and press ENTER
  3. Please reply whether the keys render in Russian or not and whether they render correctly for you. Please provide as much detail as you can, including location, keyboard type, keyboard layout, language etc.
  4. try entering the following command смотреть (look) and pressing ENTER. If it worked, the screen will refresh and you will be presented with the first starting room of the demo scenario.


Любые #gamedev’s родом из #Russia
#adlengine язык пробный:
посещение adliberum.com/engine/langtest
напечатать .ru
что происходит?

~ Liam
Thank You / Спасибо

If you haven’t already, you may wish to investigate posting this on forum.ifiction.ru/index.php ? I have to search there with Google Translate on occasion for info on ASM.

This looks so cool, but I still can’t convince myself to play seriously when the first situation goes like this:

[spoiler]

I completely understand that this might be incomplete test implementation, but…ow. There’s not anything I seem to be able to logically do here.[/spoiler]

Apologies =D… I keep meaning to add more variations to the demo game file.

Currently it will respond to dirt, wall or gate
Adding variations is done with the == command
e.g.

west wall==wall
steel gate==gate

etc :slight_smile:

Thank you for the suggestions re .ru I will try posting there as well! Really appreciate your feedback!

You definitely need to post this on the Russian interactive fiction forum.

As HanonO said, it’s at forum.ifiction.ru/

I think the “Developing the Russian IF platform” or “Western IF platforms” subforums would be appropriate.

Engine seems to rely on scancodes rather than input characters, and implements the phonetic layout itself. But this layout very rarely used (I think only met it on soviet PDP-11 clone, some 25 years ago, and it was already obsolete back then). Modern and much more widely used layout sometimes is referred as ЙЦУКЕН.

> смотреть I don't understand that

Browser: Chrome 59.0.3071.71 on Win10, language: English, keyboard layout: Birman’s Typography Layout (russian variant).

Thank you for your feedback, I have changed the layout… would be really grateful if you could please try again at adliberum.com/engine/langtest/ru-RU/ and let me know if it works now :slight_smile:

fingers crossed!

Much more comfortable, thanks:) One thing though: in second row rightmost key (’/") should produce э/Э instead of 0. And key right below ESC (`/~) can produce ё/Ё, but this is not obligatory, the letter is kinda disputed and in most cases can be safely replaced by e/E. So if it poses a problem, don’t give it to much sweat.
Good luck!

Thank you so much. fixed :slight_smile: I’ll reupload a new version soon. Next I’m implementing the translator that converts the russian into the English command equivalents and setting up the standard commands.

Really appreciate everyone’s feedback. This is a huge step forward! =D

=D

New version: adliberum.com/engine/

Current Russian Commands:

to activate Russian type .ru

строить object: i.e. build box
object я могу взять: box is takeable
дубль object: i.e. take box

Thank you so much for your help!