Instead of doing anything other than...


#1

I have a pretty restrictive rule in my game, when the player is in a particular room–he cannot do anything that requires physical movement, but certain other things are allowed–in fact a lot of other things that don’t require much movement. These are covered by an Instead of doing anything other than… rule. The problem I am having is that the one thing that the player needs to do to succeed in that room–which is one of the actions I have listed in that rule–for some reason is not being allowed. It is an action that I have created, and though the player is sitting in a chair while in this room, there is no ‘reaching outside of’ rule interfering. I just can’t figure it out. The action is clearly included in the list, but the response to it is as if it wasn’t (it responds with the ‘say’ phrase also defined in that rule). What’s more puzzling is that the action worked in every previous testing, and though I have heavily edited the game recently, I barely did anything with this part of the game. It’s only now that I am doing a serious playtesting that it has failed. All of the other actions listed in the rule were allowed. Let me re-word my question–

Is there any instance in which an action listed in an Instead of doing anything other than…rule would not be allowed??

I note that it is a long list of actions–is there a limit to the number of actions allowable in such a rule??

I have looked all over my code and haven’t found anything that would interfere.

Thanks


#2

I think I figured it out. I had another action–a two-noun action–that had the same verb. The two actions are Writing and Writing it with. Both take text, and the second one takes a thing. I listed the first action as ‘writing’, and the second I listed as ‘being commanding’ (after having said 'Writing a topic with something is being commanding). Neither one was allowed. I solved the problem by re-naming them both, and now they are both allowed.

Thanks


(Piergiorgio d'errico) #3

I’m wrong, or is a puzzle, as you describe it, similiar to the very first puzzle in Adams’s the Hulk ?

[rant](suffice to say that back then in 1980s kept the game in a “pirated” status for a while (I was one of few sane people whose used pirated copies as playable demos…)[/rant]

Best regards from Italy,
dott. Piergiorgio.


(J. J. Guest) #4

Veering way off-topic here, but having previously played Scott Adams’ The Count, Ghost Town and Strange Odyssey, I was in equal parts disappointed and fascinated by The Hulk. The version I played had no graphics, so it seemed very far removed from the Marvel Comics it was based on. I remember it being a very weird game, and I’m tempted to play it again.


#5

Sorry, I’ve never played that game, but thanks for the recommendation.