Installing frobTADS on FreeBSD

Does anyone out there have any instructions for installing frobTADS on FreeBSD. If not I will settle for Linux instructions and go from there. Thanks

It’s the usual deal: download, unpack, ./configure, make, make install. Last step should be executed as root if you didn’t change the default install location.

Many thanks for replying… I tried that. I get an error that libcurl is not installed, yet I know it is. I reached out to our server tech support and here is what they posted

"Thank you for the information. We were able to replicate the same error that you received. We can confirm that libcurl is installed and the version of CURL associated with that is curl-7.21.3. You may want to communicate with the developers of the software and see if there is a requirement above that version of curl and see if there have been any reported issues building this software on FreeBSD 8.1, which is what your server is running.

In trying to think why this might arise:

  1. does frobtads have a higher that 7.21.3 requirment.
  2. Is it possible it is looking for it on the server in a place where it is not installed. How does the configure file check for libcurl?
  3. Perhaps there is a file linking issue
  4. Is it possible to bypass the check for libcurl

Many thanks for your response.

It should work with 7.21.3 (I just tested.) Can you find out where the header files for curl are installed? They should be in /usr/include/curl. The filename you’re looking for is “curl.h”. Try:

find /usr/include -name “curl.h”

Try /usr/local/include too. If it’s found there instead of /usr/include, then you must add that directory to the compiler’s include path. Add this:


as the first argument to the ./configure command.