Informatic -- an Inform 6 IDE

Edited on 2015/02/26 to link to latest release.

I’m working on an Inform 6 IDE called Informatic. It’s in an early stage of development right now, but you can create a new project, browse the source directory, edit multiple source files, and compile. It is a cross-platform application that has been tested on Ubuntu 14.04 “Trusty Tahr” and Windows XP. More details are available on the Informatic GitHub page. For information in Spanish, visit the Informatic thread on CAAD.

I am aware of some other Inform 6 IDEs, but the ones I tried didn’t handle multiple source files in a way I liked, and I needed a practice project anyway, so I started building my own.

For Windows users, I’ve created a “frozen” Windows binary package that you can run without installing Python or PyQt. Of course there’s also a source tarball and an Ubuntu package. The current release, 0.0.4, adds a French translation by Hugo Labrande and an improved Spanish translation by Fernando Gregoire. It’s all on the release page.

This is the first real application I’ve developed, so anyone interested in aiding its development can help me by:

  • Submitting issues, and maybe code
  • Making a sensible application icon for Informatic
  • Building “frozen” Mac OS app releases for Informatic using cx_Freeze or a similar tool
  • Sending words of advice and encouragement.

I’m having flashbacks to 1998 when I wrote an I6 editor. geeeahhh (shiver)

Admittedly, the fun part was building the syntax parser to deserialize the code into an object tree. That code still exists somewhere on the IF archive. It was written in VB6.

I’m sure you’re having similar fun.


Oh, that’s great, congrats ! I’ll definitely try it soon and give feedback :slight_smile:

I tried to get this running on MacOS, but I couldn’t make it go. Sorry.

(Installing PyQt5 from “brew”: did not install PyQt5.Qsci. Installing PyQt5 from pip3: “No distributions at all found for pyqt5”. Compiling PyQt-gpl-5.4 from source: failed, weird C errors not obviously traceable to a missing header file.)

I was a little daunted by this, but am less so now that the application’s basic framework is in place.


Thanks for giving it a go, zarf. I haven’t yet got a working Mac OS X VM, so I hadn’t tried this myself, but I know that I’ve had trouble compiling PyQt5 before and because it doesn’t use a build system compatible with setuptools or distutils, pip can’t install it. Did you by any chance try brew install qscintilla2 to install PyQt5.Qsci?

Yes, I did that at one point, but I think it installed a python2 module rather than python3. Didn’t work, anyhow.

If one can’t install PyQt5.Qsci on Mac OS X without building it yourself, that’s like an issue I might want to bring up on either the PyQt mailing list or the QScintilla mailing list. It looks like the current Homebrew formula for qscintilla2 provides PyQt4.Qsci but not PyQt5.Qsci, so maybe I’ll just submit an issue for that.

I have updated the original post to link to the new release of Informatic, 0.0.2.

Sorry to bump this again. Won’t do it for a while. Just wanted to let you all know that Informatic, which I am still slowly developing, should now be able to run in Spanish. This might expand its potential user base. Accordingly, I’ve posted about it on the CAAD forums.

I thought there was an awesome Inform 6 IDE --> vim! hehe

Congrats on working on a fun project. I cloned your repo on my Linux Mint 17 (Ubuntu 14.04) laptop but, after installing python3-pyqt5, I get the following error:

Traceback (most recent call last): File "informatic.pyw", line 9, in <module> from informatic.mainwin import main File "/home/username/Desktop/informatic/informatic/", line 13, in <module> from .sourcectl import SourceCtl File "/home/username/Desktop/informatic/informatic/", line 11, in <module> from PyQt5.Qsci import * ImportError: No module named 'PyQt5.Qsci'

Importing PyQt5 in ipython3 doesn’t show any Qsci submodule/function…

PyQt5.Qsci isn’t included in all installations of PyQt5. Try installing the python3-pyqt5.qsci package from Ubuntu repositories. Also remember to build before you run Informatic. (Because it’s a binary file I don’t track it on GitHub, but it’s included in the release tarballs.)

OK, PyQt5.Qsck installed. How would I ‘build’?

Otherwise, in the README.rst, you suggest using a source tarball instead of the GitHub code. Where can we get the tarball?

You’ll need the pyqt5-dev-tools and qttools5-dev-tools packages, and then you can run “make rc” in the root directory of the cloned repo.

I said earlier I’d test your IDE, but haven’t gotten around to doing that yet. Sorry…
So I translated it to French, in the hope you’ll forgive me :wink: The translation file is here; let me know if you have any comments.

Also, there’s a minor typo in your Spanish translation: you’re missing “:” at the translation for the -H switch :slight_smile:

Merci! All is forgiven. :stuck_out_tongue: I’ll make use of your translation and fix my typo next time I’m ready to work on this (probably tomorrow).

Any chance to revive this project? Especially update the build/setup instructions for Ubuntu 16.04 now that this is a Long Term release?