Inform7 will not compile even simple programmes.

Greetings, I am a blind person who would like to learn to build interactive fiction games using Inform7. I am on a Mac, but unfortunately the Mac version of Inform7 is completely inaccessible with the Mac’s built-in screen reading service: VoiceOver. The application cannot be read or interacted with in any capacity. VoiceOver simply reports the application to be an empty panel. The most likely cause of this is the frame-work used to build the application not exposing accessibility information to the screen reading service.

Luckily, via a Raspberry pi, I am able to have access to Inform7 using the Linux terminal version. Using a terminal app coupled with VI is a greatly preferable method of working with Inform7 for me personally. The simple menu system, ability to use a text editor of my choice, and clear and concise nature of working makes life considerably easier for me. The only problem, with the terminal based version of Inform7, being that it doesn’t work.

I have tried multiple simple examples, downloading and attempting to use simple demonstration examples from the net, and unfortunately nothing will compile. On every attempt I get the same error:

Illegal instruction.

For clarity, here are the steps I took to install the Inform7 for linux terminal application.

  1. I downloaded the tar-ball archive I7_6M62_Linux_all.tar.gz,

  2. I extracted the tar-ball with, "tar xvf [filename].

  3. I installed the package using, sudo + the installer script.

If anyone can point me in the direction of how to get the compiling functionality working, I would be extremely grateful. Having a working version of the terminal based version of Inform7 would be a good result for not only blind people like myself, but also command-line ninjas, command-line pi enthusiasts, and those of us who come to Inform7 from a coding background. A fully working terminal version of the compiler really would be a great string to add to Inform7’s bow.

I have read some articles on using Inform7’s GUI based console to generate a prototype terminal command for compiling files into something like a Z-machine or Glulx file, but none of these are of any use to me currently. As stated above, I have absolutely no ability to interact with the GUI based application in any way. In a perfect world I would be more than happy to use the terminal based version, so long as all functionality was available.

Many thanks and kind regards.

Hi, Tain, sorry this is happening to you. It sounds like an issue with the install of Inform 7. I’m sorry that I don’t know enough about Inform nor Linux to be of help, but hopefully, someone around here will be able to assist in detail.

I don’t know if this is of use, but there is an online version of Inform that runs in the browser at That may not be at all what you want, nor work with your screen reader, but it may be worth a shot in the meantime if you’d like to experiment with Inform before someone can assist you with your local install.

The website spelled out is p l a y f i c dot c o m

Good luck!

I am not at all expert with MacOS Voiceover, but in the current version of Mac I7 ( I can get it to read all the controls and the contents of the left and right panes. I was able to do a compile, and while the story pane was probably non-ideal, I could enter game commands and then get it to read back the window contents.

Is it possible that you have an older version of I7?

It is also possible to run the Mac I7 compiler from the command line. The command-line tools are included in the Mac package. My test commands look like this:

/Applications/Inform-7/ -internal /Applications/Inform-7/ -external /Users/zarf/Library/Inform -project new-test.inform -format=ulx

/Applications/Inform-7/ -kE2SDwG +include_path=/Applications/Inform-7/,.,../Source new-test.inform/Build/auto.inf new-test.inform/Build/output.ulx

That’s verbose, of course, but you can put them in a shell script or Makefile.

I know I haven’t given complete instructions, but that might be enough to get started.