[Inform IDE] [OSX Big Sur] Is there a way to disable Dark Mode in Inform7?


Big Sur has obviously scrambled everything (also, I’m on a M1 processor: let’s cross fingers).
Now Inform has this nasty partially-dark mode that makes it awful and hard to use.

Is there a way to disable dark mode selectively for this app?
in case, I can disable dark mode from the Mac prefs before using Inform, np.


I haven’t tried it, but I see this article:


The bundle identifier for Inform is com.inform7.inform-compiler. So:

defaults write com.inform7.inform-compiler NSRequiresAquaSystemAppearance -bool NO

Again, not tested.

How is Big Sur? I’m still on Mojave on my Mac Mini. I think I completely missed the last one.

Rounder corners. I dunno. It’s not a big difference in my life.

1 Like

It’s jump from Catalina, for me, and to a new processor. So… well, I like the graphics, but I can’t see relevant, life-changing differences. The widjets are cool, but I’m not used to them, so I don’t use 'em very much. The tweaks in the graphic, I approve.

Thanks, @zarf.
Unfortunately, it doesn’t work and I can’t seem to find anything similar in the 'net for BigSur (too soon?).
Something has changed in the way the OS treats ligh/dark modes (probably they complicated it in some way).
I can survive by changing mode prior to using Inform. Some of the button appear with white text on a light background, but I know what they are (the tabs on the top of the siding windows in IDE main area).

If anybody finds an answer, I’ll be monitoring this thread.


I’m a bit late, but if you haven’t solved this yet, I think the problem was just that you’re setting the wrong value in that command line. It should be:

defaults write com.inform7.inform-compiler NSRequiresAquaSystemAppearance -bool YES

(Note the “YES” at the end.) You may need to reboot and retry this command a few times before it actually switches.

1 Like

Nope. Tried it several times with reboots.
Thanks for the reply, tho :slight_smile:

I had the same problem (OS Catalina), I couldn’t see the input caret in Dark Mode. I changed the appearance by adding a row in the Info.plist of the application:

NSRequiresAquaSystemAppearance | Boolean | YES

Then I had to re-sign the app with:

sudo codesign --deep -fs - /Applications/Inform.app

How shoukld I add that line? I see a lot of tags like


Inserting the string directly gives an error when re-signing.

Sorry, but this is definitely not my field :slight_smile:

If you don’t have Xcode or another plist editor installed, you can just add it with a text editor like this:


This is what the beginning of my Info.plist looks like:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
1 Like

It worked! Thanks!

defaults write com.inform7.inform-compiler NSRequiresAquaSystemAppearance -bool YES

@ArdiMaster’s solution worked for me without needing to go the XCode-resign route. Many thanks!