Inform 7 won't run code on my system

I’m on a Mac mini 1.66 GHz with 2 gigs of RAM and OS X 10.5.8.

I tried compiling examples from the Writing With Inform manual, but they wouldn’t run. They seemed to compile successfully, but the ‘game’ pane wouldn’t activate and that pane actually completely refuses to activate no matter when or how many times I click. Basically, my ‘game’ pane is dead and I don’t know why.

So I tried just compiling a little ‘Hello World’…

But even that wouldn’t run in the game pane. I can’t even get the ‘game’ tab to highlight.

Here’s the compiler progress I get out of it…

I don’t really know how that’s supposed to look but I don’t see anything in it that looks to me like a fatal error. Anyone had any experience with this issue?


More info: I am running Inform build (1.2 6.31/6E72) which I just downloaded off the official site, this morning.

I tried restarting my Mac fresh and running nothing else but Inform: same problem.

Instead of using the ‘game’ pane, since the compiler reported success, I tried proceeding directly to the Release stage, so I clicked ‘Release’. It told me…

I looked in the appropriate folder and there was no .blorb file created. So if Inform isn’t creating the files it says it is creating, then it makes sense that the ‘game’ pane doesn’t work. So I opened my Inform project package to inspect the contents, and checked in the ‘Build’ folder, and sure enough — no actual build was created although it reported that it did.

Basically my copy of Inform can compile but it can’t create finished build files in which to store the compiled results — although, it had no trouble creating the package files and folders meant to contain those build files, so I doubt it’s a permissions issue…

EDIT: I just tried removing the spaces from the ‘Writing With Inform’ folder I was using to create the project, so that there would be no spaces in the file path. Still no love…

Almost certainly this bug:

There are suggested fixes there for the time being; a new bug-fixing release of Inform is probably not too far off.

Thanks, Emily!

BTW I just downgraded from July’s release of Inform 7 to the June release (1.2 6.31/6E59). My game pane is now working and all appears to be well.

I’m in Leopard; the bug report you posted is in Tiger. Since this build has been out since July and the IFcomp has happened since then, I’m guessing that the newest build works more reliably in Snow Leopard.


Wahoo! Looking forward to it.