Inform 7 mapping glitch (SOLVED)

I posted a picture below to help illustrate what I mean.

In my game, I have many rooms, but they seem to want to lay on top of each other… There is a Living Room (which is where the PC starts), and north east of the Living Room is the Porch. North of the Porch is the Weathered Path, and north of that is the Town Outskirts, but when I try to go north from the Weathered Path, it just gives me the ‘you can’t go that way’ spiel.

When I look at the map under index, it shows that the Living Room is in the same spot that the Town Outskirts is… so there is something screwy going on.

I started writing this interactive fiction when I was 13, so it is 5 years old, but I haven’t done much with it since I ran into that glitch.

It’s fairly organized, if that even has anything to do with it, and underneath the map where it shows every room by itself, the Living Room is abbreviated with TO, as well as the Town Outskirts.

Along with that, the Weathered Path appears in two locations, both upwards and to the right of the Town Outskirts/Living Room area, and directly below it…

Please help me.

Since the game itself doesn’t let you go the expected way, there’s very probably something in your source text that puts some of the rooms in the wrong places (rather than a bug in the map of the World Index).

I’m afraid there isn’t very much to do except taking a long, hard look at how you have defined the Living Room, the Front Door, the Weathered Path, and the Town Outskirts and their positions relative to each other, and then correct any possible mistakes.

Well, there is something screwy going on with the World Index, too, I see now.
It calls the room where you start Living Room, but still abbreviates it TO (for Town Outskirts apparently).

Are you using the latest build of Inform 7 or the same one you used 5 years ago?

I think it is the same build… I’ll re download it and see if that fixes the problem.

I should try a later build. You may have run into some bug that was fixed years ago.

The downside, of course, is that there has been a few changes to the language of Inform 7, so it’s not guaranteed that your old code will compile with the latest build. For instance, I don’t think you can easily call a room “Outside” any longer (but I may be wrong about that).

If that doesn’t work then try posting your code here and we’ll diagnose the problem.

Hope this helps.

Just from what you’ve posted so far, it sounds like you’re accidentally creating two Weathered Path rooms even though you think there’s only one.

Yes, definitely use the latest build of I7. It will be difficult for any of us to answer questions about an older version of the language.

You don’t have a region called “Town Outskirts” that is affecting the map do you?

Thanks guys, I got the new version, and everything is how it is supposed to be. That’s a relief.

I also realized that I had one room labeled ‘Weather Pathway’ (which is connected to the front door) and ‘Weather Path’… which was the source of my problem.