Infinity Engine - Beta Release, Seeking Testers

The Infinity Engine is new tool for reading and writing interactive fiction. It seeks to build out the world of the author’s imagining in a near unlimited manner, crafting a story that is as much the reader’s own as the author’s. It’s signature feature is a randomized event system which provides a coherent journey through the world that is never quite the same.

The Engine requires no coding or technical skills to use. It provides a simple UI that allows the user to both easily read and write their story. Planned features include an iOS & Android app as well as an in-browser interface.

It comes prepackaged with The Age of Sail, a story which pits you in the role of a Captain on a pirate ship who embarks on a swashbuckling journey through the Caribbean. You may simply read the story for fun, or use it as a reference for your own writing.

This is the first version of the beta release. It is only intended for writers at this point. If you would like to beta test the Engine, you can download here:

Please send all emails to We look forward to exploring your worlds!

Is this Windows only?

It’s a little weird. It seemed to download twice.

I tried to open the included game and got this error:

[rant=image]Infinity error.JPG

This isn’t my file directory (I’m not John.)[/rant]

Yes, currently it’s Windows only.

Problem is now fixed. Please re-download. Questions or comments, PM or email me -

It has the exact same name as Bioware’s Infinity Engine and the novel by Neal Asher?

The application run as administrator on Win 10 displays an empty “screen” with tabs for editing and reading. Nothing beyond that. I cannot read the story or begin editing.

It looks interesting.


Hi Fos. Take a peek at the documentation. Once you open the Engine go to File - Open and click on the story Age of Sail. Start reading!

I’m getting the same error messge as HanonO; can’t open “file.txt” when trying to open “Age of Sail.db”

Recommend you put a version number in the app somewhere, so you know which binary we’re using.

Also, the main window doesn’t resize.

Same… Errors when opening Age of Sail file.

I can find no documentation in my zip file or within the application.