If-archive problem

Chrome now blocks users from downloading many filetypes (zip, chm, etc) from ifarchive.org since Chrome thinks they may contain some kind of malware. I first got this problem with inform634_win32.zip, but it looks like it affects lots of files.

What can be done, and who can do it?

I reproduce this issue. https://ifarchive.org/if-archive/infocom/compilers/inform6/executables/inform634_win32.zip

While investigating this issue, the problem went away on its own. :grimacing:

@fredrik is it working for you now?

The best advice I can give is: Don’t use Chrome.

It’s the largest piece of spyware on the planet with the exception of Microsoft Windows.

2 Likes

No, no change. Still can’t download any zip files.

Try rebooting your computer, and then try clicking on the exact link I posted above?

(Rebooting might help because it appears that Google changed something on their end; the fix might not have rolled out to you yet.)

1 Like

Ok, it works after a reboot and Windows Update.

I tried updating and restarting Chrome first, but that wasn’t enough.

Thanks.

I don’t know what Chrome is checking behind the curtain or why a Windows update would change it, but I’m glad it’s working now.

Regarding Windows and Chrome, my consideration is: :roll_eyes:

I bet the Windows Update was a coincidence. The main thing was fully quitting Chrome and reopening it.

I agree. Killing all instances with the task manager probably would have fixed it too. Especially since I believe that Chrome installs as a service by default for quicker launching (which I always disable, because “Ew…”).

1 Like

Just to be clear: Updating Chome, closing Chrome and reopening Chrome was not enough.

I’m convinced that the best browser setup is Firefox reinforced with the adblock+noscript combination… and this is my suggestion.

1 Like

IIRC, when I tried to download something from ifarchive.org about a year ago, the ISP (The Post Office) blocked it because it was “a dating site”!
(I’m using Brave, which seems to be a slightly-tweaked Chrome principally because reading ‘New Scientist’ on The Web is bearably fast, which it isn’t with Firefox.)

2 Likes

one should assume that your ISP is the UK post office ?

Yes, www.postoffice.co.uk
Well, actually, no. It was The Post Office. Now it’s Vodaphone.

yea, I remember UK having implemented net filtering, jokes in the EU being that UK net filtering is more victorian than chinese, and UK post office considering IFArchive a dating site is, well, a very hilarious incident :smiley:

Best regards from Italy,
dott. Piergiorgio.

1 Like

Correlations between the fix and updating Chrome, restarting Chrome, and rebooting the computer may all just be coincidental. I suspect it has more to do with when cache entries get refreshed, and many factors go into that. If Chrome has a cached list of suspect URLs or fingerprints for downloads, it might just take time before your installation grabs the fresh list with the false positive removed.

This also could have something to do with how the files are served (of which, I know nothing). If you type chrome://flags in the address bar, you’ll see a huge list of fine-grained options. In that, you can find this one:

Treat risky downloads over insecure connections as active mixed content

Disallows downloads of unsafe files (files that can potentially execute code), where the final download origin or any origin in the redirect chain is insecure if the originating page is secure.

I don’t know if there are redirects behind that URL, but if there are, and if any of them are over HTTP rather than HTTPS, this safety feature would probably block the download of a ZIP (certainly of a ZIP that contains executable files).

Again, I don’t know anything about how the archive serves, so this may or may not apply here.

ifarchive.org and www.ifarchive.org go through CloudFlare these days. They should not redirect at all.

Currently there’s not even a redirect from the non-HTTPS http://ifarchive.org/ to the HTTPS version https://ifarchive.org/ … I wonder if it would be a good idea to add that redirect?