[i7] [solved] dynamic object trouble


I started using dynamic objects by Jesse McGrew in my game, and it worked fine. But right now while I’m trying to nail down the minimal code for a completely unrelated bug, I just can’t seem to get this example to work:

[code]“conversation trouble” by “bartax”

Include Conversation Package by Eric Eve.
Include Dynamic Objects by Jesse McGrew.

The basement is a room.
Ben is a person in the basement.
Pen is a kind of thing. “A pen.”
Red boiler plate pen is a pen. “A red pen.”
Understand “red pen” as Red boiler plate pen.

Response for Ben when asked for “pen”:
say “‘Have a red pen!’”;
let the new red pen be a new object cloned from Red boiler plate pen;
move the new red pen to player.

test me with “ask ben for pen”.[/code]This does the following if tested:

I’m totally stuck figuring out what I did differently than in the single occasion where I used it in my game (or also compared to the example of the extension’s documentation), so I have no idea why it won’t work. If someone can see it and could help me out, I’d be glad!

That piece works fine for me …

Oh I am an idiot, I had it set to z8 code and not glulx - and the extension only works with glulx of course. Sorry for bothering! :unamused: