I7 not creating a release?

I’m trying to release my I7 project with a website and an interpreter, but Inform flat-out refuses to compile anything. No error messages are generated- it says it’s generating code and flat-out quits when the task is finished.

It will create a Project.materials folder with a release subfolder, but they’re both empty. I can release it as a .ulx alone, but my overall goal is to embed my project into a website.

Quixe is supposed to be embedded in the most recent Inform release, but I downloaded the template package just in case. Didn’t make any difference. Tried to reinstall I7, and it didn’t make a difference either. Any ideas on what I could do?

What operating system?

If the entire Inform app quits, that’s a crash.

Windows 10. Inform doesn’t quit, it just does nothing. No crash, no error report, no blorb or ulx generated.

There was a bug at one point where if cBlorb (the release packager) failed, the front-end didn’t go to the Results tab to show you what had happened, which might be the cause.

After compiling, go to the Results tab. What does it say there? From the Results tab, click “Console” (top right, just below the tab). Copy all the output and paste it here - that will say what was run and what it produced.

Also, does the “Go!” button compile and run the game?

When I release:

Inform translated your source text as usual, to manufacture a ‘story file’: all of that worked fine. But the Release then went wrong, for the following reason:

•Fatal error: unable to write to file: filename ‘C:\Users\Me\Documents\Inform\Projects\Terminal Velocity.materials\Release\Cover.jpg’

The game compiles just fine otherwise:

C:\Program Files (x86)\Inform 7\Compilers\ni
-internal “C:\Program Files (x86)\Inform 7\Internal” -project “C:\Users\Me\Documents\Inform\Projects\Terminal Velocity.inform” -format=ulx
Inform 7 build 6M62 has started.
I’ve now read your source text, which is 45263 words long.
I’ve also read Standard Rules by Graham Nelson, which is 42655 words long.
I’ve also read English Language by Graham Nelson, which is 2297 words long.
I’ve also read Unicode Character Names by Graham Nelson, which is 28382 words long.
I’ve also read Basic Help Menu by Emily Short, which is 2368 words long.
I’ve also read Basic Screen Effects by Emily Short, which is 2218 words long.
I’ve also read Menus by Emily Short, which is 2001 words long.

The 45263-word source text has successfully been translated into an
intermediate description which can be run through Inform 6 to complete
compilation. There were 248 rooms and 477 things.
Inform 7 has finished.

C:\Program Files (x86)\Inform 7\Compilers\inform6
-wSDG +include_path=…\Source,.\ auto.inf output.ulx
Inform 6.33N for Win32 (30th August 2015)
In: 1 source code files 109825 syntactic lines
108444 textual lines 4373194 characters (ISO 8859-1 Latin1)
18846 symbols (maximum 50000) 18040936 bytes of memory
Out: Glulx story file 1.180224 (1701K long):
52 classes (maximum 200) 796 objects (maximum 1000)
236 global vars (maximum 512) 450728 variable/array space (maximum 500000)
140 verbs (maximum 255) 1229 dictionary entries (maximum 2000)
279 grammar lines (version 2) 426 grammar tokens (unlimited)
156 actions (maximum 200) 44 attributes (maximum 56)
40 common props (maximum 256) 122 individual props (unlimited)
393167 characters used in text 289861 bytes compressed (rate 0.737)
0 abbreviations (maximum 64) 4309 routines (unlimited)
105185 instructions of code 63592 sequence points
824320 bytes writable memory used 916992 bytes read-only memory used
1741312 bytes used in machine 1072000512 bytes free in machine
Compiled with 2893 suppressed warnings
Completed in 1 seconds

That would be the problem, then: you need to put an image in Release/Cover.jpg. If you do that it should work.

I know I’ve seen an error message for a missing cover image, so that’s odd that it’s not getting there.

Thanks, that seemed to do the trick.