I7: Just curious

In testing, if I transport the player to a room with an “abstract me to . . .” command, I understand why it does not do an automatic “look” upon arrival as it would do if I arrived by more conventional transportation. What puzzles is me is why, if, having arrived via the “abstract” magic carpet, I then do a manual “look,” I still don’t get a room description. It obviously “knows” where the player is, since it is possible to examine or otherwise interact with any object in the room. It’s not a big deal, but it seems odd enough to pique my curiosity.


Robert Rothman

I do something similar, except the player is hit over the head and blacks out, then awakens in another room and region. I do get a full room description on entering, which is coded with a [if the blah room is unvisited] for the initial description, and then if the player does a ‘look’, he/she gets the [if the blah room is visited] part that I also wrote into the room description. On the ‘look’ they also get the other usual add-ons to the area description… “You also see a piano, a bench, and a mutant frog singing while he plays by bouncing around on the piano keys. And in the corner is a gecko selling car insurance.”

Or something like that. :wink:

How are you doing it? Maybe it is a subtle difference in the code. We all know how one misplaced tab or punctuation can change the results.

Oh, and I do it with a “Now the player is in the blah room;” command. Maybe that is the difference.

Seeker, Robert’s talking about the ‘abstract’ command you can use while testplaying your game, as opposed to coding :slight_smile:

You can use it to teleport people and objects around, to cheat and to test things that would otherwise take some playing to reach.

But yeah, I also noticed look-related weirdness if you abstract yourself to another location.

Oops… I hadn’t tried that. I even did a search for “abstract” and didn’t find it in the docs.

But now that I try it (and understand it) I see how it works, no initial room description as stated. But if I do a ‘look’ I do get the correct reply. So I still get what I would expect in that regard, but I get stuck in the location and can’t leave (It seems I can only go to places I visited before I said 'abstract me to… but that might just be because of my choices, not a real clue)

But very cool command. It will save me hours when I just want to see a single room way down in the game. Up till now I did it the long way.

Edit to add: I notice in playing with it, it also screws up my status bar compass rose and exit listing (based in part on Exit Lister by Eric Eve… but just a few parts of it) :wink:

Seeker, if you haven’t used “abstract” before you’ll find it a real timesaver. You can use it to move anything, not just the player. For example, let’s say you’ve just written an action which can only be performed if the player has a whatchamacallit. In the ordinary course of play, getting hold of a whatchamacallit might require doing a bunch of other things. You can test your new action without going through all that by using “astract whatchamacallit to me” – it will immediately show up in your inventory. It even works if the whatchamacallit is offstage.

It’s very strange that, after abstracting yourself somewhere, you can get a room description but can’t move. I can move around freely but can’t get a room description.

Robert Rothman

Wow… that is an odd command. Useful but with strange results. I just tried abstracting an object that is a trigger for later events, and it broke the trigger. I even dropped it and took it again, in the correct location, but nothing happened.

Then I tried it with a different item, one that when held opens a secret panel. I got the message that the panel opened, even though it was in a region I had already left and no longer had access to.

I need to try this in a game where I always get killed by taking a certain object :wink: Damn harpies.

Kidding, but I see how this can be useful and it will save me lots of time. Like said, I always did it the long way before.

And I seem to only be locked into the room if it is certain locations…rooms not in a region, but linked through doors in a region without directions… just enter room/exit room type of commands work. I have a few of those ‘hidden’ rooms. Odd. But either way, the status bar with compass rose and exit listing break. And I get room descriptions fine if I abstract to the ‘hidden’ rooms, but not if I go to normal rooms in a normal region. Same as you describe.

I guess as with any ‘magic’ tool, it has its limitations. But they are fun to play with.

Now the player is in the noun.
^ Your best bet. I use that in unit testing my puzzles.

“Abstract” is a leftover from the I6 debugging system. It does not play well with I7 constructs like part-of.

It’s also just flat-out buggy if you abstract the player around. Always has been. I’m sure that’s the biggest reason it’s not documented.

The testing command for moving the player is “gonear” which you can use to go to specific rooms or to game objects (GONEAR LAMP moves the player to the room where the lamp is).

WOW!!! Now that does just teleport you around! And does not seem to have any bad side-effects.

Thank you!

Thanks, Juhana. I’ll use “gonear” in the future and avoid the weird behavior of “abstract.”

Robert Rothman

“purloin whatchamacallit” has this effect too (and is probably the approved I7 way of doing it).

[spoiler]The “aerial shield” spell is your friend. (And yeah, you have to do a lot of stuff to get that spell, and you might get killed anyway.)

UPDATE: My god, there’s even a hint about that in the feelie (pdf), not to mention a list of the stars in whateveritis constellation that doesn’t require use of Wikipedia. I didn’t even know there was a feelie – though suspect the hints are best appreciated when you’ve already solved (or looked up the solution to) the puzzle for which they’re hints.[/spoiler]

I sometimes need follow an ABSTRACT with an EXIT. I’ve had the player climb out of newspaper vending machines, out of blades of grass, out of other people…