I7 glux - input field looses focus

When the player has typed enough commands to fill the screen, a box with the text “More” appears at the lower right corner - and the > input field looses focus.

What gives? Any way of disabling this bug/feature?

Well, that’s pretty much standard. If you press a key or scroll down, the command line will regain focus when you reach it. Theoretically. Isn’t that what’s happening for you?

If that were disabled (and no, it can’t be disabled at the I7 level; the Tads 3 terp allows you to change that behaviour, but only at the terp level, and I don’t think the Glulx ters allows you to do anything about it. WinFrotz does, I think) the only way to read some of that text would be to scroll back, and the default Glulx and ZMachine terps don’t have an easy scrollback feature.

Is this happening only at the I7 IDE level? If so, it’s possibly worth filing as a bug if you don’t regain focus on the command prompt after you’ve scrolled it all down (or pressed space bar to have the terp do it for you), but it should play as expected on any actual interpreter.

What is terps? Anyway, a normal text adventure goes through this basic cycle:

  1. Type your action
  2. Read the games reaction to your action (repeat at 1.)

This “More” feature kinda disrupts the flow of the game:

  1. Type your action
  2. (Sometimes) reach for your mouse, scrool down, and click a little to the right of the > thing to get the focus back.
  3. Read the games reaction to your action (repeat at 1.)

The basic action-reaction cycle is the essense of playing any game. It don’t make any sense to disrupt this just to keep some past info on the screen.

To see the ‘more’ box in action, check out the example games:

I think I’ll go back to Parchment!

Quixe allows you to hit any key to scroll down until the MORE box disappears. This is traditional.

Is that not happening for you? What game and what web browser are you using?

Terps = interpreters.

I would argue that if you had to scrollback to see the text that the game printed that was more than could fit in the window would be a much bigger disruption to the flow.

The “click to get the focus” bit is the one that has me puzzled. Have you tried not reaching for the mouse and, instead of scrolling down, pressing any key? At least trying the space bar? That should scroll down to the rest of the text.

Oh, right! :slight_smile:

Okay - so this should only happen when the text that the game prints was more than could fit in the window? Then it makes sense. But to me, it happened all the time.

I tried disabling Firefox’ add-ons, and this fixed it - guess one of them was the problem!

I found this Glulx test game with the same error - or at least, it has the same error on my system. Can anyone play it with a Firefox browser and see if they’re getting unwarranted ‘More’ boxes too?

eblong.com/zarf/glulx/quixe/quix … .gblorb.js

Ok, this is pretty weird. I’m running Firefox, and the very first time I tried I ran into the same problem was you - the MORE box would NOT go away, even after having scrolled, until I clicked back on the screen. It had lost focus.

But for the life of me I can’t replicate it! It did happen - exactly once. After that, not even reloading the page caused it to happen again. Weird!

EDIT - I got it to replicate… sometimes. With a high enough font size and a browser window reduced to half in width, going N then S from the first room often triggers the pervasive MORE. Not always, but pretty often. I can confirm the bug.

Zarf, I’m using Forefox 40.0, here’s a screenie for you. Note that it’s scrolled down as far as it will go, the MORE box is still there, and there’s no cursor on the command line. Typing anything doesn’t work.

[rant]Quixe MORE bug.png[/rant]

(it’s also worth noting that, unlike some of my previous experiences with Quixe, the performance is superb and it just plain looks gorgeous!)

Since the OP also mentioned the possibility of an add-on problem, here’s a list of my add-ons:

[rant=my installed and active add-ons]AdBlock Plus
Classic Theme Restorer
Video DownloadHelper[/rant]

Thanks for testing Peter - too bad it isn’t just my machine. I have discovered that I still get the error even with all extensions disabled. To me, the error is a bit inconsistent, too. At times, the game runs just fine.

I guess that implementing a feature like More, which has to detect if the latest reply from the game is expanding beyound the browsers available space, requires a bit of clever hacking … which might go avry at times.

One thing I observed is that not all of the layout examples on eblong.com have this bug - so it’s likely caused by some specific layout.

Anybody know if I can file a bug report somewhere?

Bug reports go in github.com/erkyrath/quixe/issues . Thanks.

Thanks - the bug kinda bugged me. Filling that rapport made kinda got it off my chest.

I can confirm this! :slight_smile: