I7: Font shrinkage?

Can anybody think of a reason why the font size of the documentation, index, errors, and settings window in I7 would suddenly shrink? The fonts in each of those windows is a point size or two smaller tonight than it was last night, and I can’t figure out why. It’s especially bothersome in the documentation window, as I strain to pore through it.

Windows 7 updated itself last night, including an install of IE9, which makes me suspicious, but it’s not immediately clear to me how that would cause the shrinkage I’m experiencing. Any ideas?

I don’t know what HTML engine is used by WInform. Try IE’s zoom in and zoom out keys, maybe I’ll find a CSS that can be modified to help the problem.

Windows Inform 7 uses an IE component to display HTML, which is basically the documentation, index and errors, so it’s possible that IE9 has caused the change. I have checked Inform 7 on Windows 7 with IE9 and didn’t see any problems, but possibly I didn’t check thoroughly enough.

However, this will not affect the settings pane at all, so it seems very odd that that has changed font size. Are you sure about the settings pane? If the font has changed size in the settings pane, it should also be changed in the source pane. If that’s changed then are you sure you haven’t changed the font size in the options dialog? That should affect all font sizes for all panes.

This happened to me too, a while ago though, might indeed have been around the time IE was updated (my default is Opera, so I cannot really remember for sure when that happened). Changing the font or its size in preferences affects only the source, nothing else, not even the settings pane.

Adding to that:

Ctrl + mouse scroll affects the font size in both the source and the game pane (and nowhere else), but Ctrl + [plus/minus] only in the source pane.

The real pain is not beeing able to change font-size in the documentation panel. Last time I was writting something with I7 I went so far as to stop using the IDE documentation and open my web browser to consult it on-line so I could read it without adding more strain to my eyes (yes, it is that bad!). There are a couple of comments about it in this suggestion at the I7 forums, but I’m not sure wether we should open a new specific suggestion about font-size in the docs. Should we?

Given that some users are visually impaired, it would be highly desirable to have the font size of EVERYTHING be user-controllable.

I believe there may be an OS-level way to do that, but it would affect all apps, not just I7 IDE.

Oops, it turns out I wasn’t right about the settings panel, even though I wrote that code. Sigh. Since there are several different strands developing in this thread, I should state how the font handling in Windows Inform 7 should work. Note that this is for the latest build 6G60: if you’re using an earlier build, your mileage may vary - that’s just how it is.

The font used for everything that’s not inside one of the panes (e.g. the menus, all dialogs, etc.), plus the settings pane, is always taken from the operating system. Specifically, it’s the message box font: on XP this is usually Tahoma 8pt, on Vista and 7 it’s usually Seego UI 9pt, but if you change your OS font settings, those will be used when Inform 7 is started. This isn’t going to change: allowing them to be modified from the preferences dialog is too much messing around for too little reward.

The font used for the non-HTML panes (which is Source, Skein, Transcript and Game) comes from the preferences dialog (which in turn starts with the above message box font, but can be changed by the user).

The font used for the HTML panes (Errors, Index and Documentation) is the closest that IE can be made to get to the above preferences dialog font. Normally it should be exactly this font, but due to IE being extremely annoying in terms of its programmable font support, it might possibly be slightly out in a few corner cases of very small or large fonts.

Anyway, that’s how things should work. If this does not work for you, and you’re definitely running 6G60, feel free to report this. I have not tested extensively with IE9 based systems, but I’ll look into it to see if anything has changed there.

Well, this is curious. I’ve got 6G60 installed both in my netbook (wich has IE8) and in my desktop PC (with IE9).
In the netbook (IE8) I can change font-size in edit -> preferences menu and see how the documentation font size changes acordingly (and inmediately). This definitively is not happening in my desktop PC (IE9) in which it won’t change no matter what I try.

Anyway, in none of them I can change it using CTRL + mouse wheel on the documentation itself.

Hmmm, it would appear that Microsoft couldn’t resist messing with how font sizes are specified. I will look into it.

Indeed, but I wouldn’t expect that to work - that was never a supported feature, just a side effect of the controls used for the source and game tabs, that will get disabled.

David et al, thanks for the many rapid replies. Indeed I’m not sure about the Settings pane – the letters looked tiny to me, but then again maybe they were always tiny. It’s not a pane I visit often.

What appears to be happening for me is that the HTML font sizes are separate from the non-HTML font sizes. I can go into the preferences window and make the game and source fonts just as big as I please, but I can’t seem to provoke a less squintworthy documentation font size. I can confirm rockersuke’s result, that on a desktop where IE9 is not installed, they change in unison. (And I am running 6G60, FWIW.)

Thanks for pursuing the issue, David. In the meantime, I think my workaround will be to kick IE9 to the curb. Hopefully it won’t leave this particular undesirable behavior lingering around when I uninstall it.

Hooray, that worked, and wasn’t hard to do. If anybody else wants to dump IE9 in order to alleviate font headaches, good instructions for how to do so are at howtogeek.com/howto/29112/re … er-9-beta/.

I’ve now got a Virtual PC image with IE9, and I can see what’s going on - it seems to be due to a bug in IE9. Sigh. Hopefully this can be worked around.

Hopefully there’s some way to work around this other than downgrading to IE8 - I like to keep IE as no-fuss as possible (let it upgrade if it wants to, and so on), since I only keep it around for important web content - forms and such - that sometimes refuse to work properly in Opera. I’d hate to switch back just for Inform.

I’ve tried the following ‘quick fix’ for the font problem in IE9:

In IE9:

Open the Tools Menu (or if you haven’t enabled the menu bar: click the geared wheel, top-right, or ALT+X)

Open Internet Options and on the General Tab select Fonts (in the Appearance section at the bottom of the list of options)

On the Webpage-font list (the left-hand list), pick a new font. If you open a documentation page in inform7 it will pick-up the new font as soon as you click ok.

After upgrading to IE9 my inform7 showed the docs in Times New Roman and it was a little bit smaller on my netbook display. I’m not really sure which font/size it was using before but after the IE9 install it didn’t look as nice, that’s for sure!

I then discovered that different fonts seem to have a different default size?! I now use Arial because it’s nice and clean and it’s displayed a little larger than some of the other fonts DavidK mentioned as the system defaults. Has anyone got any ideas why different fonts seem to have different default sizes?? Or is that not really the problem?

EDIT: I noticed that on the Accessibility settings (next to Fonts), you seem to be able to use your own css. Maybe that’s a (better) way of doing it? But I can’t seem to get it to work - probably because I haven’t found a good example for my brain to cope with!

Your mileage may vary with this solution! I don’t care about IE9 at the moment - I (stupidly) installed it because windows update was nagging me and maybe next time I’ll look for potential pitfalls before installing a non-critical upgrade…

Give it a try…it might even work! I will just stick with Firefox 4 for browsing, you might need to tweak things here and there if you really, really need IE9. Yes it’s true, I also upgraded to Firefox 4 (because it was also nagging) and no problems yet to be seen!

Yes, this is probably the best way to work round this for now. The bug is that IE9 is not picking up the custom settings that Inform 7 has configured for it, so all pages are just displayed with the default font settings. As a result, making the default font name and size something more sensible will help.

I have an idea for how to fix this properly, but it will take a little while to get around to trying it.

At some point I should really get round to using something like WebKit for the HTML display, but that’s a fair bit of work, and other things have priority …

Thanks for this!

I changed my default to Segoe UI, and also checked the ‘ignore font sizes specified on webpages’ -option in the Accessibility tab, which further increased the font size in Inform documentation.

Much easier to read now, though I still hate I can’t change the text size on the fly.

I now have a fix for this that seems to work when Internet Explorer 9 is installed. It’s something of a hack, though, so I would like to get some wider testing for it. If you have IE9 installed, you’re affected by this and would like to test a new build of the front-end, send me a private message on this board.

I have been wanting to make a joke about not leaving your fonts in your jeans when you wash them for a long time now.