Hint thread for A1RLOCK

I’m playing Marco Innocenti (@Jamespking ) 's A1RLOCK. Great atmosphere, great map, great PC!

I’ve explored the middle level and now I don’t know how to progress further.

-There is a flesh-eating eel of sorts in the dark pool in the Caved In room. I have a piece of beef that I want to poison somehow and feed to the creature but I can’t find anyhting suitable. I also tried throwing the can of pressurised spraycream in the water, hoping that it would burst its intestines. Didn’t work. I even tried to cut the beef open with the rock splinter so I could hide the cream canister inside and stitch it up with the stapler. That way the beast would bite into the beef and BANG! Nope.
-I found the Duct under the Food Court drain. The valve won’t open because the opening disc/wheel became detached. I can’t re-attach the disc because it’s deformed. I think I need a replacement wheel to put on the valve, or a way to bend the original disc back into shape.
I have found that I can lug the disc around the base, but I have no idea where to go with it. I tried putting it in the dumbwaiter, hoping the weight would dislodge the elevator. No such luck
-The door south of the Screening Room is barred. The description tells me that there are no handles but that there must be some kind of hidden mechanism. I haven’t found it yet.
-In the Implausible Observatory (fantastic room name!), the whales are singing to me. It seems I can’t interact with them further. Should I?

Can anyone help me with one (or all) of these obstacles? Or tell me in which order they should be tackled, so I know where to focus my attention?


When too frustrated to go on, feel free to ask me.
Thanks for the nice words :slight_smile:

Also, you are right on track on many things. If you just need a PushDir, gimme a signal.
In the screening room be sure to examine the terminals (this is valuable almost everywhere).


I don’t know how exactly, but you have a knack for putting together maps that feel just a bit off. I thought this about your map for Andromeda Awakening too. A turn here, a bending hall there,… Not a maze, but ever so slightly disorienting. Great fun to explore and draw with my graph paper and my coloured pens.

I did examine the terminals. there’s a card slot in one of them. I haven’t found anything to put in there yet. So yes, if you would give me a nudge, I’d be grateful. I’m very curious to get to the upper level infirmary where the voice through the comms told me to go last time I heard it. The research scientists maybe? Who got to safety during the earthquake?.



  • The spray does indeed explode. Consider having it blow up somewhere where the resulting shock is usable. Also, beware of the blast. (PS: to explode it needs to be properly solicited. Maybe there’s another object you need, somewhere).
  • The meat can be dangerous even if not poisonous. You may have found something that’s quite… jagged. that can be dangerous if ingested.
  • For the rest, keep on going. You are on the right track.
1 Like


I did indeed think of putting the crumpled tin canister in or on the meat. Either I abandoned that idea after one command that didn’t work, or I just thought of it and never actually tried it. I’ll get back on it.

Yes! That’ll teach that thing.

-The flesh-eating eel has fled after I fed it some spiked beef. Underwater there is another bulkhead door. It has an empty circular housing. Oh! That disc might fit on that door… I died. → My plans for this obstacle: a) Find some way to safely carry the disc down in the water. (For some reason the game won’t let me THROW IT. As if a solid metal disc would float away on the current…) or b) Get the cream can to explode near the underwater door. The shockwave would propagate through the water and be strong enough to force the door.
-That last idea brings me to another issue: Exploding the cream can. I tried to PUNCTURE/CUT/STAB/PIERCE CAN (WITH SPLINTER), thinking that I would create a weak point in the tin and the can would burst after a few turns. Nope.
I also tried (and I was so excited about this idea!) to PUT CAN IN/ON STOVE, COOK CAN, HEAT CAN to make the temperature rise and build up pressure. Nope
-I was expecting there would be more to find once I got past the water monster. There are no new objects. I now have a spray can, a pneumatic stapler, a shiny splinter and my suit. I can’t think of a way to use any of those to rig the cream can bomb or hack the card reader on the terminal. So I guess I really have to get that underwater door open before doing anything else.

An extra nudge would be welcome.

Read these as an Invisiclue, one after the other…:

X the STAPLER. Understand how it works.
LOOK IN the ARMORED DOOR underwater. See anything similar in other places?
What happened when you tried to put the disc back in the valve in Duct?
Any chances of guessing where the Dumbwaiter goes?

You really NEED to get beyond that door in the Screening Room. That’s where all the mysteries unfold.

1 Like

Sigh this game would have needed three weeks of TESTING, not coding :slight_smile:

1 Like

-The stapler is pneumatic. It shoots staples with pressurised air. Can I use it to overpressurise the cream can?
-I assume the dumbwaiter goes from North Bridge (3-3) to the room behind the underwater door (4-3). Can I straighten out the dumbwaiter with the cream bomb?
-The housing of the disc in the Duct valve is magnetic. It draws the disc toward itself. Can I lower the disc in the dumbwaiter so that it somehow is magnetically drawn to the door? But then it would be on the other side where I can’t reach it. Should I lower the disc in the water (with a rope I have not found) so the magnetic housing catches it?

To get the order straight: fix the dumbwaiter first, open the underwater door next, then proceed to the Screening Room door?

1 Like

Yes, that’s the sequence.
You can use the stapler (as it is a gun) to SHOOT THE DUMBWAITER once the CAN is inside. But watch out for SHRAPNEL!

1 Like

And here I was blasting staples at the can while it was inside the dumbwaiter… Silly me.

Thanks. I’ll play more this evening.

EDIT: After exploding the can, the dumbwaiter is straight on its axis again. However, in the room description for North Bridge, it still says: "A dumbwaiter remains slanted in the west wall.
EDIT²: The underwater door is now unlocked. I like the spatial thinking and the magnetic mechanics behind this puzzle. To actually open this door I need the automatic mechanisms to work. That is probably done from the terminal in the Screening Room. Any slight nudges on where to find an ID card for the card reader? Or how to hack the card reader by putting something else in it?

1 Like

It would be perfect if you had a transcript of your play through :slight_smile:

You are not silly. That’s a pretty obvious choice of words, but somehow I forgot to implement it. That and MANY MORE things are due to a post-comp release.

1 Like

Well, my very first serious command (after JUMP, FART and DANCE) was TRANSCRIPT. Then SCRIPT. Then SCRIPT ON. Then TRANSCRIPT ON.


“That is not a verb I recognize.”

It seems the option to produce a transcript is not supported in the version I downloaded from the itch page.

(PS: While you were writing your reply, I was editing my last reply with a small bug/typo comment and a request for a hint on the card reader.)

Where can I found A1rlock?

1 Like

It’s one of the games in PunyJam#3 , a competition for games made with the PunyInform library.

All the games are here: Submissions to PunyJam #3 - itch.io


The door is unlocked and it opens when you get near it. Just GO EAST/WEST (I don’t remember the direction :slight_smile: ).


Oh. Right. Go in the direction of the door. That was forgetful of me. Thanks.


I’m stuck at the last command!

The whales are watching through the glass wall as Dr Celyne is coming nearer, intending to inject me with a needle. I want to order the whales to break the glass, or use my mind to kill Dr Celyne. I can’ t find the right way to phrase the command though.

1 Like

Try PUSH/PULL her (but it won’t work)

The trick is to SHOOT her (provided you still have the stapler). Other plausible solutions and the use for a very special object will be added in post-comp.



PEW PEW PEW will take care of it?

Hahaa… Brilliant!