Hint / Menu System not working for TADS 3 Web UI

Hello. For my TADS 3 game, I initially included a hint system & menus for the “Amusing” option. I initially compiled it for the traditional UI (thinking that it’d be easier), & everything worked fine. However, upon trying to port it over to the web UI, none of the menus work anymore. Instead, the game simply returns an error message saying:

“The server sent an incorrectly formatted response. This can be caused by a garbled network transmission, or by a bug in the story. If the story otherwise seems to be running properly, you can ignore this error. If the story isn’t responding or is acting strangely, it might help to reload this page.”

When I click “show details,” I get this:

"9:51:03 AM | View Details
Request ID: 8
Resource: /webui/getEvent
HTTP Status: 200 OK

<?xml version="1.0"?>mainHintsI've no idea what I am doing! Still stuck in the castle? Still stuck in your cell? qp[left][bksp][esc]u[up]d[down]ENTER


I have now gotten rid of the custom menus but retained the hint system & now always get the above result. I’m thinking it has something to do with the game trying to load a new window for the menu. Everything originally worked perfectly fine when using the traditional UI but porting to web UI now leads to this error. Any help would be appreciated. Thanks!

My game appears in the IF Archive under the indexing if-archive/games/tads/wolfenschtein_WebUI.t3. The IF database page for it is here: ifdb.tads.org/viewgame?id=9pp2nh5axfys4qsa

I can attach the .t3 & .t3m files, if seeing them would help.

Menu should work on WebUI perfectly fine, I run my game online and hint menus work as expected. However I run the game on my own server, so it must be something specific to your game or (less likely) to the public game servers.

I’ve tried your game on IFDB and Firefox tells me about malformed XML:

[code]XML Parsing error: Document is not valid. Line 1, column 127:

…>I’ve no idea what I am doing! Still…

Could you please post the part of the source with the hint definition, is there something specific? There seems to be some illegal character after the exclamation mark. 000B seems to be vertical tab character?? What’s the #charset of your hint file?

Okay. Thanks for the help. Menu system now works fine. Seems to me that the TADS3 Web UI uses Javascript for its menu system, so HTML syntax would not work; only ASCII characters would do. As such, my “new line” character appeared to have broken the system.