Help with 'Camelot Jack' (TALP Jam 2024)

I can’t even get past the first puzzle/tutorial/room. Is my brain just not working today?

I’ve been able to pick up one object (the cheese) that I can’t seem to do anything with. As it’s limited parser (and most objects aren’t implemented) there’s only so many things you can try, so I’m totally stuck. Any hints appreciated.

1 Like

Talking to swordy repeatedly gives more hints. One of them is what to do with the hilt in the stone.

Is there a command to show the inventory? I couldn’t find one.

1 Like

Thanks! No, I couldn’t find one either.

2 Likes

I’ve been plugging away at this for a couple of hours and I’m still stuck in the first room. I’ve got the cheese, sword, flint and pebble, but can’t work out how to unlock the door. I did notice that there are now strange glittering lights around the beam of moonlight, but none of those words are understood.

Can anyone give me a hint before I rage quit on this one?

EDIT: Damn. Just got an exception. Time to rage quit.

Have you tried to use the sword on the objects you have found?

What’s the phrasing for this - is it USE X ON Y? Nothing I’ve tried seems to work.

Correct. It also works with WITH. Order of items in the phrase are important. Also in this case both items needs to be in inventory.

1 Like

Hi guys

I’m Davy, and I’m responsible for all this frustration :sweat_smile::grin:

Really sorry, I just ran out of time and haven’t made some important things clear in the tutorial, and I just haven’t got the inventory working yet - I am actually working on it as we speak!

Anyway sorry that swordy is such a douchebag.

He can take four word commands

Verb noun preposition noun

Or as I like to say Do Thing With Thing :laughing:

Anyway that’s the most complicated command he can do at mo, I haven’t extended it to understand adjectives but a working on it :sweat_smile:

He can take obvs also one, two or three word commands, so take thing, look at things, push things, pull things, examine things etc and he’ll ignore articles like the, and or a so that won’t screw him up.

So you have to basically use sword on a certain object to cut it and make a new object!

Cheese and other item to come in handy later!

Also my terrible design means I also need to have him describe the room when you go on - you can type LOOK to get the description of the environment.

Not sure on exception error - believe me I’ve had a few this past month haha but thought I’d sorted it, let me know if you like and i can try and sort it :grin:

I hope you don’t hate it TOO much and thanks for giving it a try :grin::+1:

4 Likes

Ooh and also remember that, annoyingly haha, you need to call the sword item a SWORD.

Whereas if you want to Talk to swordy you need to use SWORDY

I’m trying to work out why I had to make a separate sword but there’s definitely a reason…panic most likely :sweat_smile::grin:

2 Likes

Yes, I have. I’m pretty sure I used the sword on all the objects I had. The response is always something like:

Sorry to disappoint, but, really, there's nothing that special about the pebble.
In fact, I'd say it's USE-less, ami-rite?

I might have done something that’s screwed it up. Now that I know I’m on the right track, I’ll start from scratch and try again.

Hello guys, I really want to give the game a try to help a fellow coder with his future projects, but as much as I try I cannot even get that hilt out of the stone. “Pulling it” is not enough, and “thinking in reverse” (pull stone from hilt) crashes the game. I’ve been trying for hours …

3 Likes

Yes pulling is not enough, you need to use a 4 word command, specifying where you are pulling from, PULL HILT FROM STONE. But you won’t get the sword that way, you need to reverse the action as swordy says. The reverse it’s talking about is not about swapping the hilt and the sword but reversing PULL action itself. You also need to substitute the preposition FROM with another one more suitable for the reverse action.

2 Likes

I tried every combination of USE object WITH object and eventually hit on the correct combination. After a few more moves, I am now in the second room.

The author has posted a new version that has an Inventory button, but it doesn’t understand INVENTORY as a command. It also clears the screen after every command, which is really annoying. Personally, I prefer the earlier version that doesn’t clear the screen all the time, so I might revert to that.

1 Like

Hey guys

Thanks for playing and the feedback - it’s good to know! Sorry it crashes when you reverse the nouns, that’s weird! I’ll check it out!

Yeah, I mean it’s more like “reverse the legend of King Arthur” is what Swordy meant :wink:

Thanks, I really do appreciate you having a go and sticking with it! It was a bit of a labour of love, and taught me loads.

Was clearly a bit ambitious but hell I’m not expecting to beat the other awesome games anyway.

Garry, the inventory shouldn’t clear the screen, but maybe the LOOK does, which is probably not ideal!! I’ll change that - thanks for the testing, MUCH appreciated :wink:

3 Likes

I’ve persisted with this and eventually got it finished. There are a number of things that need to be done in the correct order or it won’t work. If you strike something that doesn’t work even though it worked before, then try restarting and only use the commands that are absolutely essential. It may take a few tries, but it’s only a small game, so it’s not a big deal.

3 Likes

Back again. Does anybody have a hint for getting past the pixie’s traps?

Progressive spoilers:

  • You need to trigger one of the traps, without putting your HAND at risk.
  • Use one object that you haven’t used anywhere else.
  • Solution: put pebble into pot2
1 Like

Just to elaborate, if you examine each of the pots, you’ll see that they’re all dangerous, but one has a different type of hazard. I seem to recall that if you pick up each of the pots and examine them, you get a more detailed description of their contents.

2 Likes

Does anyone know the command for using the shoes? I tried wear shoes, put on shoes, use shoes, and then tried give shoes to man which worked but I can’t get them back. I can’t undo and can’t save the game, as far as I know. What’s the right command here?

1 Like

You don’t have to do anything special with the shoes. If you’ve given them away, this may have an impact when dealing with the trow, though I suspect not. Your next step is to solve the pixie’s test with the pots.

1 Like