Help - Instead of rule not working?

Hey everyone, writing a fairly indepth Interactive Fiction, but had a very strange issue. I’m assuming this is the forum to ask for help with it in. Now, the issue is that instead of the player looking at a specific object (in this case, a coffee table), I want one of two things/descriptions to play out depending on the value of another item. But for some reason, the game simply won’t acknowledge what ‘looking’ is, or that any variation of it is an action at all. Here is what I believe to be all the relevant information connected to this specific sequence:

<A thing has a number called interactedwith. Things have a interactedwith 0 or interactedwith 1. Things usually have a interactedwith 0.

Ostwick’s Apartment is a room. Ostwick’s Apartment is north of the Third Floor Hallway.

The leather sofa is a thing in Ostwick’s Apartment. The leather sofa is scenery. The description of the leather sofa is “A black, leather sofa. Its frame has collapsed entirely, but there’s a noticable v-shaped divet in the middle. Going by the damage I assume something heavy - like a person - was thrown down onto it with tremendous force. It fits with what a werewolf is capable of.”

The coffee table is a thing in Ostwick’s Apartment. The coffee table is scenery. The description of the coffee table is “Placeholder.”

Instead of looking at the coffee table:
if leather sofa interactedwith 0:
say “The coffee table is beneath the wreckage of the flipped sofa at the moment. If I want to look at it in more detail, I’m going to have to move the sofa.”;
say “I can see the cofee table clearly now.”.

Movesofaing is an action applying to nothing. Understand “Move Sofa” as movesofaing. Understand “Move Couch” as movesofaing. Understand “Shift Sofa” as movesofaing. Understand “Shift Couch” as movesofaing. Understand “Remove Sofa” as movesofaing. Understand “Remove Couch” as movesofaing.

Instead of movesofaing, say “There’s no sofa here to move.”

Instead of movesofaing in Seventh Floor Hallway, say “[one of]I pull the sofa out a bit and look behind it. Nothing; it seem the janitors are fairly thorough. I slide the sofa back in place.[or]I’ve already established there’s nothing beneath or behind it.[stopping]”

Instead of movesofaing during Investigateapartment, say “Whilst I’d love to distrub an apparent crime scene, I should locate Patrick first and make sure he’s ok.”

Instead of movesofaing in Ostwick’s Apartment the first time:
say “The sofa looks fairly heavy, but I think if I position myself right, I can move it. I get behind the sofa, and grab it by the collapsed ridge in the middle. It shifts beneath my grasp, but the frame’s still intact enough that I can affect the rest of the sofa. I pull at it carefully, and slowly but surely slide the sofa off the coffee table. I leave the destroyed sofa close to the wall, and slide myself out from behind it.”;
change the interactedwith of leather sofa to 1;
rule succeeds.

Instead of movesofaing in Ostwick’s Apartment, say “I already moved it. If I want a better look at the sofa, I can always look at it, search it, or look under it.”>

It will NOT recognise ‘looking’, ‘describing’ or ‘look’ with regards to the coffee table, with or without an at before the object, or if it is the player performing the action. This is my main problem. The error (and the only one that seems to show up) is as follows:

<You wrote ‘Instead of looking at the coffee table’ , which seems to introduce a rule taking effect only if the action is ‘looking at the coffee table’. But that did not make sense as a description of an action. I am unable to place this rule into any rulebook.>

I have tried using the alternative of "The description of the coffee table is “[one of] _______ [if interactedwith of leather sofa is 1] _______ [stopping]”, and whilst it reads that fine in that it has no errors, it doesn’t actually work. The description of the coffee table when the ‘interactedwith’ value is 0 is the exact same as when it’s 1 (I have no idea why it accepts the rule in the secription, but completly ignores it). I have no idea what phrase the game recognises as the action of ‘looking’ at something as I have tried all I can think of that work by default when an IF7 game runs. I’d prefer the wierder set up of the ‘if _____’ as opposed to changing the description the other way, as during this action I also want to reveal objects (I’m using Kirstin Fundin’s Hidden Items extension). Any help in what phrase the game might understand, or help in general with what I’m doing would be very appreciated.

The name of the action is “examining,” not “looking at.” So you should write “Instead of examining the coffee table.”

(A couple things you can do to figure out action names. One is to compile a project without any of your interesting code, type “actions” at the command prompt, and then type whatever command you’re trying to figure out; here, “LOOK AT ME.” It should tell you the name of the resulting action. Another thing is to look at the “Actions” tab of the Index; under “Commands A-Z” it has a list of commands and the actions that they invoke.)

If you want to use the alternative, you should make the description “[If interactedwith of leather sofa is 0]…[otherwise]…” or something like that. If there’s something you want to print independent of the if/then, you write [end if] to end the if.

[One of] is properly used like this: “[One of]This text will print the first time.[or]This text will print the second time.[or]This text will print the third time.[stopping] This text will print every time, and is the only thing that will print after the third time.” There are options with “[one of]” detailed in section 5.7 of the documentation, but it needs to be followed by “[or]”. I’m not sure exactly what happens when you mix “[one of]” and “[if]” but I wouldn’t trust it to behave the way I wanted.