Has Parchment left Infocom behind? EDIT: No

This is neither a complaint nor an accusation nor an admission nor an investigation. It is merely an FYI, as I think it is genuinely possible that nobody knows about this.

The latest version of Parchment (as downloadable from Inform7.com – I think the revision date is in July of this year) simply doesn’t work on original Infocom titles anymore. Or at least, empirically, I can only say that it didn’t work on a single Infocom title that I tried, which included a slew. I don’t remember all of what I tried but I definitely tried Infidel, Planetfall, Zork I, Cutthroats, Spellbreaker, and a few other early examples (focused particularly on .z3s but .z5s don’t work, either). Most of them no longer launch in Parchment at all – Planetfall launched successfully (it was the only one) but the display was a mess.

When I downgraded Parchment back to a 2010 version that came with Inform 7 then, everything worked perfectly again – all Infocom titles launched successfully. Except there was that annoying cursor-displays-below-the-input-line bug in Firefox and Chrome (but not Safari). This is the bug that I was trying to get around by upgrading my parchment.

Do not accuse me of enabling any piracy – not that I am above piracy but in fact I purchased all of these games, many of them more than once, and I have the legal right to set them up so I can access them in any way possible and from any kind of device I desire, so you would just be plain factually wrong about that if anyone thinks that preserving web functionality for Infocom titles has anything to do with enabling piracy. I just hope that this is not the actual intentional future of Parchment or some kind of intentional developmental break. I hope that the situation is simply that nobody else really noticed b/c people don’t generally do the things I do, or still care about the things I care about.


What version Parchment is it exactly?

Hi Dannii,

Sorry, I should have mentioned.

“Parchment for Inform 7 (2013-07-29)”

I accessed it yesterday by visiting this page… raw.github.com/curiousdannii/pa … nform7.zip

Anyway I take it maybe this was not the best way to find the latest version? Hoping this is the case.

No that is the latest version, but Parchment for Inform 7 is cut down and only supports versions 5 and 8, just to make the file size smaller. If you use the full Parchment it will run versions 1-5 and 8.

I recently changed how the display system works too, so it’s possible/likely that there are bugs. If you’ve got a version 5/8 file that doesn’t work properly let me know and I’ll take a look.

OK thanks for that info. Can you provide me with a link to the full latest Parchment version that will run all zcode? I really don’t have any faith in my ability to locate the correct files to install on my own.

Also, this must have been a recent development, since the version of Parchment that came with Inform 7 in 2010 clearly does run all the Infocom releases, including .z3 and .z4. I have tested all the Infocom zcode now with Parchment 2010-10-18 that came with an Inform 7 installation I still have from that year, and excepting the cursor bug, only Zork Zero fails to work properly with it. (Which is no surprise since AFAIK .z6 has never been supported in this manner.)

Personally, I wonder why this decision was made. Considering that the files involved in Parchment are all of negligible size, there doesn’t seem to be any technical purpose in reducing its footprint within Inform 7.

P.S. There may have been other Infocom .z5s that didn’t work, but the one I recall for sure is that Planetfall.z5 doesn’t work – the status line doesn’t stay confined to the top, but instead prints black inverse blocks all the way down the screen. Furthermore, if you try to actually type anything and press return, it immediately beachballs and crashes. This is with the Parchment version I mentioned (13-07-29) and Planetfall.z5 Release 10 / Serial number 880531.

EDIT: And I tried it (Planetfall.z5 with Parchment 13-07-29) in at least one other browser besides Firefox and it also messed up the display and crashed, though I can’t now remember if my second browser test was on Safari or Chrome. Had to be one of those two though – for OS X.

The main Parchment will support v3: github.com/curiousdannii/parchment There’s a download button on the right.

The old Parchment for Inform 7 versions used Gnusto which supports 1-5, 7-8. The new Parchment uses my new VM ZVM which only supports versions 5 and 8. I didn’t think there was any reason to include both when you can’t make anything but 5 and 8 with I7.

I’ll take a look at Planetfall.

I was at that page yesterday but did not understand the way it was laid out (not really github-fluent, so this often happens to me with github or googlecode pages – for some reason I can find everything but the link I need). So thanks for that. If I had seen that page again on my own, I would have skipped it as already investigated.

If this goes well then I may have more data for you soon regarding bugs in other Infocom titles, as I will end up updating (and therefore testing) every title.

You can add &vm=gnusto to force it to use Gnusto if needed. The v3 statusbar doesn’t work.

To what would I add that? Basically I just took the .html files I had set up for each game in Parchment 2010, copied over the relevant library files and modified the .html a bit to match the new setup (2010 version referred to 'parchment.css; but now the 2013 reference is to ‘parchment.min.css’). And that worked. Except as you say, the statusbar doesn’t work. I tried adding ?vm=gnusto to the page’s URL, but that doesn’t do anything (didn’t really expect it to).

EDIT: Then I tried matching the including ‘parchment_full.html’ file instead of the ‘index.html’ file and that involved changing ‘jquery.min.js’ to ‘jquery.js’, and ‘parchment.min.js’ to ‘parchment.debug.js’ , and then adding ?vm=gnusto to the address when accessing the page, and that still loaded the story file fine, but still no status bar.

EDIT 2: And then I changed ‘parchment.min.css’ to ‘parchment.debug.css’ which I should’ve done in EDIT 1 but forgot. Still no luck.

To the URL, but nevermind about it actually. It would only be useful if your files were misnamed, such as calling a version 3 file .z5. (Such as from here batmantis.com/zorks/) It won’t help with the status line.

I’m in two minds about this: it would be good to get the status line working in v3, but… I don’t want to touch Gnusto any more.

Well if you don’t want to, you don’t want to. I can’t really convince you, nor do I feel it’s wise to try to convince someone else to spend their valuable dev time on priorities they don’t personally feel are important enough to justify the hassle. I also have no idea how difficult the fix would be so I don’t know to judge. I suppose I can just stick with Parchment 2010 and its cursor problem in Firefox (read: Gecko browsers). It’s not showstopping, it’s just offputting so I was just trying to avoid that so the original Infocom games would look presentable when I need to pull them up on a device without installing anything – usually I do this to check something historically myself in which case the bug doesn’t really matter, but sometimes I want to show it to somebody or demonstrate the way something was done in the classics, and in those cases, I prefer them to present in as pleasing a manner as I can set them up for all possible devices.

Is there a version of Parchment from before you changed the display system but in which the cursor problem is already fixed? If so, then I could just run that… maybe Parchment 2012? Can I still get ahold of that?

There may be a version like that, but I can’t remember which one it would be sorry. It could be that it was working in the browsers of that time. I’ll try to take a look tomorrow and see if I can find anything useful for you.

Not really a fix for the problem, but re Planetfall and .z3: Planetfall is one of those games that were later released as “Solid Gold”. I may be wrong, but I think the SG games were .z5 - if nothing else, at least to make space for the built-in hints.

While it won’t fix the issue generally, if you wanted to show off a SG game in Parchment, if it really is .z5, then that would work, wouldn’t it? Regarding the statusbar issue?

DISCLAIMER - Personally, I am always all for a ZCode interpreter that runs .z1 to .z8 perfectly, and which includes arrow keys, keyboard functions, sounds, graphics and .z6. So of course I consider the windows version of Frotz to be the Messiah (and if not, then at least a very, very naughty boy). So if Parchment were ever to go this route I think it would bring nothing but general goodness. Having said that, one must be practical.

I see Parchment as an interpreter for contemporary works, and don’t see Infocom’s as a big priority. Not that I wouldn’t want to support them if I could, but when they can’t be legally shared, and when they need a different VM I just don’t think it’s worth it, especially seeing as Frotz does exist. We need fast interpreters for the heavy I7 works, and supporting v3 in the one engine will make that very hard, at least the way I’ve designed it. And eventually I plan to use Glk for ZVM’s UI, which means v6 is out of the question.

@Peter Planetfall.z5 doesn’t work in the latest version of Parchment due to what I perceive from this disussion is a bug unrelated to the reason .z3s don’t show a status bar, i.e. it shows a status bar in fact it OVERshows a status bar.

Regarding Frotz, yes I have this installed and it works great on an iPhone (I don’t have Windows) but there are many platform with a poor (incomplete) implenetation or no Frotz at all. However, almost everything these days has a browser and pretty good javascript performance, so Parchment has the potential to be a much more reliable ‘lingua franca’ interpreter than Frotz. Also once it is set up on one’s personal server, one does not have to install anything to display a game: I cannot stress the importance of this enough. One may not be able to legally ‘share’ them but one can demo a game to other people without breaking any laws, and usually they don’t want you to install anything if you’re just trying to SHOW it to them. (In case it’s not clear, I do tend to try to recruit people to the form.)

Anyway, it would be less of an issue if there were at least one version of Parchment that ran Infocom on the major modern browsers without a glitch, and if that version were still available then I bet we could sit pretty on that for a long time – after all, it’s not like the Infocom collection is ever going to change again, nor are web standards likely to get less back- and inter-compatible than they are right now.

The solution I propose is if Dannii can find the latest version of Parchment that doesn’t break Infocom, a link to that might be released as a legacy download for anyone who wishes to set them up in this way? I can’t see a good reason to really prevent it nor to hide the best Parchment interpreter for Infocom from public use. (I’m not saying anyone hid it – I’m just saying maybe that’s the one release that shouldn’t have been automatically taken offline by the later development process, since it may have key capabilities that will never be replicated in the future releases. If the perfect ‘Parchment for Infocom’ release already exists without anyone doing much work, besides uncovering it… bob’s our uncle, right? – To that end, Dannii, I am willing to test any candidate versions you might uncover with every single Infocom title and report back on whether the cursor glitch is taken care of and that eveything else works OK with Infocom in that version.)

You might try the fork I have in this branch: github.com/erkyrath/parchment/tree/zarfsite

(The “zarfsite” branch, not “master”. Use zarfplay-full.html as the base HTML file.)

This is what I use on my own web site and pr-if.org/ . I hacked it up when Dannii was in the middle of replacing Gnusto and I needed a working version in a hurry. I don’t promise it’s perfect, but the cursor isn’t misplaced, and it runs Planetfall (v3) semi-okay (the status line appears but has a transparent background). Zork 1 (v3) runs but the status line is missing. Inform-generated v5/8 games are solid as far as I know.

Thank you zarf, I will try it soon – it’s too bad about Zork I and Planetfall. I don’t have a playable copy of Planetfall.z3 anymore though. (That’s likely the one I originally played, but the difficulty of extracting zcode from my old Apple II floppies means most of my Infocom files were pulled from my ‘Lost Treasures of Infocom’ Macintosh disks, and that’s where I got the .z5.)

I think you’ll find Google will help you get that particular version of Planetfall and many more besides. :wink:

OK I tried this fork on a whole bunch of Infocom titles. Besides your display customisations, results are almost identical to the latest behaviour of the main fork: no cursor issue, but also no status bar on any .z3. I tested all sorts of stuff and the only game that I could find that behaved any differently was the aforementioned Planetfall.z5. Whatever the bug is on that title, it doesn’t exist in zarf’s fork. Though the status line is ‘transparent’ (i.e. not a continuous solid black line) it doesn’t repeat itself down the page, and the game doesn’t beachball when you try to type a command. So, there’s that.

EDIT: I started digging more into .z5s. Turns out, almost none of the Infocom .z5s I have work right on the latest Parchment. (I don’t have that many .z5s – I think Planetfall is the only ‘Solid Gold’ release I have.) Sherlock.z5 has exactly the same problem as Planetfall.z5: statusline running down the page and command-freeze. As with Planetfall, this problem does not occur back in zarf’s 2-year-old fork. BeyondZork.z5 seems like it might work except that the opening menu disappears and I can’t see it to make a choice, so I can’t start the game. This happened on both forks. BorderZone.z5 works in both forks including status line. (At first I thought there was a problem because the status line was three lines thick, but nope, that’s really the way it was in Border Zone I guess, b/c it’s the same in Gargoyle.) And those are all the Infocom .z5s I have.

Trinity.z4 and AMFV.z4 work fine and show a status line in both forks. Bureacracy.z4 has a disappearing text problem much like that of BeyondZork, again in both forks. And those are all the .z4s I have.

To sum up, after further tests, only Sherlock and Planetfall(.z5) work better in zarf’s fork. Also, .z5 support for Infocom is now actually much poorer than .z3 support in the main fork, in general (not just with Planetfall but almost every Infocom .z5 is unplayable), which I did not fully realise until now.

I am able to start up Beyond Zork in my branch. The scrolling div is too tall(*) and I had to do the menus blind, but I got it started. (The enhanced status line works, except for the mini-map, which is blank.)

(* Or rather, I think, the game prints too many blank lines before drawing the menus. This would not be a problem except that menu input causes Parchment to scroll back to the top of the story div, when the prompts are at the bottom and the menus are partially or fully invisible anyhow.)

Overall: drat. I suspect all of this status-window failure boils down to a single bug, and I had hopes that it was one I had solved, but apparenty not.

I agree it would be good to support Infocom games – the historic value outweighs the (possible) inducement of additional copyright violation, and I’m not worried about increased code size in this branch.

Sadly, I can’t call it a priority this month. As I said, I built this fork to host my own games and a small selection of other Inform games.