Hard Puzzle

Hi all,

During the IF Comp, we were challenged to write a short game. Mine was called Hard Puzzle. It’s only a silly little puzzler - A speed-IF that should take all of 10 minutes to complete. But if you like this sort of thing, then this is the sort of thing you might like.

I’ve popped it on IFDB here : ifdb.tads.org/viewgame?id=81afnluyffpxa8iv

First person to complete it and IM me a transcript here wins a prize of much kudos :slight_smile: It is quite a Hard Puzzle.



I have not yet finished the puzzle, but here are the things I came across so far that stood out:

[spoiler]- the stool base is a container. I first tried putting a leg in the base. This actually put a leg inside the base, instead of trying to put it in one of the holes, breaking the immersion. I think you’d want to prevent this behaviour (and maybe show a message about attempting to put it in the holes instead)

  • The ‘crossbar’ is referred to as ‘a t-shaped brace’ in its description. However, the alias ‘brace’ is not recognized (And neither is ‘bar’).
  • oh my all the different metal rod lengths :laughing:
  • I love what happens when you sit on the wobbly stool
  • smelling any of the components or listening in the room does not give any flavour text.
  • I tried flipping over/turning the instructions and the box, but both do not work. This would be a place to add flavour text, e.g. ‘reading the japanese upside-down does not make the characters more understandable’.
  • examining the rubble after stripping away the garage door, reveals bricks and blocks. ‘bricks’ however is not aliased. Also, maybe add a custom prevention message when trying to pick them up?
  • I love the mysterious references to The Event and The Family
  • Attempting to take the wobbly stool shows that's fixed in place. Better would be a message like ‘if you pick it up like it is now, it would probably fall apart again’.
  • It is possible to put all objects that exist at this time (the rail,pulley,sheets,rods,etc) on the stool without it collapsing (put all on stool). Maybe restrict the amount of stuff that can be put on top? Also, I would expect the rods to roll off when attempting to place them.
    -I would expect verbs like ‘combine’ or ‘brace’ to return a message like ‘you try slamming the objects against each other, with no effect.’
  • The short rod has a small threaded hole in its description, but I have been unable to interact with it (put something else in the hole, or examine it). It seems to be a screw-hole, but things like ‘screw objectname’ does nothing, while ‘screw objectname on short rod’ is not understood by the parser.

That is how far I am now. I expect I need to combine the ‘threaded hole’ on the short rod with something else in some way, but I’ve run out of ideas at this time.[/spoiler]

That’s my two cents. More might follow if I can figure out how to continue ^^’


I have made a lot of progress, but may be blocked by a bug…

[spoiler]I have dismantled the shelves and the cardboard box. I have made a lever. But when I >lever rubble, I get no response, just a carriage return…

You are carrying:
heavy staples
fragments of cardboard
a length of tape
a lever
a big wheel
a small wheel
a plastic bag (open but empty)
a metal rail
a crossbar
a long metal sheet
a shiny metal sheet
a second long metal rod
a first long metal rod
a page of instructions
an aluminium sheet

lever rubble

Is this truly a bug, or should I be able to progress?


This is not a bug.

Some stuff you can do, Bob:

[spoiler]DIG RUBBLE repeatedly. This should unveil a car trunk, which you can incidentally take. Then lever the car trunk open. Dismantle what you find inside, I guess.

At this point I have no idea what to do, or even what I might think of doing other than randomly trying to combine things with other things, so if you have an idea let me know.[/spoiler]

Whatever you do, don’t put the lever into the trunk and then close it, because you won’t be able to open the trunk again! I guess that’s why this has a Forgiveness Rating of Tough.

i sat down on the thing after i did a thing to another thing and then one of the things that was part of the thing i sat down on was no longer available to me

I’m not here to be helpful but if you did what I did you’ll know what I did.

Hey Wes

There’s a thing you can dismantle and then you can find the thing again.

Also, for anyone tempted, the “ten minutes” claim appears to be pure trollery.

I believe Andrew Schultz managed to complete it so it’s solvable.

No. He didn’t. He cheated. :slight_smile:

Andrew Schultz is my new hero now.


Also, the claim that this is not a “guess the verb” game is definitely suspect. :smiley:


I’m guessing based on the various bits of flavor text that

my character is a zombie and the “legs” are human legs.

Haven’t got to the punch line yet, if there is one, but am I right?

Nuh-UH :laughing:. I burst out of my own abstract-puzzling persona and became more than what I was! I thought outside the box and used all available tools at my disposal!

Tools I’d feel sheepish mentioning in this thread, because someone would (and should) say “C’mon, dawg,” and be totally right. However, I’ll defer to Ade to mention what I did, as I won’t mind a little ribbing once this is all said and done.

I wouldn’t dream of doing so. However, since the CheatGate ‘episode’, I changed stuff slightly to make such a method of cheating implausible. Try it again :slight_smile:

matt w, is there a specific syntax I need to use to lever the trunk open? open, dismantle, lever, etc don’t seem to work, either by themselves or with any of the lever-shaped items I have. Or is there a specific “lever” object I need to find?


I don’t know the solution yet, but I hope it’s like the last puzzle in So Far.

Don’t tell me the solution to the last puzzle in So Far!

A “ferret out the noun” game even.