GUEmap not wrapping text in Windows 10?


I’ve just noticed, since the latest update to Windows 10 (The ‘Creators Update’), the IF mapping tool GUEmap no longer word wraps text to fit in it’s box ie…

I’ve just spent 4 hours trying to fix this by playing around with compatibility settings etc but with no luck. The only ‘solution’ I can find is to manually enter carriage returns when entering text by using Ctrl + Enter.

Can anyone else confirm this or is it just me? Any suggestions of a fix? I know other mapping tools are available but I have always preferred GUEmap & I guess something like this was bound to happen sooner or later with any software that hasn’t been supported for over a decade.

I’m the author of GUEmap. I have the Windows 10 Creators Update (Edition Windows 10 Pro Version 1703 OS Build 15063.296) and word wrapping is still working fine for me.

Looking at the source code (which is available on the GUEmap Development page), word wrapping happens in CMapView::wrapRoomName (MapView.cpp). It’s creating a printer device context to measure the text size. (I don’t recall why I did it that way.)

So my guess is that you don’t have a default printer set. I just noticed that my printer had disappeared from the list, but I still had a PDF printer installed. I had to turn on my printer and wait a minute or so before it reappeared in the list.

Try opening Windows settings, Devices, Printers & scanners and make sure you have a default printer.

Setting the printer default happily has fixed the issue :smiley: Many thanks Chris, your help has been much appreciated.