Glulx Inform extensions don't work anymore?

I’m at the latest version of Inform 6M62.

I’m tryin to use some of the basic glulx extentions for Inform, ie; Glulx Status Window Control because I want to give the game a nice looking top banner line.

It doesn’t work at all. Many of the Glulx extensions I’ve added fail as well. There is NOTHING in the documentation indicating that they’ve been made obsolete, but yet…

What’s going on here? Is the IF community fading out?

Inform 6M62 was a big change from the previous version. Lots of extensions broke, though some only superficially.

The main thing is that the newly introduced Public Library is a repository for extensions that have been checked in their up-to-dateness. That doesn’t mean all extensions that work are in there, but the core ones are, and ones that authors have vouched for and tested and had added to it.

If you use extensions from before 6M62, or from inform7.com/write/extensions/, there are no guarantees they will work.

I think the public library is still not built into non-Mac versions

  • If you’re using Mac OS X, the extensions are available from the public library section in the Inform 7 application. With your internet turned on, click the Extensions tab at the lower right of your window, then the Public Library tab in the top right corner. The extensions are in section 11.2 - ‘Out of World Actions and Effects’ - ‘Helping and Hinting’.)

  • If you’re using another platform, visit the rough’n’ready for-now folder equivalent of the public library online: emshort.com/pl/payloads/

-Wade

You’ll have to provide more details of what you tried, where you got the extensions from, and what the errors where. “It doesn’t work” isn’t enough for anyone to be able to help.

This is not correct. The Windows and Linux versions now support the Public Library.

Hooray!

-Wade