Getting around "That can't contain things"

Hi again! I’m trying to let the player throw (drop) seeds into a fountain, but I keep getting told that the fountain can’t contain things! Here’s the code…

I also tried using “Before” but got the same result. Strangely, after making the fountain a container (which I want to avoid), the game still would ignore my code and would say “You put the seeds in the fountain.”

Anyone know how to make the code behave?

The issue is that there is no action called “dropping in”. Inform interprets your rule as “Instead of dropping seeds (while the player is) in the fountain”. You can verify this by making the fountain an enterable container, going inside the fountain and typing DROP SEEDS.

The command DROP x IN y translates into the “inserting into” action, so if you change the rule into “Instead of inserting seeds into the fountain” it should work. (You can find out the names of actions in the actions tab of the index, or by commanding ACTIONS in the game before trying the action.)

This works (well, it works as far as it goes) but it does the container thing. Is it critical that it can’t be a container (here, it’s a container you can’t put anything into):

Garden is a room. "This is a lovely garden, with a fountain in the middle."

The fountain is in the garden. The fountain is scenery. The fountain is a container. The description is "It's the finest fountain you've seen all day."
 
 The player carries some seeds. The player carries a rock.
 
 Check inserting:
     if the noun is not the seeds and the second noun is the fountain begin;
        say "Nah." instead;
        end if;
     if the noun is the seeds and the second noun is the fountain begin;
        remove the seeds from play;
        say "Woot. You totally did that." instead;
        end if;
        

Dern it, I hate it when it’s something simple I missed. Thanks!

Juhana’s got good advice. The debugging command “actions” can tell you the name of every action you try during the game. It’s useful!