Gargoyle issues on Mac


#1

I just upgraded my Mac to Mojave, and Gargoyle stopped working.

The first problem I had looked like this:

I was a little surprised to see that the response was “You have to build from source/issue closed.” There’s no new binaries that fix the problem? But ok, I’ll build from source.

Building from source solved that problem, but then I had a new problem - not for my account, but for my kids:

# logged in as me
$ open /Applications/Gargoyle.app
# Gargoyle starts with no problem
$ sudo -u otheruser open /Applications/Gargoyle.app
The application cannot be opened because it has an incorrect executable format.

When my kids try to launch Gargoyle from the finder, they get a slightly different but similar error saying that the application doesn’t work with this computer.

Can anyone tell me what’s going on or how to fix it?


(Petter Sjölund) #2

Is this the same issue as this?

There hasn’t been an official release of Gargoyle since 2015, but the problems on recent macOS have been fixed in the Github repro, and fixed unofficial Mac binaries can be found here and here.

The latter includes support for Retina screens, but unfortunately seems to introduce a couple of new bugs.

EDIT: I see now that you say it used to work on Sierra, which seems weird. Both the builds I linked to work fine on Mojave as far as I can tell. I have yet to find a version that works on Sierra but not on Mojave.

EDIT 2: As for the other problem, have you (and your kids) tried opening the app by right clicking on it in Finder and choosing Open from the contextual menu, i.e. the usual way to open apps from unidentified developers?


#3

Thanks for your thoughts, Angstsmurf. I can try opening in the contextual menu next time my daughter logs in.


(Petter Sjölund) #4

On second thoughts, I’m not sure that it will help. I googled that error message, “The application cannot be opened because it has an incorrect executable format”, and although I couldn’t find a good explanation, it seems to mean that something went wrong when the app bundle was created in the first place.

It is probably a better bet to try those newer unofficial versions I mentioned.