Fully removing actions, Alert & Note text.

I have a couple of questions…

First, id like to fully remove some actions, so that it gets a deafault response, not just remove the words that lead to the action. How do i do this? ( i have read everthing on modifying them, changing them, adding them, lol, but not removing an entire action)

Understand nothing as “blank”. This will just remove everything leading to the action, but not remove the action, right?

Also, im using Glulx Text Effects, by Emily Short… in the extension it says that a few text styles come with glulx, two of them being “alert-style” and “note-style”. However, i cant seem to reference them in my source… i try the same things i would use for italic and bold like [bold type] but none of it works… (including [alert-style] [alert style type]). Does anyone know the proper syntax for those?

Finally, where can i get updated extenisons? i notice quite a few compiling errors right of the bat when trying to use anything that has to do with flexible windows, i noticed on github that joningold new version is much higher than the one that Inform is pulling up… or can i get them right there from github? (sorry github has always eluded me on how the heck to use it lol)

Thank you for your time!

  1. What is the difference in this case between removing an action and removing all the words leading to the action? Both will get the same error message from the parser.
    2 and 3) Which version of Inform are you using? That makes a difference for getting proper extensions. (I’m guessing it’s either 6G60, 6L02, or 6L38; look at the About screen.)
  1. oh, ok then. I thought it still left the base action. For instance, if i said understand nothing as “ask”, i thought it would still leave the “ask” action, just nothing that lead to it. thank you. 2) i am using 6L02
  1. That is indeed what it would do. But if the player can’t trigger the action, what does it matter if it’s still in the code? (A lot of the basic actions have I6 code underlying them and can’t be removed completely without side effects deeper in the template layer, though I think “ask” should be fine.)

  2. I usually use this extension combined with this one for that, though there are other alternatives as well. If you go this route you can use HTML-esque text substitutions to switch styles:

[alert]alert (or sometimes bold-italic)[/alert]
[note]note (or sometimes anti-bold)[/note]

I want to point out that even with zero extensions, Inform 7 6M62 generates different behavior for Z-Code vs. Glulx targeting. I tested this on both Windows 10 and Linux Ubuntu 16.10.

North Styles is a room.  "The 'D' italic in that room description, such as [italic type]this italic text[roman type] should not be bold according to the stylehints I have studied that inform 7 6M62 is generating for this story file (Z-code .z8 target). set style is called to set style_Alert stylehint_Weight to 0 and stylehint_Oblique to 1. This is bold off, italic on. :::: Ok, what if [bold type]turn on bold type [italic type]turn on italic type[roman type] now return to roman type; [italic type]italic again; [roman type]roman type. Same Inform 7 6M62, target Glulx, and it comes out different. Try further North.".

This will come out different, in Z-Code z8 the bold and italics will merge where in Glulx they will not both be on at the same time. Again, this is with zero extensions! This makes a lot of the documentation out there very confusing :wink:

I see there is a part about having bold and italic at the same time in Typographical Conveniences. How do you say that?

Kind of messily. I use stylehints to specify that Alert style should be bold+italic. Then special “continuing” substitutions switch to and from alert, using different phrasing if it should go back to bold, italic, or normal afterward.


Regarding the Z-machine versus Glulx issue, that’s unfortunately interpreter-defined behavior. From the Standard §8.7.1: “The specification does not require the interpreter to be able to display more than one of these at once (e.g. to combine italic and bold), and most interpreters can’t.” There’s a hacky way to figure out whether the interpreter actually allows bold-italic or not, but it only works with version 6, not v8.

Thank you and Happy New Year.