FrobTADS3 and curl [SOLVED]

Trying to install the new Frob on Debian 6.0.3, I ran into the error of not having curl recognized. This seems odd to me as when I look inside Synaptic, I clearly see libcurl3 installed. =]

A search on the internet yeilded a very unhelpful result.

Any help on getting this working would be gratefully appreciated, if I may be so redundant.

Thanks in advance

Hot diggety damn! I was talking on the phone with a friend of mine while posting the above, and he laughed at me and informed me that libcurl is up to v4 now, so I likely was using an outdated lib. I looked through Synaptic, found libcurl4, installed the -dev package, and what do you know, install success. Sometimes you just have to not trust in package managers keeping you up to date I guess, lol. :unamused:

Sorry for the board spamming, carry on.

I had the same problem attempting to compile Frobtads. I installed a dev version of the libcurl library and it worked fine … but it’s also complaining:

configure: *** A curses library is missing. The interpreter cannot be built.

Any idea which curses package it would be looking for? There’s a few of them. Using a *buntu 18.04 LTS.

It’s libncurses5-dev.

Thank you so much for that. The configure process completes, but unfortunately, the make process aborted.

tads3/tct3stm.cpp: In static member function ‘static void CTPNVarIn::gen_iter_init(CTcPrsNode*, int, const char*)’:
tads3/tct3stm.cpp:318:24: error: ISO C++ forbids comparison between pointer and integer [-fpermissive]
if (create_iter != VM_INVALID_PROP)
Makefile:6599: recipe for target ‘tads3/tct3stm.o’ failed
make[1]: *** [tads3/tct3stm.o] Error 1
make[1]: Leaving directory ‘/home/rms/Downloads/Linux Software/frobtads-1.2.3’
Makefile:3011: recipe for target ‘all’ failed
make: *** [all] Error 2

I went to github and got 1.2.4 release there, and that seemed to work fine. Leaving this here for future TADS explorers.

Now to make my TADS masterpiece :wink:

1 Like

I am from the far-flung future. This information has helped enormously.

In short:

  • sudo apt install libcurl4-openssl-dev
  • sudo apt install libncurses5-dev
  • git clone
  • cd frobtads
  • ./bootstrap
  • ./configure
  • make
  • sudo make install