fizmo input-file encoding?


I’m using fizmo-ncursesw 0.7.2. It’s working great, except when game commands are run from an input-file, the accented letters (“ä”, “ö”) turn into “C$”, “C6”. Is there a workaround or something? I tried to replace the letters (in the input-file) “ä” and “ö” with “[155]” etc. like some other interpreters, but it didn’t work with fizmo. Perhaps I should see that the input-file has a specific encoding?

While not an encoding solution you could always replace the umlauts in the input-file with their two-letter counterparts:
ä -> ae, ö -> oe, ü -> ue

Thanks. That could be an option, but I can’t make the Finnish library work with “ä”, “ö” substituted as “ae”, “oe”… This is a bit technical I guess, as some interpreters (like xfrotz) figure out accented letters from an input file.

It looks like fizmo-ncursesw saves the command records file as utf8, but it can’t read it – keyboard input with “ä”, “ö” works however. I changed the input-file to iso-8859-1, but same thing happened (as I explained in 1st post)


there’s a new beta – currently source-only – at … -b7.tar.gz which should hopefully solve this problem.

Happy new year,

Thanks! I’ll post here as soon as I get it compiled.