Farm Quest-Testing and general opinions

I designed an interactive fiction for a business of game design course and I would appreciate any feedback, whether its bugs or incomplete object descriptions or any sort of usability issue, as well as general opinions on how enjoyable or un-enjoyable it is. This is my first interactive fiction and working with Inform 7 was both fun and frustrating. I plan to make more updates when I have more time to work on it.

The game can be played on my host site.


Hi, after a few turns I’ve noticed a couple typos:

[spoiler]In the first speech, “folliwng” should be “following” or maybe “followin” and you have an “it’s” that should be “its”

“He hides it from the wife as he recieved it” should be “received”

there are a few stray quotation marks, too.[/spoiler]

More importantly,

The room description for the stables doesn’t change after I’ve let the horse out – the horse and flies are still said to be there.

I’d also suggest that

“search straw” should yield an indication that there’s something you can’t reach near the horse, and then should actually yield the key if the horse is gone.

I also had this sub-optimal interaction:


You probably want a rule for printing the name of the box that prefaces it with its locked property, and also a rule that says “understand the locked property as describing the box” (not too sure about that). And there seems to be another bug in here – I’m not sure how the second message happened, but isn’t there supposed to be a gun in here?[/spoiler]

Finally, you should probably “Use American dialect” – it feels weird to have the word “recognise” show up in this game.

Quick run-through of what I’ve had time to look at so far:


  • In the first room, “x tools” leads to examining the shelves instead. “x tool” tells me I don’t see any such thing, even though I see a whole shelf of them.
  • “x toolbox” tells me I can’t see any such thing, but “x box” describes the toolbox.
  • Trying to take the box tells me it’s fixed in place, which is fine. But it would be nicer to tell me why it’s fixed in place. Is it too heavy? Too large? Am I a duck?
  • In the pig sty, I’m told that there are walls covered with shelves and equipment. But when I try to examine either, I’m told they don’t exist.
  • Why am I talking to animals again? Maybe we’ll find out later on…
  • I like the description of the pigs.
  • In the hen house, I’m told there’s a large box with a hole in it. I can’t examine that, either.
  • When I open the toolbox, I’m told that I unlock the “lockedbox”. You need some love from: The printed name of the lockedbox is “The Toolbox”. Understand “toolbox” as the lockedbox.
  • When I unlocked the box, I’m told “You open the lockedbox, revealing .” I tried examing again and got the usual description. I tried to look inside the box and was told it was empty. Then I looked at my inventory and saw the instructions.
  • So now I have the instructions. I’m not sure how I feel about having to complete a puzzle to get instructions on how to play the IF. I mean… If I got this far, haven’t I already kinda figured it out? Or maybe this wasn’t what was in the box, since I didn’t do an inventory before I opened the lockedbox. I just kind of assumed my inventory was empty. My bad.
  • The pigs are too absorbed in their food to consider “replaying”. Should be “replying”.
  • I can get the scarecrow. But I couldn’t get the lockedbox. After taking the scarecrow, it’s still in the description.
  • In the woodland path, I see “acrons” instead of acorns.
  • In the kitchen, there’s a chicken. But I get more “you can’t see any such thing” when I try to examine it.
  • Or any of the other scenery items in the kitchen. Back to the sty to presumably feed the pigs their children.
  • After I take the bacon, it’s still in the description. Maybe I didn’t take all of it?
  • I try to take more, it says I already have it. When I try to eat it, it says it’s inedible. Maybe the old bat is a horrible cook.
  • Where did that silly horse go?

Okay, well, that’s about all I have time for at the moment. I can’t give the bacon to the pigs, which it seems I should. I can’t take the hen, body, chicken, remains or corpse for the chickens.

So… I’m stuck! I’ll take another crack at it soonish.

Overall, good opening effort, I think.[/spoiler]

[spoiler]Okay, so I did already have the instructions.

  • When I talk to the horse, I’m advised to ask him about the treasure instead of saying hello. Why wouldn’t I introduce myself first?

Okay, so I tried again. I still can’t get the chicken corpse, still can’t get anything out of the box and still can’t give the bacon to the pigs. Am I missing something?[/spoiler]

I’m surprised giving bacon to the pigs doesn’t work… This feedback is very useful, I appreciate it. I never did have a proper chance to run more play testing other than my professor’s play through, which was lenient since many of us struggled with getting Inform 7 to do what we wanted, let alone design a good narrative flow. Its pretty fun when you have time to work with it though.

Well, I like the description of the pigs. So…

[spoiler]I’m curious as to what happens when you give the pigs the bacon, once you make it work. However, in the initial description, you capitalize TASTE like you’re supposed to taste the bacon or have them taste the bacon. You emphasize taste over smell or giving. If tasting isn’t involved in the action, I’d take the emphasis off of it.

So make the pigs workk, man! (or woman, whatever the case may be)[/spoiler]