Extension Requests and General Discussion

(Andrew Plotkin) #21

Heck yes.

(Peter Piers) #22

Quoted because I’ve already asked this and got no answer. I get from the following post that, as I’d suspected (but hadn’t seen confirmed), the Windows version of Inform can’t access it yet. But is it therefore unaccessible, or accessible like a normal website?

#23

You can download them from emshort.com/pl/payloads/

(Peter Piers) #24

So does that mean that that link is the Public Library? Or is it a way to access it for non-Mac users?

EDIT - Nevermind, got my answer:

emshort.com/pl/

EDIT 2 - And I now understand how it works, and thank you for your link which gives me access to the actual extensions.

(Erik Temple) #25

The Public Library lists a new version of Glulx Entry Points for download, but there is actually no version of GEP in the library payloads directories. This isn’t particularly important, since the new version is included in Inform, but should you delete the built-in one somehow, it is a bit misleading.

#26

Im on mac osx, and i just went from 6 to 7, and i have a major problem… no documentation… whilst in the extension tab, clicking on any extension does nothing. the public library tab has the list of extensions as well, with no way to get to the documentation. I have to navigate to the inform webpage and read the documentation there, which is just…super inconvenient for everyone. worst part is, all built in documentation isn’t even available on the site… i know this is open source, so getting this fixed will probably be difficult, however, maybe there is a new setting im unaware of? i think its highly unlikely that there could have been this big an oversight. anyone?

#27

See this thread.

#28

Ah thanks juhana, you make using inform even easier then it already is!

#29

hi,

i’m a complete newb but i’m finding all the documentation in the new inform7 to be really detailed and easy to follow.

but i would request that the extension pages on the inform 7 site put a prominent caveat that a lot of the extensions listed on that site is currently incompatible with the current version of inform 7.

i finally found the reason for the compile failures while googling and finding this site but it cost me a lot of frustrating hours where i was wondering if i was doing something wrong. and especially since those extensions are on the home page, some kind of warning should be prominently featured there… or even better, to have a separate page for extensions that are known to work with the latest version.

(Daniel Stelzer) #30

Hi Kindlecrasher,

There actually is a new site for 6L02-compatible extensions, called the Public Library. The plan is to eventually connect to this site from within the Inform 7 program itself and allow users to download extensions that way, but that feature is still Mac-only for now.

You can also find many experimental versions of extensions at the I7 Github. Unfortunately the device I’m on now will not let me copy and paste, so I can’t post the links, but they should be in the other sticky thread.

EDIT: I imagine the Public Library will be mentioned in the documentation as well once it’s available for all platforms. Right now you can download the extensions without using the IDE if you’re on Windows or Linux, the link should be in the other thread as well.

(matt w) #31

The built-in extensions don’t seem to have their own threads so I’ll put my question about Complex Listing here:

How do you use “invert scored list”? Obviously it puts the list in reverse order but when should it be invoked? It seems that “invert scored list; say prepared list” doesn’t give you a reversed list because “say prepared list” calls “dump list” which runs the list arranging activity which sorts the Table of Scored Listing in non-inverted order.

(Peter Piers) #32

I think this falls under “General Discussion”…

Does anyone remember iXu? It would download and install every extension and/or updates from the site.

ixu.zenfactor.org/

I take it, since it will all migrate to the public thingamajig, this application is now obsolete and should not be used, yes? I believe it “connects” to the I7 website EXTENSIONS page.

Of course, if the public library is mirrored bu the extensions page in the i7 website, iXu will still work as normal.

#33

I have a problem when running the Patrollers extension by Michael Callaghan. There are 2 lines in the extension that Inform 7 keeps throwing up - To depart is a verb. To come is a verb. Inform 7 tells me that this appears to say two things at the same time. As I’m new to IF writing I would be really grateful for some help in resolving this issue. Apologies of this isn’t the right forum for this type of question.

(Jim Aikin) #34

This post from kindlecrasher was back in June. There is STILL no indication on the inform7 site extensions page that the material there is for the most part outdated/incompatible.

I will refrain from saying what I think about this, except to quote Adlai Stevenson: “I’m underwhelmed.”

#35

Just tried to update the installed extensions in Inform (1.52/6.33/6L38), and see peculiar behavior, to say the least:

  • The yellow button at the bottom of the Public Library tab of the Extensions section is labeled “Download 91 Extensions.” When I click that and 91 extensions putatively download (I7 reports that they did successfully), the yellow button continues to have the same label, and clicking it again appears to download and install the same 91 extensions – leaving the button label again unchanged. Each time these install, the number of Extensions to be updated (see below) increments by the number of newly installed extensions.
  • The blue button just below the yellow button states “Update 420 Extensions.” Clicking that supposedly updates the extensions, but two problems: 1) The number of extensions that need updating increases instead of decreasing (now up to 1147, bizarrely); and 2) A high number of “updates” fail with 404 errors (105 of 315 failed, in one attempt). Where are all these extensions coming from? Surely these numbers are bogus.

All this leaves me quite unclear as to the status and integrity of the extensions installed in my copy of I7. Does this indicate some major bugs in the I7 app? Are there major bugs in the Public Library?

Since this appears to be thoroughly broken, why has no one else reported this (as far as I can see)? Am I doing something wrong and the app and public library are OK?

Thanks in advance for any explanations.

(Daniel Stelzer) #36

That definitely sounds like a bug. Could you look at the version of one of the installed extensions (in the Extensions menu option at the top) and check whether it’s the same as the version it’s trying to install? (In other words, is it not recognizing that it currently has the latest versions, or is it failing to download them?) What operating system are you on?

#37

I’m pretty sure these bugs have been reported before. But if in doubt you can report it again.

#38

Not entirely clear what to check against what. But perhaps that’s moot, as the mystery deepens: Today when I booted up I7, the Public Library tab now reports that all extensions are now downloaded (the yellow button is now white and disabled), while the Update button lists only 1 extension to be updated – not the over 1000 last night – and that extension fails to update because of a 404 error. Between these forum reports, I did nothing other than allow time to pass and restart I7. So perhaps whatever bug there is is just in the UI code while the extension downloads/updates are taking place. Very weird.

Mac OSX 10.9.4.

I don’t see any bug exactly like this in Mantis, certainly not for the OSX version of I7. But there was this closed Gnome bug http://inform7.com/mantis/view.php?id=1612 that may or may not be relevant. I haven’t yet submitted a new bug given with the magical apparent resolution of the issue.

#39

I’m having a compiler error when I use the example of “version 3/150414 of Hypothetical Questions by Jesse McGrew”. The sample code being named “A Sense of Adventure” seems to generate invalid i6 code that fails on Inform 7 build 6M62.

If you comment out the part:

Report going:
	hypothetically take everything and consider the player's fate rulebook;
	if the outcome of the rulebook is:
		-- the player dies outcome: say "You sense an ominous presence. Better be careful picking things up in here!";
		-- the player wins outcome: say "You sense your victory is at hand!";
		-- the player scores outcome: say "You sense a potential profit. Better grab everything you can!".

The compiler doesn’t fail. Any idea how to fix this?

(Daniel Stelzer) #40

What’s the exact error message from the compiler? It should be in the Console tab.