I am working my way through Aaron Reed’s fine book “Creating Interactive Fiction with Inform 7”. I have just reached a part where, when I compile, the results message displays this message only: “>font siz”. When I switch to the Console tab from the Report tab under Results, I see this:

Can anyone tell me what is happening here? The phrase that seems to be the issue is: Instead of smoking during a dramatic scene: say “This really isn’t the time for that, man.”
When I remove it, everything appears to be hunky dory. Any help would be appreciated. Thanks in advance.

An “abject failure” error means you’ve stumbled over a compiler bug.

In this case, it’s a known bug:

To work around this, you can rephrase this as

Instead of smoking when a dramatic scene is happening: say "This really isn't the time for that, man."

Thank you so much, zarf. That worked perfectly. I really appreciate your help.

Ok, a new issue that I cannot seem to find the answer to. This is the message I get when I try to compile:

Google tells me that this often comes up when the sourse text contains a semi-colon where there should be a regular colon in an if statement. For me, it seems to happen when I add this line of code:

after, of course, downloading and installing this extension. When I remove this line of code, it compiles normally. Any solutions to this?

Thanks in advance.

Ok, I tried reinstalling Inform and got the same result. I also tried just copy/pasting the source code for the extension into the source code for Sand-dancer and received the same result.

I know that there have been changes to Inform since Sand-dancer was written… perhaps that is causing the problem.