Disallowing UNDO selectively for only a few commands

Well, maybe not. I found Inform, but this is what it has:

No directories.

I can find Inform projects, but they don’t show me any directories. Is there a way to find the directories from the same kind of information as is in the screenshot above?

That takes me the same place as Finder does, unfortunately.

This is about where I start to think that tackling each of the many, many, many error messages in a copy/paste is better.

Hmm. I found a thread here that suggests the Inform IDE might have a File > Open Extensions Folder menu item?

1 Like

The problem here is that I don’t know how to give advice about finding something on a Mac. The I7 community is Mac-user-heavy and someone will be along who can help. Everything else should be not bad, I promise.

Edited: It’s also, by the way, completely possible (given my state if ignorance) that for some execrable reason, Mac OS is preventing you from seeing directories that are there. But, again, someone with a Mac clue should be along…

I found this:

Does that look right?

It does, and it opens this:

Is any of that promising?

Note: I am called to attend to my mother. I will return when she calms down. Thanks to everyone so far.

1 Like

The former looks like a 10.1 installation.

The directory above Documentation, Extensions, Telemetry in the latter should be the “Inform” directory we’ve been looking for. The .inform and .materials directories should be alongside them.

My directions should work if you forget about trying to use “I Love Extensions.materials/Extensions” and use the Extensions dir in your screenshot instead (the one alongside “Documentation” and “Telemetry”, not the one under “Documentation”. Extension files under this “Extensions” directory will be accessible to all your projects. Ones under the materials directory’s “Extensions” directory would only be accessible to that one project. (I thought that would be simpler…)


  1. Double-click the (inner) extensions folder.
  2. Right-click and select “New Folder”.
  3. Rename the new folder as the name of the author of your extension.
  4. Double-click that folder.
  5. Put the extension file in the folder.

If you need one of those steps expanded, just ask.

1 Like

On the topic of installing an extension in general (Mac guy here) it’s easy IF you’ve got the extension file and it has the right suffix (.i7x). Reading this topic, I’m not sure that ever came up.

So @AmandaB , separate from @rileypb 's advice rounding out the path you were already on – I just want to try to take you back to getting the extension and installing it. It’s low maintenance compared to the path you’re on. It also won’t interfere with the path you’re on if you do both. But with my way, you should end up with the extension available to all your projects, as opposed to just having a copy in the current project:


I see the extension’s on github at this link.

So you go to that page. Then you want to download the file – no copy-pasting! On the top-right of the screen, you’ll see some buttons like this:


Click the ‘download’ button, two to the right of Raw. Pay attention to where on your computer you save it (for this reason, Desktop or Downloads are good options. Easy to find.)

In the Finder, go to where the file is and double-click it.
It should open in Inform, on the nice yellow sheet that tells you it’s an extension, and at the top of the sheet you’ll see an alert saying something like ‘This extension isn’t installed in Inform yet. Do you want to install it?’ Click yes/install.

Now quit Inform, reopen Inform, and you’ve got the extension.

With Inform open, confirm by going to the menu File → Open Installed Extension → Erik Temple → Undo Output Control

Let me know if this series of actions produces this result, because if it does, it shows that you are able to install extensions in general.

Additional pro tip for you:


Right below that ‘Open Installed Extension’ option in the File menu is another saying ‘Show Installed Extensions Folder.’ Choosing that will jump you, in the Finder, right to the installation location of your global extension collection in the Finder. This is in your Library folder, which for you (euphemism:) being a user of the nature you have continuously described as being, and as per @Zed’s fears, is probably hidden in general. So even though a Finder search cannot bring up contents of that folder from a cold start, if you ever want to get to it, you can use that option in Inform.

You can make the Library folder permanently visible/searchable but I’ll only add that if you want/care :slight_smile: I doubt it’s affecting your life much or at all.



umm… I don’t see such a button, in multiple browsers checked. any chance you have a browser extension in play you may have forgotten?


Dementia crisis averted!

Details of dementia crisis

Apparently, it causes panic and chaos when we are going to do more than one thing tomorrow, because how can that be? The fix is easier than downloading an extension: just don’t tell her about plans ahead of time anymore.

Also in country news that kept me away:

was waylaid by a very large armadillo trying to dig under our fence and had to fill the emerging hole with big rocks.

Back to the topic at hand: I don’t see that button either, or I would have tried it sooner. I may be computer illiterate, but I do know a download button when I see one, and I’m very proud of that. Could it be hidden somewhere else?


Okay, I think I know what it is. I’m logged into github. Didn’t even realise I was, as I’m not a heavy user.

What’s amusing about your comment was that I WAS SURPRISED (but pleased) to find a download button! I always recalled getting the raw file off a github page to be a total pain in the posterior that I could never remember how to do.

And maybe if you’re not a user there, it still is… how do you do it?


1 Like

Try right-clicking on Raw and selecting Download Linked File As on Safari.

Edit: You might end up with “Undo Output Control.i7x.txt” as the filename, just rename it in Finder by removing .txt part at the end.


So follow my advice about selecting the “raw” button, but then save the file anywhere you’ll be able to find it, like your Downloads directory. Then follow Wade’s advice about going there and double-clicking it.

Well, the workaround does go back to ye olde ‘copy and paste’ that I trumpeted we would avoid, but it still gets you the right file after a few more steps :roll_eyes: Bear with me.

EDIT - yeah we got some other input in the meantime. If Timur’s advice works, it’ll jump you ahead. Otherwise - >


On the github page, you can click the RAW button, then copy the whole text content, then open a text file program on your Mac to paste into.

You can use the Mac’s default TextEdit. Open the app, open a blank document if it hasn’t already opened one. Choose the menu option Format → Make Plain Text … if that menu option actually says ‘Make Rich Text’, you’re already in plain text and can ignore it.

Now, paste that copied extension text into the blank file. Now File-> Save or press Command-S.

This is the important bit. When it asks for the filename, delete the entire name it suggests, including the file suffix. Type in Undo Output Control.i7x

It will say ‘DO YOU REALLY WANNA GO WITH THAT WACKY FILE SUFFIX?’… and you say ‘yes’. And note where you saved the file. Don’t save in the cloud - TextEdit loves doing that.

Finally, you will have the file Undo Output Control.i7x that you can doubleclick to install as per my initial post.


1 Like


Yet they are not. The parent file is “Inform”, with neither of those things near it, and the screenshot shows everything under Inform.

It won’t allow me to save it with that file name. It adds .txt to the end no matter what. I keep trying to delete it, and it just comes back.

Y’know, any one of you can bow out at any time, no hard feelings at all. I appreciate all the time you’ve all taken and I’m starting to feel badly about it, so nobody should feel even remotely obligated to keep rolling with my tech shitshow.

we’re close. Forget finding the .inform and .materials directories; use the Extensions folder that is a sibling to the Telemetry folder. There’s still no need to resort to copy-paste.

In that Extensions folder, create “David A Wheeler”. Then go to Dice by David A Wheeler (different link than I gave before; before I gave the raw version.) Follow Timur’s advice and right-click the raw button. You should see something like “save link as”. select “save link as” and save it to the “David A Wheeler” folder.

1 Like

Safari won’t allow to save it without .txt extension it seems, that is why you have to do it after you saved the file, in the Finder.


I’m now in bloody-minded ‘I’m going to get this solution through if it kills me!’ mode. I will regard success as a personal triumph. Since I like personal triumph, I’m going to continue, but overall I will wait for Zed’s solution to get resolved one way or another.

Are you 100% sure? First, you deleted everything it presented to you, including the suffix .txt. You have an empty text panel. You type in Undo Output Control.i7x and press save. And then you don’t get a window appear asking for any confirmation, it just snaps back?

I have to make sure I’m not at cross purposes with Timur. He’s referring to renaming the file while saving it directly from github’s Raw page with Safari. My directions about renaming the file were for the alternate copy-paste solution, after you’d jumped through the hoops of pasting into TextEdit, etc.

If Timur’s way lets you save the file to your desktop, yes, just save the file first, then rename it on the desktop. Don’t try to rename it in the process of downloading from Safari.



Actually no. Safari doesn’t seem to like to save it directly without .txt extension, if it doesn’t recognize the file extension or something. I was recommending renaming the file after Safari saved it with .txt extension, from the Finder.

1 Like

OK-- I had to move the Inform file to my desktop so I could find it again, which I hope doesn’t screw anything up. But that is done and I can see it in that file on my desktop. But trying to get it in a test project says that it can’t find it, and now when I click the “Show Installed Extensions” folder, nothing happens. At all.

I’m not sure what you mean by “the Inform file”. If you mean the Inform directory that is above Extensions, Documentation, Telemetry, then I would very much expect moving it to majorly screw things up.