Disabling text highlighting in Glulxe

When I’m playing games with Glulxe, I tend to change the background colour to black and the text colour to white (because I find the black on white colour scheme kinda glaring), but I’ve noticed when I do that I end up with certain words being highlighted very messily, as per the attached screenshot. I’ve looked for an option to disable text highlighting but there doesn’t seem to be one (or there is one and I’m just missing it somehow). Is there a way of turning off the highlighting?
Glulxe.jpg

It’s not really highlighting words - there’s nothing in Glulxe that would do anything like that. What looks to be happening is that the affected words are being printed in a different Glulx style (the room headings are automatically a different style, and I guess your game code is printing out certain words in a different style too?), and you’ve probably configured Windows Glulxe as white text on black for the “normal” style only, with the others left as black on white.

What you need to do is from the options dialog set the colours for all the styles to white-on-black, not just the “normal” style, which should fix it. This makes me think that Windows Glulxe’s style options really need sorting out, and ideally being made a lot simpler.

I’ve just realized that the advice I gave you won’t quite work - since by default Inform 7 produces game files that modify some of the Glulx styles, you can’t then change the styles in Windows Glulxe’s options dialog. Dammit, that’s very annoying.

Attached is a hack to fix this - download the attached file, rename it to “reversed.reg” and double click on it - this will apply the correct settings for Windows Glulxe to have white-on-black text. I will also make a note to finally get round to rewriting the options dialog to a) let you modify all the styles, regardless of what the game does, and b) have some quick way to set the text and background colours for all styles.
reversed.reg.txt (2.98 KB)

Actually, I managed to get it working. I just went into styles and changed everything to black background and white text and the display is now fine. I haven’t played through the whole game yet but everything so far looks okay.

I see the REAL problem. You play WoW!!! :angry:
Glulxe.jpg

Guilty as charged. I was once a proud WoWer, then they added pandas to the game and tuned down the difficulty so far that a toddler with a keyboard could clear all the content with ease. I still play it but I’m no longer proud.

That’s rich coming from a Baldur’s Gate addict :laughing:

omg you just outed me as a DnD nerd!!! (grabs the mountain dew and runs for mom’s basement)

On one hand - ha! MTW got pwned!

On the other - but Baldur’s Gate is a damn good game. “Go for the eyes, Boo! Go for the eyes!”

The original screenshot reminds me of a ransom note or coded message.

  • Wade

It made me feel like I was looking at a redacted government file with my special see-through-censor-bars vision.