Difficulty with Installing FrobTADS on Mac OSX


I’ve downloaded FrobTADS 1.2.2 and gone through the installation process as per normal. However, when it finishes, I cannot find any new files. I’ve tried to find the directories it talks about with no luck, and I’ve searched the entire disk for the filenames of the supposed installs.

The only thing I notice that seems possibly weird is that, when I go to install, it skips “Destination Select,” moving straight to “Installation Type,” and all the items it says it will be installing (TADS Compilers 2 and 3) have “upgrade” in the action field. But I really don’t know what to do about it.

Any help would be greatly appreciated…

Thanks in advance!

FrobTADS is a set of command line tools and is therefore installed into the “/usr/local” directory tree. Since it always needs to be installed there, a destination selection doesn’t make sense, which is why it’s skipped.

The “/usr” directory (along with quite a few other Unix directories) is never shown in Finder, so you can’t browse to it by default. However, you can manually instruct Finder to go there, by pressing Command+Shift+G, or by selecting “Go->Go to Folder…”, and in the dialog that appears, enter “/usr/local”. The FrobTADS executables (tadsc, t3make and frob) are in “/usr/local/bin” and the various data files in “/usr/local/share/frobtads”. Once you’ve instructed Finder to go to “/usr/local”, you can browse to all these subdirectories normally.

Oh dear… OK, well that worked. I’m afraid I’m no longer competent with command line interfaces like this. I guess I’ll just have to see about borrowing someone’s PC… Shouldn’t be too hard to do.


FWIW, there’s a section in the Quick Start Guide (which I think will have been installed with your T3 docs) that gives some guidance on how to manage the process on the Mac.

If you give it a try and find that it’s confusing, please let us know. The steps in that section worked for me, but your system might differ from the one I was using.