Curses broken in Zoom 1.1.5


all of a sudden, without me making any changes, Zoom freezes every time I play Curses on my Mac. Using 10.7.2. It used to work fine before. When I set the preferences to display warnings, I get stuff like

[ Warning: Object 0 has no siblings (PC=#280fd) ][ Warning: Object 0 has no siblings (PC=#28113) ]

right from the beginning of the game. I had a script running when it happened, turned it off, no avail.

If anyone has any idea, much appreciated! Restarting the game now under Spatterlight, seems to work.

sadly, spatterlight doesn’t display the maze correctly, but as i already went through that part, ok…

I don’t have any trouble (Zoom 1.1.5, OSX 10.7.3).

thanks. Do you have any idea what those warnings refer to?

FYI, Gargoyle is a much better alternative than Spatterlight; the latter hasn’t been updated in years.

thanks, I’ll just have to get my head around it, then. I was a bit put off by the fact that I had to write in a configuration file to change fonts etc., but I guess there are worse things. In fact, as a person who dabbles in Inform7, the handling of a text editor wouldn’t be too much to ask for, right :wink:

My first guess is that Zoom is reading a corrupted game file, somehow. Maybe the cached copy in “~/Documents/Interactive Fiction”?

I have now deleted the cached copy and set the preferences so Zoom does not organise the games by itself. Then opened a fresh curses.z5 from my desktop. I still get the warnings, but the game does not seem to freeze after a couple of turns, and I could restore my old savegame. I’ll have to try if I can reproduce the freeze by turning the organising back on. Will report back.

Okay. The freeze and the warnings are probably separate issues. I have some vague memory that Curses really does some illegal object access. (Dannii, were you the one who noticed this?)

Just for the record: The freeze did not break Zoom completely, i just couldn’t enter commands at the prompt anymore. Ic could close the game and open it anew.

Zarf: Wasn’t me. Nor have I found Curses to be problematic with my ZVM, and I haven’t got any fixes for illegal access either.

Woah! This just happened to me the other day as well.

Latest Zoom on my OSX 10.7.3. I’d been playing games fine for a week or so, then suddenly I found a newly downloaded one (Adam Cadre’s 905) kept beeping at me. Thought maybe it was incompatible or corrupted, so switched to Gargoyle in Windows for that one. Carried on playing other games OK.

Then I played through Fail Safe for an hour or so, at which point it suddenly started the beeping too - i.e. any command I typed resulted in a beep, and nothing registering. I tried deleting all copies of the .z5 file, and deleting the auto save, but it would happen on every new play. Specifically, it would allow one command at the start of the game, and then immediately stop registering any other commands.

I thought maybe a reboot would solve it, and did so but didn’t play any more games for a couple of days. Today I just loaded Fail Safe in Zoom and so far it’s working OK. … no, edit, it’s failing again, I got a few moves out of it this time, but now it’s jammed again.

When it jams, I can’t type anything. But if I open the Skein window, I can repeat commands by double-clicking on them. And all menu options work; I can restart the game etc. But I can’t type anything in the window and each attempt is greeted with a beep (after a little while, anyway - probably when some buffer is filled.)

The fact that it happened to both of us around the same time suggests it must be something triggered by an OSX update I guess, one we both applied? Can’t be any other explanation for it happening to two people around the same time independently.

I didn’t know about the Warnings option, I’ve turned that on now. But I’m not seeing any warnings anywhere. Where are those warnings being output for you?

I just tried opening it from the terminal, and this is the output I see - note that the “Attempted to scroll to a non-existant Skein” occur only when I Cmd-Tab away from Zoom to look at the terminal; they do not correlate to me trying to do anything in the window.

tomj@local:~ $ /Applications/ 2012-02-25 22:25:50.391 Zoom[2356:1603] = Loading plugins 2012-02-25 22:25:50.393 Zoom[2356:1603] == Not a valid plugin: /Applications/ 2012-02-25 22:25:50.407 Zoom[2356:1603] Leopard Extensions loaded 2012-02-25 22:25:50.409 Zoom[2356:1603] Zoom will next check for plugin updates on 2012-02-28 23:22:34 +0000 2012-02-25 22:25:50.447 Zoom[2356:1603] ... now /Users/tomj/Documents/Interactive Fiction/Z-Code/FailSafe/FailSafe.z5 (ZCODE-1-001218-DDAF) 2012-02-25 22:25:50.621 ZoomServer[2357:707] Server ready 2012-02-25 22:25:50.674 ZoomServer[2357:707] Server connected 2012-02-25 22:26:05.226 Zoom[2356:1603] ZoomSkeinView: Attempt to scroll to nonexistent item 2012-02-25 22:26:17.463 Zoom[2356:1603] ZoomSkeinView: Attempt to scroll to nonexistent item 2012-02-25 22:27:17.652 Zoom[2356:1603] ZoomSkeinView: Attempt to scroll to nonexistent item 2012-02-25 22:27:19.355 Zoom[2356:1603] ZoomSkeinView: Attempt to scroll to nonexistent item 2012-02-25 22:27:38.906 ZoomServer[2374:707] Server ready 2012-02-25 22:27:38.912 ZoomServer[2374:707] Server connected 2012-02-25 22:27:51.873 Zoom[2356:1603] ZoomSkeinView: Attempt to scroll to nonexistent item

Reading back again, I guess my issue could be different to yours. To be clear, this is happening for me now with every game in Zoom. EDIT: Not every game, just Z-Code ones, see last post.

For the first week I used Zoom, it worked great. Now it freezes up either immediately or after a couple of turns, with every game. No settings changes occurred between when it worked and when it didn’t. It literally started happening in the middle of a play session. I have rebooted since it started happening without any effect.

I guess I should now clear out all settings and caches from Zoom and try again.

OK, I cleared out every Zoom config/cache - moving them to new directories so they wouldn’t be picked up. I also moved my entire Interactive Fiction folder out of Documents to someplace else.

I launched a newly downloaded Fail Safe z5 file, causing Zoom to load, and confirmed that my settings were back to new-install.

The game is still totally broken - locking up on turn two.

I should add that the exact symptom of the lock-up is that the window loses focus. So:

  1. I type command 1 as normal, it processes.
  2. I can’t type command 2, and it beeps. I do not see a cursor after the >, as if focus is no longer on that window. Clicking after the prompt to give me a cursor in the usual place and restore focus does not help, still can’t type.
  3. If I right click, or look at the Edit menu, I notice that Paste is greyed out - indicating that text input is no longer supported.

I think the fact that it still locks up after being returned to a completely virgin state confirms that either whatever has borked my Zoom is a system/environment issue outside of Zoom itself, or at least that a problem in Zoom has been triggered by something external to it.

I will raise a bug to the Zoom guy(s). This is really annoying :frowning:

EDIT: Some further testing seems to suggest that it’s all Z-Code games that are broken, but not including Infocom ones?? And not including Lost Pig which is zblorb rather than z5 or z8. So confusing.

Games that lock up within max 3-4 turns (usually 2):
Minster, 905, Slouching to Bedlam, Fail-Safe, Varicella (all z5), Anchorhead, Dreamhold, Make It Good (all z8)

Games that haven’t locked up yet, tested each for at least 15 turns:
Lost Pig (zblorb), Trinity (Infocom z4), Hitch Hikers Guide (Infocom z5), Lock and Key (Glulx), Indigo (TADS).

EDIT 2: And now… it’s working again on those z-code games. I tried loading a save game for Make It Good, and found that worked OK, didn’t lock up. So then I typed restart and found that it continued to work from the beginning of the game. Then I tried closing Zoom and running Make It Good, and then Fail Safe, from the start, and they STILL worked.

Right now I can’t get any game to lock up again, where just minutes agi they would lock up every time without fail. I really can’t understand how loading one save game has made some fix that persists even after closing and re-opening Zoom, but apparently it has.

This is bizarre.

EDIT 3: Played Fail Safe for 15 mins, did maybe 20 turns I guess, then just suddenly locked up again. Restarted, still locked up. Loaded Make It Good, locked up. Tried re-loading the Make It Good save that previously seemed to fix things, that locked up on the second turn after loading.


we’re not alone:

about the warnings in Curses: They appear in and after text outputs.

The attics, full of low beams and awkward angles, begin here in a relatively tidy area which extends north, south and east. The wooden floorboards seem fairly sound, just as well considering how heavy all these teachests are. But the old wiring went years ago, and there’s no electric light.

A hinged trapdoor in the floor stands open, and light streams in from below.
[ Warning: Object 0 has no siblings (PC=#280fd) ][ Warning: Object 0 has no siblings (PC=#28113) ]

Thanks for linking the other thread.

I’ve now emailed the author, Andrew Hunter, and will report back as and when I hear anything.

Andrew got back to me very promptly. He isn’t experiencing the problem.

He did say that those warnings in Curses are harmless and can be ignored; they are not related to this lock-up problem.

He gave me some things to try:

  1. Disable spell checking as you type - this initially caused games to start working for me again, but they quickly broke again and are still broken with spell check disabled. So I tihnk that was a coincidental timing of it starting working again (as has happened before), and not a fix.
  2. Enable always-on scrollbars; didn’t help
  3. He asked if I was running any “Accessibility” programs liked Launchbar. Actually I’m running a whole bunch (Hyperdock, a window manager, and which I just upgraded recently corresponding to the time of the failure. Flexiglass, another window manager. Alfred, which is very much like Launchbar and includes a clipboard manager. Keyremap4Mac in which I remap some keys. And Witch, an alternative application switcher (Cmd-Tab) ) - but I tried disabling them all, and also tried disabling “Allow access to assistive devices” in System Preferences - which is required for a number of those programs to work - and that didn’t help anything.

He has a third suggestion which is much more technical, related to a possible invisible entry window blocking Zoom.

In order to diagnose that I’m going to need to get XCode out and run a debugger against the zoom process. And possibly also build Zoom from source and try debugging that.

I’m going to try all that sometime today and will update back.

In the meantime, I can update my exact problem description (and I’ve sent this to Andrew):

  1. Launch new game of Fail Safe
  2. Hit space a couple of times to get into the game (dismissing the intro texts)
  3. Type command 1 fine.
  4. Can’t type anything for command 2. Try letters, numbers, space bar - they don’t work, but the cursor remains in the right place in the Zoom window, and there is no beeping. Can type any number of chars without beeping, unless I hit Return.
  5. If I hit enter, the cursor disappears from the zoom window. The beeping then starts immediately, and beeps on every char.
  6. Can get the cursor back only by manually clicking with the mouse in the appropriate place in the Zoom window. This stops the beeping, but still doesn’t register text.

So contrary to what I said before, the beeping is not constant, it’s triggered by my hitting enter which also causes the cursor to disappear and seemingly therefore a focus problem.

Ooh, and one other development. The arrow keys work! So I can hit up arrow and it shows command 1, the one command I could type before it locked up. I can then left-arrow and right-arrow through that command. But I can’t edit it (all characters I type being ignored as usual), and I can’t submit it (hitting return causing the symptoms described above - loss of cursor/focus, beeping on subsequent character entry.) The only other key that seems to do anything is shift - shift+arrow keys causes the text to be highlighted as normal. I can right-click and copy, but Paste is greyed out as usual.

So this is very weird; arrow keys working but nothing else. It really feels like the game, or OSX, has somehow completely disabled new text entry: this is supported by the fact that the Paste menu is greyed out, as if I’m not even in an entry field.