Can't release anything except when Blorb is enabled in Inform 7

This is in Inform 7.

I’m on Crostini. I am using the CLI-only interface because Wheezy is too outdated for the package to install - some aren’t available anymore.

Whenever I try to release my games, only blorb files (if enabled) get released. No matter whether i’m using z8 or glulx. They…just don’t appear. They succeed - indeed,

Release Succeeded. Output is in:

And I know it doesn’t exist:

❯ ls /home/thetechrobo/Tim.materials/Release/story.zblorb
ls: cannot access '/home/thetechrobo/Tim.materials/Release/story.zblorb': No such file or directory

But enabling Blorb fixes this. I seriously don’t understand this. And the most annoying part is, no matter what it seems to want to keep doing zblorb no matter what.

I don’t understand how to fix this. Keep in mind, I just started Inform 7.

You’ll probably need to specify your full command lines to the various compilers to shed a bit more light on it.

FWIW, when compiling in the Windows IDE, if I deselect the option to create a Blorb file then it pops up a Save dialog to choose where to save the output, and the output goes there and not into the Release folder. Perhaps this means that with the command line compilers you’d have to specify some output path more directly?

Alternatively, after doing a build (regardless of whether it’s a Debug or Release build, so be careful!) you can find the story file by itself in the Project.inform/Build folder.

A safer option would probably be to let it build the Blorb file and then use or another tool to extract the story file from inside it. Or just use the Blorb file as-is – interpreters that don’t understand Blorb are very rare these days.

Oh thank you, I found that!

huh, it doesn’t ask me like that. I’ll try again later. (UPDATE: Still doesn’t ask me that.)

Thank you for your solution! I didn’t see it in the Build folder.

The only issue I’m still having is that the release contains an interpreter (I used a guide on this forum) which is not there in the Build folder.

If you’re using any of the web interpreters, then you should be going the second route: outputting a blorb file and then using and other tools to convert it to a JS file for the interpreter. (This happens mostly automatically with the 6M62 IDE, are you using something outdated? Though currently if your story uses images then that does still require an extra manual conversion step.)

I’m using the, quote unquote, image because the debian package is too old to install.